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Welcome to Studiocode - The Ultimate in Performance Evaluation

This manual will help you find your way around Studiocode. It includes descriptions of the 
features and functions you will use and it assumes you have already seen a demonstration or 
been trained in using Studiocode and therefore have some knowledge base of how it works.
If you are unfamiliar with the Studiocode suite of products, or require more information, please 
contact the Studiocode Business Group by email : support@studiocodegroup.com.

Overview of Studiocode

Using Studiocode is easy – just follow some simple steps and you’ll be on your way.

Here’s a quick guide how the Studiocode process works. You’ll find step by step instructions in 
the following pages.

1. Click on the Studiocode icon    in the dock or on your desktop.
2.  Create a new Code Window. This is the window where you can design your analysis platform 

by creating and editing code buttons to categorize events in the video.
3. Decide which events in the video you want to categorize (code) for future analysis.
4. Create and name Code Buttons for all the events. For example: you may want to code a 
  particular person, a particular action, or each time a specific event occurs in the video. Each  
  button will code specific instances for the actions in the timeline.
5.  Capture (record) the movie to the hard drive and at the same time code the information you 

need using the buttons in the code window.
6.  You now have the movie captured and the information about the movie coded in a timeline. 

The movie and the timeline are linked together and are a chronological record of the 
instances you have coded.

7. Now the movie is captured you can also transcribe the movie directly from within Studio  
  code.  The transcription window will provide you with the ability to populate the timeline  
  with instances based on captured events.
8.  You can now analyze performance according to the information on the timeline. If you want to 

change the information, add to it or delete from it, it’s easy. Studiocode is completely flexible 
to fit your needs.

Welcome to Studiocode – You’ll wonder how you ever did without it!
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Studiocode Set-up Requirements

The minimum recommended computer requirements for Studiocode are:
 Apple Macintosh with a 2.2 Ghz Intel Core Duo or faster
Mac OS X 10.6 (Snow Leopard) or greater
4 GB RAM
Your Hard Disk Drive storage requirements @ 13 GB per hour of video 
Built-in Firewire 800 or greater
QuickTime 7 (or later)

We strongly recommend adding more RAM and hard disk space to any computer using Studio-
code

Current Version of Studiocode

The current version  which this manual relates to is Studiocode Version 4.0.

To check which version of Studiocode you are operating, click on “Studiocode” in the Main Menu. The 
!rst item in the drop down menu “About Studiocode n.nn.nn” displays the Studiocode version you 
have.
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Registration of Studiocode

Before You Start Using Studiocode

Studiocode will only run if you have either inserted a dongle (software 
protection key) or registered an online code over the internet. 

Make sure you close all other applications while you’re using  
Studiocode.

When you launch Studiocode for the first time, you will see the following dialogue box.

Choose online to register online or dongle to use the dongle registration method.

Online Registration

If you select to register online you will then be presented with a registration process dialogue 
box. You must have your computer connected to the internet before you do this.

The registration code that you received with the software should be put into the registration 
code box of the window. If you input the code correctly you will see a red tick at the end of the 
text box.

Clicking will connect your computer to the Sportstec internet registration 

server and carry out the registration process.

Successful registration is indicated by: 
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Dongle Registration

Please connect your dongle to a USB port on your computer. Select dongle registration and you 
will then be presented with a registration process dialogue box.

The registration code that you received 
with the software should be put into the 
registration code line.

Clicking will complete the 
registration process.

Successful registration is indicated by: 

Change the Registration Mode

1.  Select the Studiocode application menu on the top left of the main menu bar, then “Change 
Registration Code”...

2.  If you inadvertently select the incorrect registration method, you can change this during the 
launching process by holding down the ESC key when clicking on the icon.

Choosing Language

There are two options that can be used to run Studiocode on a non-English operating system. 
Method 1 is probably the easiest to implement and allows you to temporarily switch languages 
(see next page).

If this temporary method is not satisfactory, the second method is more permanent. This more 
permanent method would mean that you could have specific local language or English versions. 
To run in English, you would start the English version and it would use English irrespective of 
the operating system.

Please note: We will use Japanese examples to outline the steps required to choose your 
language options.
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Forcing Studiocode to run in English 
irrespective of the Operating System (OS).

1. Make a copy of Studiocode and rename  
    it to distinguish it from the original. In this 
example, it has been appended with ‘(Eng)’.

2.  Hold down the control key and click on 
the duplicated version, and select ‘Show 
Package Contents’.

3.  Click the list view so that it is easier to see 
the contents.

4. Expand the view until you see something 
like this
5.  The folders ending in ‘.lproj’ define the 

language preferences. You can see that 
this version of Studiocode is set up to 

handle 5 different languages. (Australian 
English.lproj is used for testing.) 
Studiocode uses this list to try to match 
the language used in the international 
language preferences. 

If all but the ‘English.lproj’ folder is renamed 
(or removed) then Studiocode should boot 
in English irrespective of the operating 
system. Our recommendation is that you 
place an ‘x’ in front of the languages that 
you don’t want so that the operating 
system does not recognize them.

For Example: Running Studiocode in 
English on a Japanese Operating System.

1.  Quit Studiocode if it is running.
2. Go to System Preferences.
3.  Choose International in the personal 

settings area.
4.  Click the language tab. Your preferences 

should look like this if you are running a 
Japanese operating system.

5. Drag English to the top position.
6.  Start Studiocode. It should start in 

English.
7.  When the session is finished, the user 

should reset the order of languages 
found prior to changing them in the 
steps described above.

Please note: This order can affect the 
operating system if the user logs out or 
reboots. For example, if the order in step 
5 was used, and the user logged out and 
logged in again, or rebooted the system, 
the operating system would run in English.

21
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Studiocode Preferences
The Preferences windows provides you with a series of settings for Studiocode.

Here’s an index of the function settings with an explanation of the speci!c setting options.
General :

When Auto save Timeline data is selected, any opened timeline will be saved automatically as the 
timeline is updated.

By selecting the Auto load !les option, any !les that are open when Studiocode is quit, they will 
be reopened on the next launch of Studiocode. We recommend doing this on match day. Turn this 
option on, open all the windows that will be used such as code windows, matrices and statistical 
windows, then quit Studiocode. The next time you launch, they open again in the last used positions.

Open timelines with playhead set start moves the playhead to the beginning of the movie if the 
timeline is not in the opened recent list. If the timeline is in the open recent list, then the last 
playhead location is set.

Capture

• Quick Recording Folder - This is the default folder where the capture package will be saved 
automatically when the Quickstart capture feature is used

• Use timecode produced from capturing device - Timecode generated from the capture device 
will be saved in the timeline timecode track.

• Close window when recording stopped - When this option is selected, the capture window 
will be closed when capture has been ended.

• Equalize video and sound tracks when capturing - This option is used when recording MPEG4 
video in the Standard capture window. It helps with video and audio sycnhronization

• Allow code mode during capture - When selected, code mode can be used in the code 
window to code instances at the location of the playhead in the timeline during capture. Note: 
Remember to switch back to capture mode in the code window to code instances using the 
capture movie window not the timeline movie window.

• Show timeline movie during capture - When selected, the timeline movie window will appear 
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along with the capture window. This is neccessary when using code mode.

• Update timeline regularly during capture - As a means to help reduce graphics processing, 
this option is turned o" by default. When it is enabled, the timeline window updates more 
quickly and travel along displaying a zoomed in section of the timeline. Enabling this option, 
makes constant playback in delay possible.

• Default movie segment duration - During capture, the incoming video is captured in small 
parts. This allows the application to access the !les directly for instance movie creation, timeline 
share, etc. This preference sets the default duration for each movie part. It is recommended that 
longer movie durations are used except when using timeline share.

• Minimum movie segment duration - According to this setting a movie part will never be 
shorter in duration than this time. The smaller the movie parts are, the more !le referencing 
must take place and this slows things down tremendously. This is particularly important for 
timeline sharing as it is readied for access by the timeline share process as quickly as possible. 
When a code button has ended, it signals the capture window to end the current movie part 
that is being captured in order to allow access to the latest captured video part in the timeline. 
So, if the setting if a code button was ended after 5 seconds of a movie part starting and this 
setting is set to 1 minute, it will take another 55 seconds for the movie part to be ended and 
ready for viewing in the timeline. We recommend using 30 seconds for default duration and 15 
seconds for minimum duration settings when using timeline share. Otherwise, use the default 
settings.

Note: Choosing Never and None for the above 2 options will create one movie part for the entire 
duration of the capture session.

Capture type
• Standard capture - If this option is selected, the standard capture window is used through out 

the application. This is there for legacy work#ow purposes only. It is not recommended to use 
this window unless you require speci!c MPEG-4 or other codec compression settings during 
capture. It does have all the features of the Realtime capture window.
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• Realtime capture - The Realtime capture option is the default selection, selecting this 
option will cause the Realtime capture window to be used through out the program. It is the 
recommended option.

Communication
Refer to pages 78 - 84 for detailed instructions for Remote Communications settings
• Name / Description - This sets the computer name that will be displayed in the Remote 

Communications window. Note: Avoid using puncuation characters in the name.  Keep the 
names simple.

• Change Password - This sets the password that allows others to access remote communication 
features over the network.

• Use same password as default for autoconnection to clients - This allows the settings of one 
password for all networked machines. It can greatly simplify the connection process. 

• Allow servers to Start/Stop capture - This option will allow or block start and stop capture 
commands.

• Allow servers to Pause/Resume capturing - This option will allow or block pause and resume 
capture commands.

• Allow servers to update capturing - This option will allow or block capture update commands
• Do not show errors as they occur - When selected, this option will supress the error log from 

appearing if an error is encountered.
Advanced Options
• Do not connect with clients - This option will stop a computer connecting to any clients in the 

Remote communications window. This blocks commands from being sent from the computer 
to other clients.

• Stop servers connecting to this computer - This option will block servers from accessing the 
computer.

• Disable automatic connection to clients - When selected, the autoconnection process will not 
take place in the Remote Communications window. The connection process will have to be 
undertaken manually.

• Stop / Disable all communication - This turns on or o" all communications. It is recommended 
that remote communications is turned o" when not using the feature.

Labels
 Show Groups
 Copy all Labels when transfering instances

Edit List
The edit list preference enables or disables live edit list export during capture and coding sessions. 
Either format can be exported singularly or simulatenously. The !le formats are described in length 
in the Export section of this manual.

Choose the target !le directory by clicking the popup menu below the Directory for timeline text.  
The default is the capture package and generally this option should always be used.  Only change 
this setting if these data !les will be used in an alternate work#ow like for updating a web site or 
something. We recommend always using the XML format.

Note: Another added bene!t of enabling these options, is they provide another form of backup for 
the timeline data.
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Update timeline share edit list every X seconds - Use this option to increase or decrease the 
frequency of which the edit list is updated. This applies to both exports and helps with timing when 
scripting is used to pick up the data from the !le. NOTE: Be careful not to set this number too low, in 
some situations trying to update a !le too quickly will actually take the process longer overall and 
can also interrupt other processes.

Overlay Text

Movie Overlay Text

The overlay text preferences can be set live, so we recommend opening a movie with overlay text, 
then make changes to the preferences. This will save some time getting the settings perfect.
Overlay text font size is set by inputting the desired font size in the text box.
Showing or hiding components of overlay text is done by ticking the boxes next to each component.
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Changing colors of overlay text components is done by clicking on the color well below the 
component and choosing a color.

Background and Text overlay opacity of the overlay text can be set by dragging the slider or 
manually inputting an opacity value. The lower the value, the more invisible the background will be. 
The background opacity sets the opacity for the background of the text that is displayed where the 
text overlay opacity sets the opacity for the overall text display of all components.

Vertical text position is changed by moving the slider. The text can be moved to the absolute top and 
bottom boundaries of the movie frame.

Full Screen Time Display

When “Time displayed while presenting full screen” is selected, a time counter will be shown in a 
#oating window over the movie. The #oating window position can be changed by clicking and 
dragging on the window.

Display whole seconds removes the hundredths place from the counter. This makes the window less 
wide hiding the higher precision data.

There are 3 time display options:
1. Movie time displays the actual movie time from 00:00:00.00 to its end as it relates to its total play 
length.
2. Relative movie time displays the time for which the instances are found in a timeline. This is 
convenient for !nding its position in the timeline. When this is selected, the time display is not 
continuous, it can appear to jump from 01:03:15 to 00:03:25. This depends on how the movie was 
created.
3. TimeCode displays the timecode track information which is time of day for when the movie was 
captured or for what time the movie timecode was set.
The position can be set manually set by using the vertical and horizontal sliders, however it is easier 
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to present a movie full screen and use the mouse to set the position.
The size of the time text can be changed using the slider or manually inputted.
The background opacity can be set using the slider or manually inputted.
The background can be switched on or o" by ticking the box.
The background color can be set by clicking on the color well and selecting a color.
The foreground opacity slider sets the overall opacity for the time display. This is set by dragging the 
slider or manually inputted a value.

Commando

This preference is used to set up the Commando Remote options. Click on the di"erent drop down 
menus to set the options. See the Commando remote description in this manual for more details.

Apple Remote

This preference is used to set up the Apple Remote options. Click on the di"erent drop down menus 
to set the options. See the Apple Remote description in this manual for more details.

Drawing

• Hide drawings when playing movie at full screen- When selected, this option will hide drawings 
on an instance when the instance movie is presented in full screen.

• Delete full screen drawings when movie starts - This option only works in full screen, when 
selected, drawings that have been drawn on the movie while the movie is paused will be 
deleted when the movie begins to play.

• Pen size - This sets the pen size for the drawing pencil cursor.

Windows

There are times when a lot of windows from various applications might be open at the same time, 
selecting Bring all windows forward when a single window is clicked will make sure that all the open 
Studiocode windows come to the front and will not be obscured by another application’s window.
To make moving timelines and their movies around a little easier, select the Group timeline and 
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movie windows option. The timeline and its movie window will be locked together and can be 
dragged around together as one. This works great if the Default timeline and movie arrangement 
option is turned on also. To move them independently, hold down SHIFT and click and drag on the 
window to reposition it.

The Edit instance window for sorter options are:
1. Standard. While this option is selected, the edit instance movie will play through once unless 
movie looping is turned on and remain in the current row of the sorter.
2. Go to next instance. While this option is selected, the edit instance movie will play through to the 
end, then the sorter window will drop down a row from the current selected row and the movie for 
the new row will be paused at the start.
3. Go to next instance and play. While this option is selected, the edit instance movie will play 
through to the end, then the sorter window will drop down a row from the current selected row and 
the movie for the new row will be start to play automatically.
Maximum number of instance movies value set how many instance movies can be open at one time. 
Once the maximum is reached the oldest movie made will be closed to allow the new one to be 
created.

While working with Studiocode, windows get pushed all over the place especially timelines, to 
help create some consistency in where a timeline will open select Default timeline and movie 
arrangement. This option sets the timeline movie in the upper left corner of the screen and does a 
best e"ort to maximize the timeline window to display the most data that it can on the screen.
When using the statistical live during coding, it is very desirable to have this option selected. As 
changes in the timeline are made, this triggers the statistical window to automatically execute. While 
building and testing a statistical window having this option turned on can be bothersome, so we 
recommend turning it o" for those occasions. This will save a little time by not throwing up errors 
every time a change is made.

Movies
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• Auto play movies created - When an instance is created from any source, it will open and begin 
to paly.

• Adjust resolution for full screen movies - This option reduces the screen resolution when 
presenting movies full screen.  It can help smooth out playback when viewing movies full 
screen, particularly on older computers. This is helpful when presenting H.264 compressed 
movies. Note: the screen go through a black transition period when a movie is presented, this 
is normal.

Full screen movies
• Use single !eld - Only one !eld is shown of an interlaced movie. This helps clean up jagged 

edges when the video is paused.
• Use both !elds - Both !elds are shown of an interlaced movie. Jagged edges maybe present 

when presenting full screen on the computer screen.
• Duration of text movies for instances - This sets the duration of static text movies and titles for 

instance movies created from the timeline, matrix, and movie organizer.
• Limit chapter track text to  “nnnn”  characters - When there are a lot of labels for an instance, 

the instance movie cannot display them in the chapter menu of the instance movie window. 
the chapter menu is removed in this situation. To retain the chapter menu, set an amount of 
text to be displayed in this setting, only that amount of characters will be displayed and the 
rest will be truncated. This allows enough room for the timeline in the instance movie to be 
displayed and used properly.

• Don’t play sound if movie playback speed is greater than “nnn” percent - Setting this option 
helps using the playback speed slider in the main toolbar. In some cases, the default playback 
speed may be greatly increased to allow for faster coding. Cutting out the sound playback 
makes this process smoother.

• Expand or contract audio - Set this option to automatically adjust the length of the audio track 
to match the video track. This can help with audio video synchronization.

• Timeline stack movie lead time when view is switched - The default for this setting is 10, this 
means when one angle of the stack is being played and the view is switched, th playhead will 
jump back 10 seconds, so the new view can be easily replayed without rewinding. This jump 
only occurs when the movie is playing. If the movie is paused, the angles will switch without 
the playhead moving.

• Instance movie plays from previous chapter marker when view is switched - Like the timeline 
stack movie, this causes the playhead to jump back to the start of the instance or chapter. This 
makes replaying another angle easier because the movie does not have to be rewound.

• Multiview hotkeys - Turn on the multiview hotkeys by selecting the check box, then click on 
the boxes next to Movie 1, Movie 2, etc. Choose a hotkey by pressing a key on the keyboard. 
Movie 1 will be the top right angle, Movie 2 will be the next one to the right and so on. If there 
are 4 or more angles, the numbering will #ow from right to left and down. Note: These hotkeys 
will override any other hotkeys in the application, so it is recommended that code windows are 
checked for clashing hotkeys.
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Matrix

• Remove unused movies when web reporting - When the matrix is exporting live, many 
movies are created because the cells are constantly updating during the coding process. 
Enabling this option will clean these movies up during the process. This should remain enabled 
in most situations,  there are a few work#ows where the extra movies are desired thus the 
option.  

• Ignore groups for new matrix - When selected, this option will cause the matrix not to show 
the label groups for the labels.

• Row totals are all instances in timeline row - Select this option to display the row totals as 
number of instances as opposed to displaying the total number of labels.

• New matrix columns sorted by group - By turning this option on, when a matrix is made from 
the timeline or code window, the labels will be sorted by their respective groups.

• 
Web
• Users public website folder - This option sets up the default web sharing folder for a user. It is 

rarely necessary to change this option.
• Computers public website folder - This option sets up the default web sharing folder for the 

system. It is rarely necessary to change this option.
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Studiocode Terms
Many terms in this manual have specific meanings in Studiocode. Here’s a brief explanation of 
the most common terms.

Capture
To record a movie to a file on the hard disk drive.

Code
A category for information in your movie. When you want to mark a piece of action from a 
movie for later reference/analysis you code that as an event with a code button.

Code Button
Code buttons are used to define an event by its name and time when it occurred in a movie. 

Code Matrix
The code matrix is a two dimensional grid representation of code rows and text labels in  a 
timeline.

Code Window
The window for creating and using code buttons to categorize events in a timeline.

Database
A database is a timeline created by exporting selected instances from one or multiple 
timelines. The database process only exports the specified code and movie data. This process 
removes all the unwanted code and movie data and allows you to compile information in 
one file.

Instance
An instance is a coded segment of a movie. An instance becomes part of a timeline for that 
movie (also see Code).

Label
A Label is text inserted into an instance to describe an event or a consequence of an event 
marked by a code button

Lag Time
  Lag time presets a specific length of time to an instance when it is being coded so that it 

creates an instance of a fixed length. Lag time creates a button that only needs to be pressed 
once. The beginning of the instance is marked when the button is pressed down and the end 
is marked when the lag time runs out.  

Lead Time
  Lead time automatically adds a preset time to the beginning of an instance when it is being 

coded. When you click on the code button to code the instance Studiocode marks the timeline 
by the amount of the Lead Time ahead of when the Code button is clicked.

Movie
 The performance you are using as the source of your information.
Package
 A special type of folder that contains timeline and movie data.
Timeline
  The window that displays a timeline showing each instance of all code buttons chronologically 

recorded.
Title Button
  A title button is an inactive rectangle used to title a set of buttons. Title buttons can also be 

graphics in the window that do not perform any actions.
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The Studiocode Main Tool Bar

 

 Open file   Opens saved files.

 Undo Removes the last action.

 Save  Saves the file.

 Capture Opens the capture movie window.

 Volume Selects the speaker volume level.

 Playback rate control  Temporarily sets the playback speed for all movies.

 Loop mode Sets the playback mode for play once or repeat.

  Fast forward/Fast rewind Steps forward or backwards 1 second.

 Play/Pause Plays or pauses the movie.

 Forward/Back Steps forward or backwards 1 frame at a time.

 Present Movie Plays the movie full screen.

 Drawing Tool Bar Opens the drawing tool bar.

 Export to DV Device Export DV format movie to external DV device.
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Keyboard Shortcuts
MENU ITEM -FUNCTION

COMMAND

CONTROL

OPTION

SHIFT

LEFT  RIGHT  UP  DOWN ARROWS

PAGE UP  PAGE  DOWN fn fn

DELETE

CLICK

FILE

Open O

Open all timelines in folder O

Save S

Save as S

Print P

Quit Q

Combine timeline windows L

EDIT

Undo Z

Cut X

Copy C

Paste V

Select all A

Cut movie segment X

Copy movie segment C

Paste movie segment V

Delete movie segment 
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Instance edit E

Instance trim T

Nudge all instances left L

Nudge all instances right R

Moves all instances in the timeline Hold down Z plus   & drag

Moves all instances to the right of the 
playhead in the timeline

Hold down X plus   & drag

Removes unused instance time to the right 
of the playhead

L

Nudge all instances on the right of the play-
head to the right in the timeline

R

Find and replace F

Nudge sound track left L

Nudge sound track right R

Contract sound track L

Expand sound track R

Paste Instances in Movie Organizer V

Delete Drawing Items

Edit Instance Labels

Show Labels Tree E

Find F

Find Text in Transcription Window F

WINDOWS

Present movie (Full screen) M

Make movie M

Full screen coding F

Play backwards J

Stop movie K

Play movie L

Stack instance movies Y
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Overlay movies Y

Reduce movie size < (Use , for <)

Increase movie size (Use , for >)

Reduce transparency 9

Increase transparency 0

Close all instance movies I

Close window W

Hide / Show drawing tool bar D

Quit full screen presentation ESC

Measurement > Line 1

Measurement > Angle 2

ROWS

Add row N

CAPTURE

Open capture window R

Quickstart capture R

Stop capture . (Period / Full stop)

Pause / Resume capture K

MOVIE WINDOW & PLAYBACK

Play / Stop

Play / Stop Space Bar

Slow motion forward play Hold down 

Smooth rewind play Hold down 

Fast forward play (1/10 sec steps)

Fast rewind play (1/10 sec steps)

Faster forward play (1/4 sec steps)

Faster rewind play (1/4 sec steps)

Fastest forward play (1 sec steps)
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Fastest rewind play (1 sec steps)

Turbo forward play (10 sec steps)

Turbo rewind play (10 sec steps)

Play stack movie angle full screen  on movie angle

Move movie angle in stack  & Drag

Select segment of instance movie  & Drag instance movie playhead

TIMELINE WINDOW

Create an instance in selected row  & Drag instance movie playhead

Extend or shorten instance  & Drag on leading or trailing edge 
of instance

Duplicate instance  & Drag from instance to other row

CODE WINDOW

Duplicate button  & Drag from a button

Move selected button

Edit button window, apply button property to 
selected buttons

 on button property text

Move group of buttons  on selected buttons

Move selected button to top layer

Move selected button to bottom layer

Move selected button up 1 layer

Move selected button down 1 layer

Toggle Code/Edit mode  or 

Stop all code buttons TAB

Deactivate last code button pressed ESC

GENERAL

Preferences ,

Hide Studiocode H
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Hide Others H

MAC OS X

Screen snap shot to !le 3

Selection snap shot to !le 3

Screen snap shot to memory 4    V to paste to another window

Selection snap shot to memory 4    V to paste to another window

Enable display zoom 8

Zoom out display -

Zoom in display =
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Part 2  -  Code
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Launch Studiocode

Click on the icon in the Dock or double click on the Studiocode icon on your desktop 
or in the Applications folder.

The Code Window

The code window is the starting point for coding your movies. It will contain all the event 
categories (buttons) you want to analyze. Code buttons are used to categorize and mark the 
time of events in your movie. These events become your own personal study of performance-
specific information. You can save time by coding events as you capture your movie. Then if you 
want to change, add or delete information, it’s easy to go back and do so later.

Create a New Code Window

1.  Choose File > New > Code window 
from the main menu bar.

The Code Window Toolbar

The Code Window Toolbar contains icons which have 4 distinct functions :
1. Coding Functions - (Button ; Enter ; Clear ; Reset)
2. Operating Mode Functions - (Edit ; Code ; Capture ; Label)
3. Display Functions - (Keys ; Links ; Transparency)
4.        Analysis - (Matrix)

Note: In Window Operating Modes, ( 2. above,) you will notice a colored halo around the icons in 
the tool bar to indicate which mode is active.
A convenient shortcut is OPTION+UP ARROW or OPTION+DOWN ARROW to change modes.

Code Window Transparency
This is used mainly while coding in full screen. To increase the transparency of the 
code window, (make the code window MORE transparent - less distinct,) click on the 
Up arrow in the top left hand corner of the window next to the capture button. To 
decrease the transparency of the code window, click on the Down arrow.
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Capture

This will open the capture window so that you can code in real-time.

Code

Use Code mode to code the timeline with your events at any time.

Label

Use Label mode to code labels into instances in an existing timeline. ie. after the 
capture has taken place.

Edit

Use Edit mode to build your Code Window by creating buttons and also to change 
button properties, location, and size. In Edit mode you also link buttons to make 
your coding more efficient.

Matrix

With a Timeline open, clicking this button in the Code Window allows you to quickly 
display a Matrix of selected buttons and Labels.

Enter
Pressing the Enter button while engaged in Code or Capture mode will end all active 
code buttons. The short cut for this is the TAB key. This is a very convenient feature 
while live coding especially when multiple code buttons are active.

Clear
Pressing the Clear button while engaged in Code or Capture mode will depress the last 
code button pressed down, stopping the marking of an instance. The short cut for this 
is the ESC key. This is mostly used when accidently hitting a code button during live 
coding.

Reset

Pressing the Reset button while engaged in Code or Capture mode will remove the last 
instance that was ended. This can also be achieved using keystrokes COMMAND Z.
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Button

Clicking and dragging from this button into the canvas below will create a new code 
button. Holding  down OPTION will create a new text label button.

Keys
Pressing the keys button will reveal all the hotkeys that are set for each button in the Code 
window when “Show keys” option is selected for the button and the hotkeys are not 
visible.

Links
Pressing the links button will reveal all hidden links between buttons. By right clicking on 
this button, you can choose to show or hide all links in the code window. Hiding all the 
links will tidy up the appearance of the code window. 

Code Button History
To see a record of the buttons you’ve used, take 
a look at the history line. The most recent button 
activation is shown to the right of the line. A 
triangle pointing down indicates a code button 

which has been activated. A triangle pointing up indicates that code button having been 
turned off.

Button Information Bar
The Button Information Bar is located directly below the Code Button History line. When you hover 
the cursor over a button, it’s name will be displayed in this bar.

Studiocode Button Types

Code Button 
   Code buttons are identified with a diamond symbol.

·  Name a code button to define an event which will become an instance in the 
timeline. For example, you may name a Code button “Direction” to mark every time 
a direction is given by a participant. 

 ·  When you have captured a movie and used a code button, the button creates a row 
in the left column of the timeline identified by the name assigned to the button.

 ·  The code button identifier symbol, a diamond, will be either red or green. A red 
diamond means it has a toggle action that must be clicked on to start coding an 
instance and click on it again to stop coding. A green diamond means the button has 
a lag time and will stop coding at the predefined lag time after it has been clicked.
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Text Label Button 
Text label buttons are identified with a circle symbol.

   Name a text label button with a description or a consequence of an event marked 
by a code button. This label is inserted into the last opened coded instance on the 
timeline or inserted into all active code buttons. For example, you may name a text 
label button “Good Communication” for a “Student” code button.

 ·  Labels in an instance can be quickly viewed by mousing over an instance in the 
timeline. The text labels will appear above the playhead strip.

Title Button
Title Buttons are identified with a yellow square. 
A title button does not perform any coding action, it is used to put headings, 
comments or graphics within the code window. Clicking on a title button will have 
no coding effect within the timeline, ie. no instance is marked on the timeline, nor is 
there any labeling function when it is clicked.

Graphic Button
 An image can be copied and pasted into the code window. It is called a graphic 
button. By default, a graphic button will be created as a code button. This may 
be changed to a Text Label or Title button. (Refer “Change a Button Function”) 
The identifier of a graphic button appears in the center of the image. Graphic 
buttons cannot be resized in the code window. Graphic or title buttons can be 
replaced by other graphics using the right click drop down menu on the button 
and selecting copy or paste.

Edit Mode

Create/Add New Button

  To create a code button, click and drag the code button icon in the tool bar 
to the blank area below.

Create or Add a New Label Button
To create or add a Label Button to the Code Window, hold down the Option key and click and drag 
the Code Button icon from the Toolbar to the Code Window.

Use A Picture As A Graphic Button

Any image can be used as a button in the code window. COMMAND+ CNTRL 
+SHIFT+3 to copy an image to the clipboard and then COMMAND+V to paste 
the image into the code window.
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Resize a Button

1  Click and drag on any side or corner 
of the button. 

2.  Drag the button to the desired size.

Note: Graphical buttons cannot be resized. 
Make them the required size in your graphics 
program of choice, then copy and paste them 
into the window.

Delete a Button 

Click on the button and press DELETE on the keyboard.

Move a Button

 Click on the button and drag it to the required 
location in the window or use the arrow keys to 
move more precisely.

Note: When using the arrow keys, be sure to 
close the edit button properties window.

Move a Group of Buttons

1.  Press the COMMAND key and select 
the buttons you want to move, or 
click and drag over the group using 
the lasso bounding box to make the 
selections.

2.  Click and drag the buttons to the 
required position while holding 
down the COMMAND key.

 Add a graphic to a code window
1.  A quick way to add a graphic to a code window is to copy (COMMAND+C) from 

any drawing software.
  Using a Mac OS feature, you can select a picture or graphic from anything on 

the screen. Press SHIFT+CONTROL+COMMAND+4 keys, then click and drag 
over the area to be copied. Paste your copied image into the code window 
(COMMAND+V).

2.  To paste an image to an existing button, press the CONTROL key and click on the 
button. From the drop down menu select Paste image. 



30

Duplicate a Button

1.  To duplicate a button and its properties, highlight the button by clicking on it once.
2.   Press the OPTION key and click and drag the duplicate to another location within the 

code window.
3.  Name the new button. All the properties will be the same as the original except for 

the hot key and the linking. Hot keys can only be used once per code window.
4.  To duplicate a button from one code window to another, press the OPTION key and 

click and drag the duplicate to the new window.

Duplicate a Group of Buttons

To duplicate a group of selected buttons from one code window to another, press and hold the 
COMMAND key and click on each button in the group, next press the OPTION+COMMAND key and 
click and drag the group to the new window.

Button Layers

Every button created in the code window is on a separate layer. These layers are not visible, 
but they exist all the same and this architecture can be used to your advantage if required. It is 
sometimes useful to overlap buttons or hide them behind another layer. 

1.  To move a button to the top layer, highlight the button, press CONTROL and the 
RIGHT ARROW key.

2.  To move a button to the bottom layer, highlight the button, press CONTROL and the 
LEFT ARROW key.

3.  To move one layer at a time, press the CONTROL key and press ARROW UP to move 
the layer up 1 level at a time or press the CONTROL key and press ARROW DOWN to 
shift the layer down 1 level at a time.

Alternatively, right click (CONTROL+CLICK) on the button and select the 
action from the drop down menu.

Note: In a Code Window you may select multiple buttons either by using the Apple “lasso” function 
or by holding down the Command key and individually clicking the desired buttons.

Applying Properties to Multiple Buttons
You can apply any property to a group of selected buttons. Select a group of buttons with 
the edit button window open, then right click on the property and select apply to selected 
buttons from the drop down menu. The property will be copied to all the selected buttons. 
All properties can be copied to another button except the hot key and any button links.
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Edit Button window

Edit A Button

1.  In the code window, double click on the 
button you want to edit. This opens the 
Edit Button window. You can also right 
click on the button and select Edit Button 
from the drop down menu.

2.  Change the button properties.

In the Edit Button window any box or  
radio button which can be activated or 
deactivated is refered to as a “property” 
because such action will change the 
property of the button. 

Click OK to commit changes or Cancel 
to close the window and not save the 
changes.

3.  To speed up the editing process, leave 
the Edit Button properties window open 
and click on another button in the Code 
window. This saves the previous button 
properties and switches to the selected 
button. Click OK to commit changes and 
close the window.

Hot Keys
1.  To keep a tidy window, uncheck the show key box next to the hot key text box 

in the button properties window. Then press the keys button in the code 
window to show them.

2.  Use USB peripheral devices such as remote controls or number keypads to make 
use more flexible, especially if you are running a camera and trying to code at 
the same time.
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Change A Button Name

 

Double click on the button you want to 
change. In the Edit Button window, change 
its name in the text box.

Change A Button Color

 Click and drag from the color chip into the 
color palette and select a color. Code rows 
can be sorted by color in the timeline. The 
sorting scheme moves from left to right in 
the palette starting at the top row to the bot-
tom row.

You may color multiple buttons at one time, 
by “Applying properties to multiple buttons”. 
( Refer to the hot tip on page 30 )

Change the Position of a Button Name

1. Click on the points of the text positioning tool.
2. Click in the center box to reset the position to the center of the button.

Change the Text Color of a Button Name

Click on the color chip to the left of Show name and drag into the color palette to 
select the color.

Change the Visibility of a Button Name

Check the Show name check box to display the name of the button. 

Change the Font Size of a Button Name

Select the Size from the drop down menu to set the font size for the name. 

Frame a Button 

Check the Frame button check box to show a black frame around the button.
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Lock a Button Position 
Check the Lock position check box to lock the button in place.

Wrap Button Text
Check the Wrap text check box to wrap the text to the shape of the button.

Display Output
Check the display output check box to display cell information from a 
statistical window.

Change a Button Function

1.  Double click on the button you want to 
change. 

2.  In the Edit Button Window, change the 
selection from code to title or text label.

Populate Rows in Timeline Automatically

 

Check the populate box to automatically 
populate the timeline with code rows upon 
code or capture mode activation.

A code row will be created whether there are 
any instances in the row or not.

Blocking Labels

While coding, you will find that you may want to 
prevent certain labels from inserting into certain 
codes, so the labels do not end up in the wrong 
code. There are two options to help with this.

1.” Block labels unless last down” stops a label 
from inserting into an instance unless it was 
the last code button pressed down, (activated).  
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To effectively use this property, the coding process must be done sequentially to guarantee 
that the label inserts into the correct code.

2.”Block all labels” stops the code button from accepting any text label. The instance will never 
have any labels inserted in it.

Set Lead And Lag Times

You have complete control over the duration of each instance you code. Using lead and 
lag times means you can program code buttons to automatically add a specific time to the 
beginning or end of an instance when the button is pressed.

Lead Time
Lead Time automatically adds a specific time to the beginning of an instance when it is being 
coded. When you click on the code button to code the instance, the specified lead time is 
added to the time from when the button is pressed down.
For example: You are watching a classroom movie and would like to track each time a student 
raises his/her hand. If you assign a five second Lead Time to the “Student” code button, 
the instance will appear on the timeline starting five seconds before the mouse click. This 
guarantees that the event will be in the instance when you review it later.

There are Two Types of Lead Time

• Default lead time applies to all code buttons that you have not programmed with a 
custom lead time. 

• Custom lead time allows you to program a specific lead time to individual buttons.

Program a Default Lead Time

 In the Code Window Toolbar, enter the 
default time you want to use in the “Default 
Lead” box at bottom left.

Program a Custom Lead Time 

1. Open the edit button properties window.
2. Check the custom lead time box and enter the number of seconds of lead time you need. 
Note: If no Custom Lead Time is 
specified, the default lead time will 
apply
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Lag Time

Lag Time automatically adds a specific time to the end of an instance when it is being coded. 
When you click on the code button to code the instance, Studiocode adds the lag time to the 
end of the Instance. For example: You are coding a movie and have a six-second lead time and 
a two-second lag time for a code button named “Clapping”. When you see the person 
“Clapping” and click on the button, the instance in the timeline will be eight seconds.

This becomes a fixed Iength instance and requires that you only click on the button once 
which makes the coding process faster and easier.

Customize a Lag Time 

1.  In the code window double click 
on the code button for which you 
want to set custom lead time. This 
will open the edit button properties 
window.

2.  Check the Lag time box and enter 
the required lag time.

3.  Code Buttons that use a lag time 
have a green diamond identifier.

During coding, if a fixed length instance button is reactivated, the lag time will be reinitialised.

Note : If no lag time is entered, the button will have a toggle action and you must click the button to stop 
coding. Lead and lag times can be set using decimal places to increase frame accurate coding.

Re-activate Lag Time
When this option is ticked, the lag time of the button will be re-activated to extend the length 
of the instance if the button is pressed again before the lag time has expired. This is to make 
provision for more accurate statistical counting of instances when ticked instances are 
extended, so 2 events of the same type will merge into one event. If this is not ticked, an 
activated Code Button which is counting down lag time when clicked on again will stop 
coding the current instance and a new one will be created with the new lag time count down 
intitiated.
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1 Double click on the Code Button in the Code window to open the Edit Button Properties 
window.

2 Set the Lag time for the button and the option will become available

Customized Hot Keys
To speed up your coding, instead of using your mouse to press (activate) your code or label 
buttons, you can assign a hot key to a button. Using hot keys will be considerably faster when 
you are coding, than moving and clicking your mouse or mouse pad.

Assign Hot Keys
1. Click on the Hot Keys box in the edit button properties window.
2.  Press the key or key combination you want to use. Combinations can be configured 

using the modifier keys COMMAND, OPTION, CONTROL, and SHIFT.
3.  Press the modifier keys first, then the character you want to assign.

Note: You can use up to three modifier keys at once plus one character. This allows for over 
one thousand individual hot key combinations. There are some combinations reserved for the 
system, most of these use the COMMAND key.

Change the Hot Key Text Color
1. Click on the color chip next to the Show keys check box and select a color from the palette.

Hide Hot Keys
1. Uncheck the Show keys check box to hide the hot key text in the button.

Capture Mode

When in Capture mode, activating buttons in the Code Window will create instances 
in the Timeline in Current Time. (refer to the de!nition  of Current Time in the Capture 
section of the manual)
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Code Mode

Code Mode will insert instances at the position of the playhead on the timeline. When 
a code button is clicked to start marking an instance in the timeline, the instance will 
start at the playhead if no lead time is set for the button. After the movie is captured and 
available in a timeline, coding can be done by dragging the playhead to any location or 
using the movie transport controls such as fast forward, even the playback speed can be 
set faster in the main toolbar.

During capture, this can be used to code behind the capturing movie, a great option for live coding. 
Instances can be coded very accurately and precisely. There is a small time gap between the capture 
and the timeline movie that cannot be coded during capture. This time gap is roughly 5 seconds.

Coding Instances
a. From a movie already linked to a Timeline
Open a code window and movie, then press the Code mode button and the movie should begin to 
play. When you see an event in your movie that you want to code, click on the relevant code button 
or use your preset hot-key. The button highlights while it is actively marking and, (unless a lag time 
has been speci!ed for the button,) it will need to be clicked again for it to mark the end of the 
Instance.  It will have a red frame if it was the last button closed.

If the button has been customized with a speci!ed lag time, you will see a green bar !ll the button 
until the lag time runs out.

Note : the video must be playing in order for the green bar to activate. ie. If you are coding with the 
movie paused, and click on a button with a lag function, you will not get the green bar.
b. From a movie not linked to a Timeline
Open a new Timeline , File > New > Timeline
Select the movie !le you wish to code/link to the Timeline - Click Open
Answer “YES” to question “Do you wish to place the movie inside a movie package?”
Proceed per (a) above.

Stop Coding
To stop coding your movie, (halt Code mode,) click on the Edit Button in the Code Window Toolbar. 
This will also stop the movie.

Live Coding
Coding can be done during capture, press the capture icon in the code window tool bar 
to start the process. You can code using the mouse or using hot keys. To save time, we 
suggest using hot keys because you can type while watching the performance, whereas if 
you are mousing you will have to look where you are clicking.
Pausing the movie capture during breaks (such as advertisement breaks) will save 
your computer disk space. Click on the pause button in the capture window or press 
COMMAND+K. Click on the resume button or COMMAND+K to continue capture. Use the 
pause option if you need to fast forward dvds/tapes or interrupt the video signal during 
the movie capture.
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Pause / Restart Coding

To pause the coding (and pause the movie,) of the Timeline and then also to restart the coding,  
press the Space bar on the keyboard.

Live Transcription

During the process, transcription text can be inputted directly into any active code button. The best 
way to demonstrate how this process works is to work through these steps.
1. Open a timeline with linked movie.
2. Create a new code window with 2 code buttons, named “Button 1” and “Button 2”. Do not set 

lag time for these buttons; the lag time might end before the text can be inputted.
3. Initiate code mode in the code window.
4. Press “Button 1” in the code window to start coding an instance.
5. Press CTRL+= on the keyboard. This will open a live transcription window that is linked to 

“Button 1”. The name of the button that the live transcription window is linked to is in the 
window’s title bar.

6. When “Button 1” is down, actively coding, if the live transcription window that is linked to 
closed by either clicking the red button in the window or pressing COMMAND+W, the live 
transcription will be saved in the instance that is being coded. If the the button is pressed up 
to stop coding, the text will disappear and be saved in the instance while keeping the live 
transcription window open.

7. Do steps 4 through 6 using “Button 2”. Note that both windows can remain open. As many live 
transcription window can be open as required. Note that the live transcription window opens 
for the last button pressed down. Check the title bar of the windows to see which window is 
linked to the buttons.

One of the problems that will likely be encountered is how to use hot keys while inputting text into 
the live transcription window. There are two unique rules to handle this situation when using this 
feature:
1. Single short cut keys cannot be used to trigger buttons when the live transcription window is 

the active window.
2. COMMAND+OPTION, COMMAND+CTRL and CTRL+OPTION plus another key can be used as 

hotkeys that will pass through the live transcription windows and be received by the code 
window.

Live transcribing takes a lot of practice. Do not expect to perfect on the !rst few tries. Being an 
e"ective user of this feature requires solid keyboarding skill.

It is common practice to use feature for annotating during capture, then exporting into the 
transcription window to thoroughly transcribe the video.
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Label Mode
Label Mode is designed to add or remove labels to and from existing instances in a 
timeline. While label mode is active, code buttons cannot be used. It is common 
practice to have a code window purely made up of label buttons only. Some events 
might be coded using code buttons only, providing the skeleton of the events that 
occurred in the movie. In a second pass during the analysis process, labels can be added 
while reviewing the instances in a looping mode.

Using Label Mode
1. Select a row of instances in the timeline by clicking on the row number. This will highlight all the 

instances in the row.

2. Set the playhead prior to the !rst instance for which you want to start labeling.

3. Activate Label Mode by clicking on the Label icon in the code window toolbar. 
4. Press the TAB key start the process. The playhead will jump to the instance and start playing the 

movie. The playhead will continually loop in the instance.
5. Press the label buttons in the code window to add to the instance. To remove a label, hold down 

SHIFT+OPTION+COMMAND and click on the label button.
6. Press the TAB again to advance to the next instance. Pressing SHIFT+TAB will retrogress to the 

previous instance.
7. To stop Label Mode, change modes in the code window.
We suggest opening the Edit Instance Labels window (COMMAND+E) to make viewing the labels 
contained in an instance easier to view. This will update according to the selected instance with the 
added bonus of being able to easily remove labels.

Once Label Mode is active, there are several clever ways to use the feature.

Click and add labels
Select an instance and click on the label buttons to add labels. Select another instance any where in 
the timeline and repeat the process.

Adding a label to a group of selected instances
Select a group of instances or all instances (COMMAND+A) and click on the label button in the code 
window. This will add the label to all the selected instances, convenient for adding metadata such as 
event name or date to a bunch of instances.
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Removing a label from a group of selected instances
Select a group of instances or all instances (COMMAND+A), hold down SHIFT+OPTION+COMMAND 
and click on the label button in the code window. The label will be removed from the instances. 
If there are duplicate labels, press the label button down multiple times while holding down 
SHIFT+OPTION+COMMAND, each click will remove the label from the selected instances.

Button Links

Exclusive Links - Code Button to Code Button
Two or more code buttons can be exclusively linked to each other. This means that if one 
button is active and a linked button is activated, the first button will stop coding (be 
deactivated) and the second will start coding. This feature is great for coding quick exchange 
of dialogue between more than one speaker. One click to stop one button and start another.

1.  Open the edit button properties window for a code button.
2.  Click on the Exclusive link drop down menu and select a code button to link to. An 

arrow will appear in the code window to show where the button is linking to.

Exclusive Links - Text Label to Code Button
A text label can be exclusively linked to a code button, so when it is activated it can only be 
inserted in the linked code button.

Activation Links - Button to Button
A button can be linked to another button to activate it. When the linked button is activated it, 
it activates any linked buttons. The link line indicates the direction in which the activation will 
occur. Activation links only press buttons down, they will not de-activate a button or toggle 
the button up. Any type of button can activate another button. Chains of activation can extend 
to fire off multiple buttons.

Note: When a text label is linked to multiple code buttons, it is in a chain of exclusivity where 
the text label will describe any of the linked code buttons.
Click on the Links icon in the tool bar to display the links for the button. If the “Show all Links” is 
turned off for the button, these links will not  show up until it is turned on. To change the Show 
Links option, right click on the links button in the tool bar of the code window and select 
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“Show all Links”.

Remove a Link
Click on the source button and open the edit button properties window. 
Click on the Exclusive link drop down menu and click on the button link indicator to be 
removed.

Analysis from the Code Window - Matrix Function

Clicking on this icon will take you to a matrix of the open Timeline or of the front 
Timeline if more than one Timeline is open. If you right click (Control + Click) on 
the icon you will be o"ered :

1. A matrix consisting of the buttons and labels in the Timeline with the matrix cells populated 
or ...
2. A matrix consisting only of the buttons and labels in the Code window.

A full Code window from  a Timeline could potentially produce a very large and unwieldy 
window.  An analyst may quickly construct a simple Code window with a selection of codes 
and labels from a Timeline, then choose option 2 above to select a matrix consisting only of 
those components in the simpli!ed window.
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Create a New Code Window Using an Existing One

1. Open the code window you want to use as a template.
2.  Make the required button name changes for the new code window.
3.  Choose File > Save as (COMMAND+SHIFT+S) and give the code window a new name.

Code windows can be moved from computer to computer without any problems just like any 
other type of file. You can share your work and have everyone using the same terminology and 
coding schemes.

Saving Code Windows

Once you have created all your code buttons, save the code window. You can use this as a 
template for other windows or use it to code any movie. This saves time as you will not have to 
create all the buttons again and you can have as many code windows as you like.

1. Choose File > Save from the main 
menu bar (COMMAND+S)

2. Name the code window.
3. Target where to save the file.
4. If you have saved the code window 

to your desktop, it becomes an 
icon. Double click on the icon to 
open it.
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The Timeline

When your Timeline is open, the movie which the Timeline is linked to is generally displayed in 
the top of the screen with the attached timeline below it.

Components of the Timeline

A timeline of your movie represented in hours, minutes, seconds and hundredths of seconds. 
The movie displayed is from the location of the playhead in this timeline. The playhead is the 
small triangle pointing in a downward direction. It can be dragged right or left to move 
through time in the movie.

Code rows with names that are populated automatically from code buttons 
(refer to page 33,) or created manually when a code button is first activated.

Instances and where they happen within your movie.

A tool bar to conveniently access all the tools for editing and presenting your instances.
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The Timeline Toolbar

Merge Rows
When creating instance movies this button presents 3 options.  Refer to page 92.

Merge Rows = plays instance movies in chronological order regardless of the row 
the instance is in.
Sequential Rows = plays instance movies from row A then row B etc.

Selection Order = plays instance movies in the order that the instances were selected.

Make Movie

Makes a movie out of selected instances.  Refer to page 91.

Append Slow etc 
When Append slow is ticked, the instance movie you make 
will play in real speed !rst followed immediately in slow 
motion, (default speed is 50% real speed.)

By checking the Static text box, each instances associated text descriptors will be displayed in a 
static title before each instance.
By selecting Text tracks, the text track will be displayed at the bottom of the instance movie screen.
By selecting Overlay text, the row name, instance number and text labels will be displayed over the 
movie as it plays.

Lines 
Allows you to specify the number of lines of text displayed at a time in the 
instance movie.  Refer to page 137.

Find 

Takes you to the Global Find window. Refer to page 113.

Database 

Saves an instance or group of instances to a pre-created database.  Refer to page 112.

Matrix 

Takes you to the Code Matrix window.  Refer to page 120.

Text 
Opens the Edit text window. Transcription text will also be displayed here. Refer to page 
137.
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New Row
 Adds a new blank row to the Timeline.  Refer to page 107.

New Row + 
Creates a new row from selected instances in the Timeline.  Refer to page 107.

Transcription
Exports a single instance or any group of selected instances to a Transcription 
window

Labels 

Takes you to the Labels Tree window.  Refer to page 48.

The Playhead

Create a New Timeline

Timelines are always created during capture. However, there are times when you will want to 
link a new timeline to the movie so you can code a different aspect, or multiple users are 
coding the same movie and you want to keep the data separated.

1. Choose File > New > Timeline from the main menu bar.
2.  Select the movie you wish to link the new timeline to.
3.  Save the new timeline by pressing COMMAND+S or choose File > Save from the 

main menu bar.
You can now press the code mode button in your code window to code the movie. 
Alternatively you can create and modify instances manually.

Save a Timeline

To save a Timeline, open the Timeline and select File > Save As from the Main Menu bar. 
Note:  The link to the existing movie !le will also be saved. The actual movie !le will not be saved 
as a part of the Timeline. If this link is broken for any reason, when this Timeline is opened again, 
Studiocode will ask you to re-link the movie.  (See page 76)
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Editing Labels in an Instance in the Timeline
When you right click (Control + Click) on an instance in the Timeline, the Labels Tree for that Timeline 
will be displayed in a drop down panel. The labels and label groups which are available will be 
displayed. The groups will be indicated by an arrow marker, hover the cursor over the group name to 
display the labels in that group.
The labels which are attached to that instance are indicated by a blue diamond marker or a red arrow 
marker beside a group name if a label from that group is attached.
You may add or remove a single label in that instance by clicking on the label in the existing labels 
tree displayed. You may add or remove multiple labels from an instance by displaying the labels tree 
for that instance, then hover your cursor over each label and press the Command key

Exporting Instances to a Transcription Window
Any group of selected instances or a single instance can be exported to a 
Transcription window. Select the instances in the Timeline, then press the 
Transcription button in the Timeline tool bar. If a Transcription window is open 
the instances will be pasted below the last row of that window. If a transcription 

window is not open a new one will be created automatically with the instances. When multiple 
instances are exported at once, they will be pasted in the window chronologically. If the 
selection is across multiple rows, each row will be pasted in their respective sections in the 
window

Movie Packaging
We recommend always packaging movies. A package is really just a folder with !les inside, Mac OS 
X simply recognizes it as a single !le. This makes it very convenient to move around and not lose any 
necessary !les. We use packages because it is solid way of protecting the source movie and handy to 
store timeline and edit list !les inside.
A de!nite trend is for users to acquire video !les over the internet. While this is a great convenience, 
the quality and creation process is largely unknown. What you download is what you get, in 
most situations there is no knowledge on how the video was created and what tools were used 
to compress, etc. Some of these movies will have di"erent movie data containers that may be 
corrupted by Quicktime when there are attempts to write data back into the !le. This is why it is 
best to always package the movies. The packaging process places the source movie in a movie data 
folder, then creates a reference movie that points to the source movie. Any changes to aspect ratio or 
text track information of the movie is saved in the reference movie and we never have to touch the 
actual source movie.

If a new timeline is linked to a free standing movie, a prompt will appear asking whether or not you 
wish to package the movie. We highly recommend answering yes to this question. The process is 
very quick, it simply wraps up the movie and timeline inside a package. It does not copy any data like 
the Save as standalone package does.
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Place front movie and timeline inside a movie package
In previous versions of Studiocode, it was common practice to have a free standing movie and 
timeline !le. If you have this situation, package them. Open the timeline and choose File > Place 
front movie and timeline inside a movie package. It will package them up together.
Note: Timeline files can still be free standing as long as the movie is packaged. You can have as many timelines pointing 
at a single package as you wish.

Timeline Backup Folder
The timeline is continually backed up inside the movie package. Up to 50 timeline backup !les will 
be saved. The oldest one will be removed when a total of 50 !les is reached. As coding or editing of 
instances is done in the timeline, a backup timeline !le is saved in a folder called BACKUP folder. Each 
backup !le is saved with a time stamp included in the name. If a gross error is made when editing, 
the system loses power or crashes while the !le is open, a backup !le can be used to replace existing 
timeline.
To replace an existing timeline with a backup timeline. Open the package, navigate into the BACKUP 
folder, then drag and drop the backup timeline next to the existing one in the folder above and 
delete the existing timeline. When you double click on the package, the backup timeline will open as 
the default timeline. The !le name can be changed if desired.

The Timeline Timecode
This function is to help integrate speci!c time based imports, (such as METI data, SimMan data and 
XML transcription data,)into a Studiocode Timeline.
A new preference has been added in the Capture Preferences, “Use Timecode produced from 
capturing device”. When this is ticked, a Timecode track will be created in the movie from the data 
that the device is outputting. Remember to set the correct time on the camera or device that is 
being used to capture from. The Timeline timecode can be altered by right clicking on the Timeline 
timecode counter situated above the row column in the Timeline window. Right clicking on the 
counter will reveal a Pop up menu, these are the options:

• Use movie time, this option displays standard movie time hh:mm:ss:hshs. The “hs” is 
hundredths of seconds.

• Use Timecode, this option displays the timecode in terms of 24 hour time as in the time of 
day. The numbers will be displayed in blue. This is useful for setting the time of day of an event, 
so the ability to when an instance occurred. NOTE: Changing the counter to display this might 
show the time at which the capture was done. This can be read from the camera or capture 
hardware that is connected.  Be sure to set the camera time, so the correct time is captured. 
Presenting, breaking the timecode up segments along the timeline is not possible. The timecode 
will roll over to 00:00:00.00 when the playhead is dragged past 23:59:59.99. This means the 
playhead was dragged past midnight.

• Set movie time to zero, this option resets the movie time to 00:00:00.00 according to the 
location of the playhead. The time will be displayed in red when the numbers are “negative” or 
the playhead is set before the new zero point.

• Set TimeCode, this option reveals a menu from the timeline title bar. The time can be set here
• Delete TimeCode track, this option removes the Timecode track. It can be readded by using 

the Set TimeCode function, but the original one that may have been done during capture 
cannot be brought back.

• Use frames for TimeCode, this option will display the hundredths of seconds in frames.
• Use seconds for TimeCode, this option will display the Timecode to the hundredths of 

seconds.
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The Labels Tree Window

The labels tree is a pop up menu system used to add or remove 
text labels for an instance in the timeline or the movie organizer. 
The term “Labels Tree” is derived from the concept that groupings 
of labels may resemble the branch of a tree because labels may 
be grouped into categories or branches. 

The labels tree pop up menu is auto generated from the text 
labels in a code window or can be created manually using the 
Labels Tree window. When code mode is activated in the code 
window, the labels tree pop up menu is saved into the timeline 
and can be accessed by right clicking on an instance. All the labels 

found in the instances in the timeline are shown in cells of this spreadsheet style window. 

The pop up menu will display in the order of the rows in the Labels Tree window. Labels can be 
sorted alphabetically in ascending or descending order. The Labels Tree window can configure 
the pop up menu layout to extend horizontally, so labels can be structured in logical and easy 
to navigate branches. A Labels Tree can be saved as a file and used similarly to a code window. 

Many Labels Trees can be opened at one time. It is the front most Labels Tree window that will 
appear as the pop up menu when an instance is right clicked on. This is useful when coding 
enitirely different aspects of an event and can help avoid long lists of labels that make it 
difficult and time consuming to find a specific label.

A default Labels Tree window is created for the Timeline from using a code window in code 
mode. If multiple code windows are used, all the labels from each window will be added to the 
default labels tree in the Timeline.

Accessing and Creating a Labels Tree
There are many ways to access a Labels Tree. A Labels tree can be accessed from the 
Timeline, Sorter window and Movie Organiser window. The most common way is to 
press the labels button in the timeline window. This will open a Labels Tree with the 

labels that were used for coding the timeline. Once opened this window can be edited and the 
changes will be saved in the timeline. The window can also be saved like a code window and 
used to label other timelines and the new Labels Tree data will be saved in those timelines. 
Opening an existing Labels Tree is a good place to start when building separate Labels Trees 
for various coding work flows.

Labels Trees can be created from scratch too. Select File > New > Labels Tree. Then add a label 
in a cell of each row in the first column of the window. When this window is the front most 
Labels Tree window, it will be used to create the pop up menu that appears when an instance 
is right clicked. Save this window by pressing COMMAND+S.

In Studiocode, a Labels Tree can be created by right clicking on the Label mode 
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button in a Code window. Select export labels from the pop up menu and all the labels will be 
exported into a new Labels Tree. The label button color will also be exported, making it easier 
to find label sections in the window.

Adding a New Text Label to The Labels Tree 
Press the new row button in the tool bar of the Labels Tree window. This will create a new row 
under the currently selected row or at the bottom of the window if no cells are selected.

Deleting a Text Label in the Labels Tree
Right click on the row number and select delete row from the pop up menu.

Changing a Label
Click in the Labels Tree cell and edit the text.

Creating Branches for the Labels Tree Popup Menu
Adding columns to the labels tree will create branches for the the popup menu that appears 
when you right click on an instance to edit the labels in the instance. Creating branches 
spreads the lists of labels out horizontally and groups them, so labels can be more easily 
navigated and found.

The root of the menu is the first column in the labels tree window. The second column creates 
a branch from the root and subsequent columns create sub-branches of the branches. The 
labels tree can have as many columns (branches) as is required. A branch ends when the last 
column and rows of that column end.

Here is how to create a simple one branch level menu.
1.  Create a new labels tree window. File > New > 

Labels tree.
2.  Add 1 column and 9 rows by pressing the add 

rows and add columns button in the tool bar.
3.  Add the name for the first branch in cell (1,1). 

Then, add labels in cells (2,1), (2,2), and (2,3). 
This creates the first branch with 3 labels as 
options in the popup menu.

Use multiple Labels Tree Windows
Create multiple labels tree windows where each window has a specific set of label 
information in it. (Name the windows as to their purpose and the information contained) 
Open all the labels tree windows at once, press the small button in the upper right corner 
of each window, this will hide the window, leaving the window bar only showing. Click on 
the window bar for the labels tree that will 
display in the popup menu when an instance is right
clicked on. The top most label tree window will display in the popup menu.
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4.  Add the name for the second branch in cell (1,4). Adding text into this cell ends the 
previous branch and starts a new one. Then, add 
labels in the cells (2,4), (2,5), and (2,6). This 
creates the second branch with 3 labels as 
options in the popup menu.

5.  Add the name for the third branch in cell (1,7). 
Then, add labels in the cells (2,7), (2,8), and (2,9). Adding text into this cell ends the 
previous branch and starts a new one. This creates the third branch with 3 labels as 
options in the popup menu.

6.  Save the labels tree, so it can be re-opened and used again to label instances in a 
timeline.

7.  Test the labels tree by opening a timeline and right clicking on an instance. If the 
labels tree is the top most label tree window, the popup menu will appear as it has 
been structured

Editing Text Labels Using the Labels Tree Pop Up Menu

The labels tree is a pop up menu system used to add or remove text labels for an instance in the 
timeline, movie organizer, and the sorter window. The labels tree pop up menu is auto generated 
from the text labels in a code window or can be created manually using the Labels Tree window. 
When code mode is activated in the code window, the labels tree pop up menu is saved into the 
timeline and can be accessed by right clicking on an instance.

Strip Instance Contents

Sometimes it is necessary to remove any labels and instance notes from instances in a row of the 
timeline.
1. Select the instances in the timeline, press COMMAND+A to select all. 
2. Choose Edit > Strip instance contents

Remove duplicate labels from Selected Instances

If data has been imported using one of the many imports, it can often contain duplicate labels that 
are not necessary. To clean up the duplicate labels, select the instances or all isntances and choose 
Edit > Remove duplicate labels from selected instances. Any duplicates will be stripped from the 
instances. This feature is helpful when cleaning up coded instances too, especially if label counting is 
important in the matrix or statistical window.



51

A
n

 In
tr

o
d

u
ct

io
n

C
o

d
e

C
ap

tu
re

R
ev

ie
w

 /
 A

n
al

ys
is

D
is

tr
ib

u
te

C
o

d
e

To Add or Remove a Text Label in an Instance 

There are 2 ways to add or remove labels from an instance.
1.

Right click on an instance, the Labels Tree will open. 

Hover over a text label and press COMMAND to add a label, a blue diamond 
will appear next to the label. 

To remove a label, hover over the text label, press COMMAND.

To add or remove multiple copies of the same label, hold down COMMAND and click on all the labels 
you wish to add or remove. You may also select the option from the Edit Menu in the Main Menu Bar 
to remove duplicate Labels

2. Open the Edit labels window, COMMAND+E, then select an instance.

To add a label press the new label button, then double click on the new untitled text label 
row and add the text.
To remove a label, select the row, then press the scissors button and it will dissappear.

Leave the window open and click on instances  click edit or view labels.
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Importing Files 

Studiocode can import a selection of third party textual data. If there is a problem please let 
Sportstec know as it is likely the third party data source has changed its data structure.

An important item to note about importing is movie and data synchronization, it is very likely that
adjustments will have to made on the instances after the import. We recommend getting familiar
with the Instance Adjustments and nudging features in the Edit menu.

Each import has a speci!c format and data structure. Only the Edit List and Studiocode XML will be
explained in detail as we export both of these types of !les. These are also commonly used in third 
party solutions to feed data into Studiocode. There are quite a few users generating or converting
data from external sources beyond Studiocode.

Edit List

This import is mostly used in conjunction with a spreadsheet editor like Excel. Try exporting an edit
list from Studiocode and look at its structure. Note that Excel might insert hidden characters, so use 
the export as tab delimited !le if creating an edit list in excel.

The !le to be imported must be tab delimited !le with the following columns in order and included
as the !rst line:

start time
end time
category
Nth instance
#descriptors
descriptors...

• The start time and end time must be in 00:00:00:00 format. These columns set the start and end 
time

• for the instance.
• The category column represents the timeline row.
• Nth instance is the number of the instance in the row.
• # descriptors indicates how labels are in the instance.
• descriptors... are the label names that are in the instances. The amount should match the # 

descriptors and each label should be separated by a tab.
• Each instance must be on a separate line. 
Here is an example of some lines

To use this import, open a Timeline and choose File > Import > Edit list... and select the Edit list !le. 
The instances will be imported into the front-most timeline in your working window.
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XML Edit List

Similar to the traditional Excel type Edit list !le, an XML edit list !le can be employed. The XML !le 
format o"ers a bi-directional method to push and pull data though Studiocode. We recommend 
using the XML import over the Edit List because it is o"ers more options and is easily extended. Plus, 
this is the only format that Studiocode can import live during capture. When using the Studiocode 
capture window a time code track based from the computer’s clock will be added to the movie.

The XML !le can handle labels, label groups, instance notes, row colors, row sorting and time 
synchronisation where the traditional edit list does not o"er this.

Note! Our XML !le breaks strict XML standards, however the format follows the nested hierarchical 
nature (1 root element, elements and sub-elements) of standard XML structure. But, does not 
include special character handling in the element’s contents. Some characters such ampersand 
should be represented as ampersand if used as content in code, label, label group, and instance note 
elements. Do not use the special XML character handling routines. We admit to a loose interruption 
to the standard and apologise for any inconveniences. It is likely in the future we will tighten this up 
like we have done in the Matrix web exports.

Here is a short example of an XML edit list to get you started. We have added indenting and styling 
to better display the nesting of the tags and make it more readable. Often XML !les will not have this 
nice indentation making them a little more intimidating. Just know this is not a necessity.

You can try copying and pasting this example into TextEdit or some other text editor like Text 
Wrangler, then changing some of the content between the elements and importing it into 
Studiocode. For those not familiar with XML, remember, all open tags must also be closed, i.e. </
TAGNAME>. If the !le is not formatted perfectly in this way, it will not import.

<!le> 
 <SESSION_INFO> 
  <start_time>2010-03-10 21:21:39.63 +1100</start_time>
 </SESSION_INFO>
 <SORT_INFO> 
  <sort_type>sort order</sort_type>
 </SORT_INFO> 
 <ALL_INSTANCES> 
  <instance> 
   <ID>1</ID>
   <start>4.9984074982</start>
   <end>10.0046128241</end>
   <code>Alexis Proctor</code>
   <label> 
    <text>First Step</text>
   </label> 
   label> 
    <group>Speed</group>
    <text>Fast</text>
   </label> 
   <free_text>This is a great example of a fast !rst step.</free_text>
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  </instance> 
  <instance> 
   <ID>2</ID>
   <start>29.0119131044</start>
   <end>59.2852137351</end>
   <code>Alexis Proctor</code>
   <label> 
    <text>First Step</text>
   </label> 
   <label> 
    <group>Speed</group>
    <text>Fast</text>
   </label> 
   <free_text>This is another great example of a fast !rst step.</free_text>
  </instance> 
 </ALL_INSTANCES> 
 <ROWS> 
  <row> 
   <sort_order>1</sort_order>
    <code>Alexis Proctor</code>
   <R>65535</R>
   <G>4139</G>
   <B>4139</B>
  </row> 
 </ROWS> 
</!le>
Reading down the above example from top to bottom, below is a description for each element 
found in the !le. For interest of saving space and paper, not all descriptions will include excerpts 
from this example. Please refer to the example above for elements that embody many sub-elements.

<!le>
The XML must start with <!le> and end with </!le>. This is the root element. This sets the block of 
data for Studiocode to read.

<SESSION_INFO> 
This is time stamp that indicates when the coding session commenced. The time stamp is used to 
calculate the o"set between a Studiocode capture session and the incoming XML data session start 
time. This o"set allows for seamless time synchronisation between the two separate systems. System 
time should be synchronised on any machines in the work#ow. All instances must relate back to this 
time.
There are two supported date strings: 
 .   yyyy-MM-dd HH:mm:ss.SS Z     This is the preferred format.
 .   yyyy-MM-dd HH:mm:ss Z
Example:
<SESSION_INFO> 
<start_time>2010-03-10 21:21:39.63 +1100</start_time>
</SESSION_INFO
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<SORT_INFO>
Sorting order can be included in order for the timeline rows to be automatically sorted when 
they are imported. This is rather important for a better end user experience. So it should be highly 
considered especially when importing live XML data during captures.

The <SORT_INFO> element has a sub-element called <sort_type>. This element tells the timeline 
how it should sort the rows.

The options for sorting are:
• <sort_type>sort order</sort_type> - sort order indicates that a speci!c order must be followed 

during the import. The import routine will look in the <row> element to !nd a value to assign a 
priority for the sort.

• <sort_order>1<sort_order> - <sort_order> is set in the <row> element. Its contents should 
be represented by an integer or #oat: 1,2,3 or 1.1, 1.2, 1.3. The smaller the number, the higher 
priority the sort will be. The highest priority will be the !rst (top) row in the timeline. We 
recommend using integers, but #oats can be handy if you need to insert something at a later 
date. 

• <sort_type>color</sort_type> - color sorts the rows automatically by color using Studiocode’s 
standard color sorting method.

• <sort_type>name</sort_type> - name sorts the rows by name alphabetically
• <sort_type>color then name</sort_type> - color then name sorts the rows by color then name 

alphabetically
• <sort_type>instance count</sort_type> - instance count sorts the rows according to the 

number of instances, greatest being !rst row.
Example: 
<SORT_INFO> 
<sort_type>sort order</sort_type>
</SORT_INFO>

The sorting methods are similar to those found under the Rows menu in the Main menu. Try 
opening an existing timeline and use the various sorting options to !nd out what will work best. We 
recommend experimenting using color and name. Color is a really good way to achieve nicely sorted 
and presentable timelines.

<ALL_INSTANCES>
This declares the parent element for all the <instance> sub-elements. This is where the real work 
begins, this element contains all the instances that appear in your timeline. See this in the short 
example at the beginning of this section of the manual. It follows the <SORT_INFO> element. 

<instance>
The <instance> element represents a single instance in the timeline and all the sub-elements 
contained within will describe the instance to be represented in the timeline until closed with </
instance>. It is a sub-element of <ALL_INSTANCES>.
Example: 
<instance> 
 <ID>1</ID>
 <start>4.9984074982</start>
 <end>10.0046128241</end>
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 <code>Alexis Proctor</code>
 <label> 
  <text>First Step</text>
 </label> 
 <label> 
  <group>Speed</group>
   <text>Fast</text>
 </label> 
 <free_text>This is a great example of a fast !rst step.</free_text>
</instance>

<ID>
<ID>  is a unique identi!er for the instance. Each instance must have a unique identi!er, no two can 
be the same and there can only be one of these elements per <instance> element. This is a sub-
element of <instance> and its content must be represented as an integer.
Example: 
<ID>1</ID>

<start>
This sets the start time for the instance in the timeline. It’s contents represent seconds. The contents 
can be an integer or #oat with precision up to 10 decimal places. This is a sub-element of <instance> 
and there can only be one of these elements per <instance> element.
Example: 
<start>4.9984074982</start>

<start>
Like <start>, <end> sets the end time for the instance in the timeline. It’s contents represent seconds. 
The contents can be an integer or #oat with precision up to 10 decimal places. This is a sub-element 
of <instance>  and there can only be one of these elements per <instance> element.

<code>
The contents of the <code> element sets the row name in the timeline where the instance will 
be created. This is a sub-element of <instance>  and there can only be one of these elements per 
<instance> element.
Example: 
<code>Alexis Proctor</code>
The next part describes the labels that will be contained in the instance. In the example, the !rst 
<label> element does not have a <group> sub-element , the second does. To learn more about label 
groups, see this section of the manual at page 48. We recommend using label grouping as it has 
great bene!ts in the Matrix and without them the Sorter loses most of sorting power.

<label>
This element indicates that a label is contained in the instance. This is a sub-element of <instance>  
and there can be as many <label> elements as required.

<text>
This is a sub-element of <label>. Its content is the label that will appear in the contents of the 
instance in the timeline. There can be only one <text> sub-element per <label> element. See page 
15 of this manual for a description of a label and how and where it is used in Studiocode.
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Example: 
<label> 
<text>First Step</text>
</label>
Here is the second example with the <group> sub-element used within a <label> element.
<label> 
<group>Speed</group>
<text>Fast</text>
</label>

<group>
The <group> sub-element indicates that the label described in its sibling <text> sub-element 
belongs to its contents (label group). There can be only one <group> sub-element per <instance> 
element.

<free_text>
The <free_text> sub-element’s contents are the Transcription notes contained in an instance in the 
timeline. There can be only one <free_text> sub-element per <instance> element. To learn more 
about Transcription notes, see pages 130 - 137 in this manual.
Example: 
<free_text>This is a great example of a fast !rst step.</free_text>
The last section of the example describes each rows color and sorting in the timeline.

<ROWS>
The <ROWS> element starts the section that tells Studiocode how to represent the code rows in the 
timeline. It is an element of the root element <!le>. It contains sub-elements that indicate color for 
speci!c <code> sub-elements and provides sorting order information when the <sort_order> sub-
element is used.
Example: 
<ROWS> 
 <row> 
  <sort_order>1</sort_order> 
  <code>Alexis Proctor</code>
  <R>65535</R>
  <G>4139</G>
  <B>4139</B>
 </row> 
</ROWS>

<row>
The <row> sub-element represents information about a speci!c row’s representation in the timeline. 
There can as many <row> sub-elements as required.

<sort_order>
As described above, the <sort_order> sub-element sets the sort priority when the <sort_type> 
sub-element contents of the <SORT_INFO> element are set to “sort order”. There can be only one 
<sort_order> sub-element per <row> sub_element and it is a sub-element of <row>.
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<code>
The <code> sub-element’s contents tells the timeline which row it’s data is referring to. This where 
the relationship between the <instance> sub-elements and the <row> sub-elements is made. There 
can be only one <code> sub-element per <row> sub_element and it is a sub-element of <row>.

<R>
The <R> sub-element’s contents represent the color red in 16 bit RGB. It’s contents must be an 
integer from 0 to 65535. It is a sub-element of <row> and there can only be one per <row> sub-
element.

<G>
The <G> sub-element’s contents represent the color green in 16 bit RGB. It’s contents must be an 
integer from 0 to 65535. It is a sub-element of <row> and there can only be one per <row> sub-
element.

<B>
The <B> sub-element’s contents represent the color blue in 16 bit RGB. It’s contents must be an 
integer from 0 to 65535. It is a sub-element of <row> and there can only be one per <row> sub-
element.

A helpful tool for !nding color values on your Mac, is to use DigitalColor Meter. It can be found in the 
/Applications/Utilities folder. Set it to display RGB As Actual Value, 16-bit.

Transcript Text File

The transcription window can export its contents into a tab delimited text !le. This import option 
will create a new transcription window from the data. Some third party transcription applications 
use a similiar format, so this import can be used to import those !les. 
Here is an example of what the !le should look like. There are tabs separating each column of data.
00:00:03:84 Matilda Alexis, quit taking all my toys! Angry 
00:00:49:97 Alexis These are my toys, I had them !rst! Upset 
00:01:25:85 Matilda No, you did not! On Fire 

Note: If you are importing third party data, the time formatting is important. It is HH:MM:SS:00. 00 
is hundredths of seconds and is separated by a colon not a dot. This does not comply with some 
spreadsheet editor’s format like Excel. So, watch out for this convention and change the formatting 
before importing.

Transcriber XML File

The XML Transcript imports !les that were created using Transcriber, the open-source transcription 
application. Since Transcriber is open-source and projects like this can change with very little 
documentation or announcements, we cannot guarantee that this import option will work 
as speci!ed unless using Transcriber version 1.5.1 found on its o$cial website. To learn more 
about Transcriber, visit the o$cial website. At the time of this writing, the website is http://trans.
sourceforge.net/en/presentation.php.
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Tab Delimited Data into selected instances

There are occasions where data does not contain time stamp information. By creating a tab 
delimited !le from the data and coding some corresponding instances, the data can be imported as 
labels into the coded or speci!cally selected instances. Each line will be imported into each instance 
respectively.

Here is a brief example on how this might be done.

1. Create a tab delimited !le that looks like this. Remember that each label must have a tab in 
between each other. And each line must end in a carriage return, not a line feed.

Label 1 Label 2 Label 3 
Label 3 Label 4 Label 1 
Label 2 Label 1 Label 6

2. Code a timeline row with 3 instances.

3. Select the instances in the timeline.
4. Choose File > Import > Tab delimited data into selected instances...
5. Each line of the tab delimited !le will be imported as labels in the corresponding instances.
Line 1 > Instance 1 
Line 2 > Instance 2 
Line 3 > Instance 3

Generic CSV

The generic csv import will import most comma separated value !les that meet the following 
conditions:

1. The !rst line (row) in the !le is the column header / value 
description.

2. There are columns/values for Mins,Secs,Frames and each 
line(row) has this data. Otherwise the data will be imported 
into the timeline.

Choose File > Import > Generic CSV !le then select the !le 
to import. 

A window will appear where each column/value can be be 
con!gured as to how it will be imported into the timeline. By 
unchecking the tick box in the import column, the row will 
not be imported. The column heading name can be changed 
by double clicking in this cell of the column heading column. 
If the name is changed and the row is code, then this will be 

the timeline row name. If the row is desginated a label, then this will be the label group. Each row 
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can be imported as label or code row, click on Type cell in the column and set it to Label or Code. 
There must be at least one code selected in all the rows. When multiple items are code, the rows 
setup as labels will import into all instances for all code rows.

Paste METI Data

An event list from a METI system can be imported into the timeline using this option. To use this 
import: 
1. Open the METI text !le in a simple text editor like TextEdit. The !le should look something like 

this: 
0:00:00 Patient Loaded: Untitled Adult Patient 
0:01:28 “Scenario Loaded: “”Cardiac Arrest””” 
0:01:28 “Scenario: “”Cardiac Arrest”” entered state: “”baseline””” 
0:01:40 “Scenario: “”Cardiac Arrest”” entered state: “”begin_Cardiac Arrest”””

2. Select the rows of data to be imported or select the entire document by pressing 
COMMAND+A.

3. Press COMMAND+C to copy the selection to the clipboard.
4. Open the timeline for which the data should be imported.
5. Choose File > Import > Paste METI data
The copied rows will be pasted into the timeline using the time references in the !rst column of 
the data !le as the starting points for each instance created. The second column of data will dictate 
the code row that is created in the timeline. Its ending point will be the next row in the data where 
a matching code row is found. All other columns in the data !le will be inserted labels for the 
instances.

Paste Laerdal Debrief Data

Similar to the METI Data import, the Laerdal Debrief Data import creates code rows and labels based 
on data in an event log. Use the same steps outlined in the METI import to import the data into the 
timeline. Rows and instances will be created for vital signs with their values being inserted as labels.
A Laerdal event log should look something like this:
Debrie!ng
Date: 11.03.2008 Time: 16:17:24
Healthy patient  00:00:00  Scenario started: Healthy patient 
00:00:00  HR: 80 BP = 126/ 84 SpO2: 98 PAP: 25/ 10 etCO2: 34 mmHg T blood: 37.2 ∞C etO2: 16  
00:00:32  Left lung sound = Crackles  
00:00:32  Right lung sound = Crackles  
00:00:48  Pulse radialis/brachialis. Pulse absent 
00:00:49  Central pulses. Pulse strength = normal 
00:01:00  HR: 80 BP = 126/ 84 SpO2: 98 PAP: 25/ 10 etCO2: 34 mmHg T blood: 37.2 ∞C etO2: 16
00:02:00  HR: 80 BP = 126/ 84 SpO2: 98 PAP: 25/ 10 etCO2: 34 mmHg T blood: 37.2 ∞C etO2: 16
00:03:00  HR: 80 BP = 126/ 84 SpO2: 98 PAP: 25/ 10 etCO2: 34 mmHg T blood: 37.2 ∞C etO2: 16
00:03:22  Left lung sound = Pleural Rub
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Set Directory for Auto XML Import

XML data can be automatically imported into a capturing timeline by selecting a folder for 
Studiocode to look for incoming data. The XML format must in the Studiocode format. See the XML 
Edit Import description for speci!cs on the data structure, particularly the session-info section. To 
make the time synchronization work really precisely, the computer clocks of the capturing and 
coding computers should be synchronized using network time. In order to synchronize properly, the  
movie must be captured using Studiocode. 

When using this import option, the !le name must have the tag <import> in the beginning of 
the !le name otherwise Studiocode will not insert the data in the timeline. A !le name might be 

“<import>MercyHospital.xml”. Double underscores can be used in place of the angle brackets, so an 
alternate !le name could be __import__MercyHospital.xml.

The import directory should be set prior to capture, but can be done at anytime during capture. The 
directory needs to be reset if the application is quitted.

The auto XML import will not update instances that have already been imported into the timeline 
for e$ciency reasons as all XML data does not have to be reloaded from the start constantly. In the 
case where the XML data has been updated for existing (past) instances, the xml must be reloaded 
entirely. To do this: Choose File > Import > Reload auto XML import. The timeline will empty and all 
XML data will be reloaded.
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Part 3  -  Capture





65

A
n

 In
tr

o
d

u
ct

io
n

C
o

d
e

C
ap

tu
re

R
ev

ie
w

 /
 A

n
al

ys
is

D
is

tr
ib

u
te

C
ap

tu
re

Capture

We de!ne capture as the process of recording a sequence of images from a video source such as 
a camera or digital convertor into a !le on the internal hard disk of the computer or other storage 
device. The capture windows supports various PCI capture cards, !rewire and USB cameras such as a 
webcam. 

The capture window can be directly accessed in several ways:
 1. By clicking on the camera icon in the main toolbar .....................
2.Through the main menu: Capture > Open capture window.
3. A keyboard shortcut: R

In the Code window, by pressing the Capture icon................

Before opening the capture window, connect the 
camera or video source to your computer.  When 
the capture window is opened, it will search for 
any connected video sources. If it does not !nd 
an attached source, it will default to the built-in 
iSight camera if available on the computer 
otherwise it will indicate none available. This 
is useful to know when testing connectivity 
between computer and video sources.
The cable used to connect a camera is likely to be 
a 9-pin to 4-pin or 6-pin to 4-pin Firewire cable. 

The 9-pin or 6-pin end of the cable connects to the computer and the 4-pin connects to the camera. 
Digital converters generally have a 6-pin connector, some have both 4-pin and 6-pin.

Making the connections
When connecting any video devices for capture, try to visualize the video signal #ow. Drawing the 
signal #ow on paper can be very helpful. Start by identifying the source and destination connectors 
physically on the devices, then map out how they are going to connect to each other, matching 
video out to video in accordingly. For instance, if you are sourcing the video from a satellite receiver, 
you are likely going to be using an analog to digital convertor as a bridge from the source to the 
capturing computer. 

Signal Flow

Satellite Video Out > Convertor Video In > Convertor Firewire Out > Computer Firewire In
So, the signal #ow will start at the video out connector of the satellite box, travel to the video in 
connector on the convertor using a rca cable, then travel to the computer using a !rewire cable. Set 
the convertor settings to analog input if automatic detection is not enabled.
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Setting Video and Audio Sources

The video and audio input sources can be set in the capture window below the video preview 
window. To change the video source, click on the drop down menu next to the camera icon. 

Choose the source from the list. A camera or other 
device should appear in the menu if properly 
connected.

To change the audio source, click on the drop down menu next to the microphone icon. 
If a camera or other external device is used for capture, this option will be greyed out.

Compression Options
The capture window has options to change the encoding method that is used while capturing 
the movie. The encoding method is referred to as a codec. Codec stands for compression 
/ decompression and is the way in which the data is stored (compressed) and presented 
(decompressed).

For many capture work#ows, the native codec used by the source might not produce the optimal 
results, so a di"erent codec might be chosen to use during capture. This is common to reduce the 
!le size. For example, the DV codec produces very good quality video, but the !le size is quite large. 
So, as a way of reducing the !le size, capture using the H.264 or MPEG-4 codec option. While the 
quality is not as good, it is much easier to transfer and store the smaller !les.

While choosing di"erent codecs from the native ones is a great option, be aware that it requires 
more CPU to recompress the !les on the #y. We recommend doing a lot of testing to guarantee that 
the options used during capture will work through the entire span of the video work#ow. You might 
!nd that your computer is not powerful enough to handle capture, recompression and coding at 
the same time. You could also !nd that the chosen video codec will not work in some third party 
software involved in your work#ow.

Video Codecs

There are 3 codec choices for the video component of capture, (apart from the device’s native video 
codec.) These are designed by Apple to produce the best results possible. The video codec options 
can be accessed by clicking on the drop down menu to the right of the video source drop down.

Device Native - The capture will use the settings that are coming from the source. We recommend 
using this option in most cases as it reduces the load on the cpu and results in the highest quality 
possible. A common native codec is DV. DV !les will be 13.76GB per hour.



67

A
n

 In
tr

o
d

u
ct

io
n

C
o

d
e

C
ap

tu
re

R
ev

ie
w

 /
 A

n
al

ys
is

D
is

tr
ib

u
te

C
ap

tu
re

Apple Intermediate - This is a codec designed by Apple to be an intermediate format in an HDV 
work#ow. This codec produces very large and high quality video !les while not requiring a lot of cpu 
work to do so. Files are roughly 20GB per hour. This is a great codec to use when you want a high 
quality master that will be used to create other videos such as for iPod or streaming over the internet.

H.264 - This option compresses the video into the H.264 codec, a derivative of MPEG- There are 3 
options while using this codec, the options only change the frame size thus reducing the !le size. We 
recommend using the H.264 SD option for most occasions. This creates a H.264 encoded movie with 
a frame size of 640x480. One hour of video will be approximately 2GB per hour. The data rate will 
#uctuate according to images being processed.
MPEG-4 - This option compresses into the MPEG-4 codec. Like H.264, there are 3 options, each one 
uses a di"erent frame thus resulting in a smaller !le. This has traditionally been the codec of choice 
for capturing good quality !les with relatively small !le sizes. Files will be roughly 2GB per hour. 
H.264 will supercede this codec in the future.

Audio Codecs
And there are 3 choices for the audio component of capture, (apart from the device’s native audio 
codec.) Generally speaking, audio codec settings are largely ignored as when compared to video, 
mainly because the size of the audio component is insigni!cant to that of video. For the most part 
using the Device Native settings will be perfect. However to save a little space, using AAC High 
Quality is a good option.

Next to the audio source drop down menu are the compression options. By default, the menu 
selection is set to Device Native.

Device Native - This will capture using whatever the device is outputting.

AAC High Quality - This delivers a CD quality audio track at 128kbps.

AAC Voice Quality - This delivers a low quality audio track at 32kbps.

Apple Lossless - This delivers a very high quality audio track that is quite large in size depending 
on the audio that is being recorded. This is a good option to use if recording using external 
microphones and audio is really important to the video.
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The Capture Window Toolbar

Capture /Stop Button

Press this button to start capture and to stop the capture. Click and holding down the 
mouse button will reveal a drop down menu of options.

Append Button

Allows you to stop a capture and then resume the capture at  another time by  appending 
the resumed capture to the initial capture reference movie !le.

Pause / Resume Button
The Pause/Resume button allows you to pause the capture and then resume later. You 
cannot logout of the capture or perform another task in Studiocode while the capture is 
paused.

Update Button

Manually updates the reference movie. (See also the Hot Tip on page 71.)

Preferences Button

Takes you to the Preferences Window.

Customize Button

Opens the Capture Customization Window.

Current Time Display

Displays the current elapsed time of the capture.
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Customize the Capture Window Toolbar

You may customize the toolbar of the Capture window by clicking the Customize icon. 

This will open the Capture Customization  window.  Drag and  drop the function icons either to or 
from the window into the toolbar

Capture Window Functions

Basic capture

Start to learn how to capture by stepping through the basics !rst.
Make sure the capture source, camera or convertor is connected and turned on. Or try using the 
Built-in iSight camera.

Open the capture window by clicking on the Capture icon in the main toolbar . This will open 
the capture window and an image should appear in the window from the camera or convertor.
Press the red capture button to start capture . This button will reveal a drop down menu if the 
click is held down while pressing the button.

Name the !le and choose a destination folder. The desktop is a good place to start capturing !les to 
as you will not lose them as easily. 



70

Once capture has begun, a timeline window will pop up. This timeline allows live access to the 
capturing !le, all the features of the timeline can be used live during capture. This timeline will 
continue to grow in length during the capture.

In the capture window, the status section in the bottom of the capture window will indicate: 
captured !le length, size and data rate. It will also indicate disk information: available space and 
approximate capture length available according to remaining disk space.

At any time, the capture can be paused by clicking on the Pause button . To continue capture 
after pausing press the Resume button .

To stop the capture, press the stop button . The capture window will disappear and the timeline 
and movie window will remain.

Quick Capture
The quick capture feature is used to initiate capture instantaneously forgoing any save 
options. By pressing CONTROL+COMMAND+R, capture will start immediately and the 
movie will be saved in the quick recording folder with a date stamp as the name. This 
feature can also be accessed in the drop down menu of the red capture button in the 
capture window toolbar. While this is a convenient feature for rapidly starting capture, it is 
mainly employed through the remote communications and iCal event captures.

Append Capture
This feature allows you to append a capture to an existing movie. Select Append in the 
Capture Window Toolbar, then select the movie !le you wish to append the proposed 
capture to, then capture as normal. The new capture will be attached as a continuation of 
the existing movie.

Update Capture
 During capture, a new !le is written approximately every 5 seconds, then from these !les 
a continuous reference movie is created on the #y. This automatic update process can be 
manually made to occur by pressing the update button in the capture toolbar. Pressing 
update will start a new !le. This is useful when exporting movies through the matrix web      
export.

Note: Pressing the update button does not drop frames during capture.

Communicate
This is a local and remote way of initiating capture. ie. both Client and Server
For use with Remote Communication Coding and Capture only.  Refer to the section 
on page  78 - 86  for details of this function.

Communicate Only
This is a remote only way of initiating capture.  ie. Server only
For use with Remote Communication Coding and Capture only.  Refer to the 
section on page  78 - 86  for details of this function.
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Capture Preferences

The capture window has a number of preferences which can be set in the capture section of the 
main software preferences.
• Quick Recording Folder sets the folder where quick capture !les will be saved.
•  “Close window when recording stopped”. This option either closes or leaves the capture 

window open after capture is stopped

Code Window functions during Capture

During capture, with a Code Window open, you may create instances in the Timeline using capture 
mode (live capture) or code mode (after capture) or add labels to an instance (after instance has 
been created). You may also add more buttons or labels to your code window or remove them. Thus 
you may toggle between capture mode, code mode ,label mode and edit mode without a"ecting 
the capture.

Update Code Button
A code button in the code window can be created to update the capture when it is 
pressed down.
1.  Create a new code button in the code window.
2.  Name the code button <capture_update>.
3.  Set the code button with a lag time. The lag time amount depends on how long 

the update process should happen after the button is clicked.
A good approach to using the <capture_update> button is to have it activated by another 
code button with lag time. Set the lag time for the <capture_update> button 1 second 
longer that the code button that triggers it. When the code button ends its lag, the 
<capture_update> button will trigger the update process 1 second later.
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Synchronizing Sound and Video
 
When using DV capture devices you may occasionally find inaccurate sound and video 
synchronization in captured movies.

Most Common Problems that Occur are:
1. The sound is offset by the same amount throughout the movie file. 
2.  When capturing a long movie, the sound and video synchronization can be good 

at the start of the video, but the further one goes, the more the sound and video 
synchronization becomes a problem. In this case the scale of the video and sound is 
different and is a known problem in Quicktime. 

When Do Synchronization Problems Occur?
The problem of the gradual drift is most likely to occur when the pause/resume button in 
the capture window is not used for extended periods of capture. These buttons start a new 
video file each time they are used, so they can re-synchronize the video and sound. Using 
the procedures below may not be very useful in this situation, since there are variable length 
sections of video and sound and synchronization in one area may lead to slight misalignment 
in others. Fortunately, the contracting and expanding procedures work best for movies created 
when the pause/resume button are not used because any drift is constant across a single 
movie file.

In the main menu bar select Edit > Equalize 
track times. This can only be done after 
the movie capture. However, it is not as 
accurate as equalizing during capture if 
your movie is made from more than one file. 
You can choose to make the equalization 
permanent if your movie is attached to a 
timeline window. This procedure stretches 
or contracts the length of the sound track 
to equal the length of the video track. 
This feature is also useful for resetting the 
tracks when you have nudged, expanded, 
or contracted the sound track and lost a 
synchronization point altogether.

In preferences, under Capture, select 
“Equalize video and sound tracks when 
capturing”. This will equalize the length 
of the sound and video tracks during the 
movie capture process (even if the pause 
button is used). In general, the sound 
track tends to be shorter than the video 
track, so this function attempts to keep 
them the same length. This setting is 
turned on as a default. 

1 2
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A. Synchronization of audio that is offset the same amount throughout a movie.
 1.  Move the timeline cursor to a section in the movie, near the start of the 

movie that can be used to evaluate the synchronization.
 2. Zoom in the timeline, turn on movie loopining.
                                        (in the main toolbar,) and play the timeline movie
 3.  If the sound is slightly ahead of the video, select Edit > Nudge sound 

track right (CONTROL+OPTION+COMMAND+R). This nudges the sound 
track one frame to the left. Hold down the keys to repeat the nudge 
continuously.

 4.  If the sound is slightly behind the video, select Edit > Nudge sound 
track left (CONTROL+OPTION+COMMAND+L). This nudges the sound 
track one frame to the right. Hold down the keys to repeat the nudge 
continuously.

 5.  When you use these features the video and sound will pause, move in 

the direction specified and resume play. If the video is attached to a 
timeline then Studiocode will try to update the movie resource, so the 
change is permanent. 

 6. Save timeline.

B.  Synchronization of audio that is gradually drifting throughout a movie.
 1. Move the timeline cursor to a point near the end of the movie. 
 2. Zoom in the timeline, turn on movie looping  (in the main  
  toolbar,) and play the timeline movie. 
 3.  If the sound is slightly behind the video, select Edit > Contract sound 

track (OPTION+COMMAND+L).
 4.  If the sound is slightly ahead the video, select Edit > Expand sound 

track (OPTION+COMMAND+R).
 5.  When you use these features the video and sound will pause, move in 

the direction specified and resume play. If the video is attached to a 
timeline then Studiocode will try to update the movie resource, so the 
change is permanent.

 6. Save timeline.
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Add Capture Event to iCal
Movies can be captured using iCal events. Follow these steps to set up movie to be captured. This is 
useful when you are not going to be at your computer when the performance is happening and you 
want to setup a queue of movies to be captured consecutively.
1. Choose Capture > iCal Capture  from the main menu bar to open the iCal Capture window.

2. In the iCal Capture window, choose a date for the event by clicking on the graphical calendar.
3. Set the start and end time using the appropriate controls. 

As a convenience, set the start time and use the slider to set the end time. If a longer end time is 
required, increase the end time manually.

4. Input a name in the File name text box to be used for the captured !le.
5. Press the Add to iCal button in the toolbar.
iCal will launch and a new calendar will be created called Studiocode if one does not already exist. 
An event will be added to the calendar using the settings from the iCal Capture window.
The event has a speci!c naming convention that must used.

The movie !le name will become the text inside the quotes. For instance, if the !le name in the iCal
Capture window was “Arrest Simulation”, the iCal event will be named, <capture>”Arrest Simulation”. 
The resulting captured !le name will be Arrest Simulation.SCpkg. If this naming convention is not 
used, Studiocode will not capture properly. If you want to rename the event, change only the name 
between the quotes in the iCal event.
The event will trigger Studiocode to open 1 minute prior to the start of the event. Then using the 
start and end times set in the event of the Studiocode calendar, the capture will start and end.

Note: Simultaneous events cannot be captured at the same time. Also, if using MobileMe synching and mulitple capture 
computers, be careful not to sync the same calendars to all the machines.
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Delete a Movie

Movie files are generally quite large, so space on your hard drive must be managed and 
organized especially if you do not have any external storage.

1. Drag the movie package to the trash can in the dock.
2. Make sure Finder is the active by clicking on the desktop. 
3. Select Finder from the main menu bar and choose Empty Trash.
4.  The Finder shortcut to trash a file is COMMAND+DELETE. To empty the trash, the 

shortcut is SHIFT+COMMAND+DELETE.

When you delete a movie file, we recommend saving the timeline file, so you can link it back 
to the movie. Timelines are very small data files, often no more than 20KB. It is a common 
practice to export the video to a dvd or tape for archiving purposes, then recapture the video 
and match the coded information back to movie. To do this, create a folder, call it Timelines, 
then open a movie, click on the timeline window and select File > Save as. Save the file in the 
Timelines folder. Now, you have your timeline data saved and it can be matched back up to the 
video at a later date.
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Linking Movies

If you want to re-capture a movie and link it to a saved timeline, you need to re-establish the 
link between the two files.

Link a Re-Captured Movie to a timeline
1.Open a timeline file.

2. Studiocode will not be able to find the original linked 
movie.

3.Click OK.

4. Use the open dialogue box to locate the movie. This 
links the re-captured movie with the codes.

5. Save the timeline once the link has been established.

Link another Movie to a Timeline

You may also wish to link more than 1 movie to a timeline.  With the timeline open :
1. From the Main Menu select  File>Link movie to timeline window.
2. Follow the prompts to link the selected movie to your timeline.

Align Instances after Re-Capturing a Movie – Nudge Right Or Left 

When you have re-captured a movie and re-linked it to a timeline, you may find the instances 
in the timeline don’t line up with the relevant parts of the movie.

To correct this:
1. Press SHIFT+COMMAND+R to nudge the instances to the right. This moves all the instances 
one frame to the right. Hold the keys down to repeat the nudge continuously. The operation 
will accelerate the longer the keys are held down.

2. Press SHIFT+COMMAND+L to nudge the instances to the left. This moves all instances one 
frame to the right. Hold the keys down to repeat the nudge continuously. The operation will 
accelerate the longer the keys are held down.

Using the Mouse to slide and move instances in the Timeline

When importing data from external sources, it is almost always necessary to push the instances 
around to align them to the movie. There are 4 convenient mouse driven features to accomplish this.
1. Set the playhead at the start point of an instance, hold down CTRL+COMMAND+Z, then click 

and drag the playhead to point in the video where the instance should start. All the instances in 
the timeline will move also. In most cases, this should synchronize all instances in the timeline.

2. Sometimes it is necessary to remove gaps between sections of instances in the timeline. This 
is common if all the movies captured were paused at breaks in the action and the coded data 
was time was not paused. To removed the gaps, set the playhead to the start time of the !rst 
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instance after the gap, hold down CTRL+COMMAND+X and drag the playhead to the left until 
the instance aligns with the movie.

3. Similar to CTRL+COMMAND+X, the playhead can be set at the last instance’s end time 
preceding the gap, then choose Edit > Remove unused instance time to right of playhead 
(OPTION+SHIFT+COMMMAND+L)

4. If a mistake is made using “Remove unused instance time to right of playhead”, the instances 
can be nudged back by holding down OPTION+SHIFT+COMMMAND+R. All the instances to the 
right of playhead will nudged to the right, creating a gap.

Adjust Placement of Selected Instances

Instance adjustments can add or subtract time to any selected instances in a timeline. In the 
main menu bar, choose Edit > Instance adjustments.  Mark In, will add or subtract time from 
the beginning of an instance.  Mark Out, will add or subtract time from the ending of instance. 
Nudge clips will move the selected instances. Use a minus sign in front of the number to 
nudge clips to the left.

Click on the adjust button once to make 
the adjustments that are ticked. The adjust 
button can be clicked on as many times as 
required to make the necessary adjustments. 
It will continuously apply the adjustments.
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Remote Communications

A flexible network feature, Studiocode remote communications are designed to provide one 
or more computers the power to control information on, or share information with, multiple 
computers during the capture and coding process. It can start, pause, resume, and end capture 
on client computers over a local area network or even over the Internet. 

Remote communications requires networking configuration. We recommend running this 
feature over a gigabit ethernet network. This will insure that the best possible network 
environment is in place. Wireless networks can be employed, but suffer from drop out 
and range problems especially in highly populated areas where there are a lot of mobile 
communication networks and active devices. For purposes of explaining this feature, we will 
assume an ethernet network configuration is in place and connected as described below.

Before attempting to network your computers, we strongly recommend consulting the IT 
department or Sportstec. The networking side of things can be quite tricky as every network is 
setup a little di"erently and might have some quirks that could present some real problems. 

Server And Client

The key to setting up this feature is understanding the roles of the Server and Client as we 
define them. 

A Server is a computer that sends commands to a Client. 
A Client is a computer that executes the commands sent by a Server. 
A computer can be both be a Server and a Client at the same time.

Setting Up a Basic Network

Each computer in the proposed network will need to be con!gured for this particular network. Each 
computer will be assigned a static IP address for this network. (If the computers are already part of 
a network, they will already have a unique IP address, which could be used. If the computer(s) is/
are not part of a network, or a new computer is being added to an existing network, we strongly 
recommend you seek the assistance of your IT consultant or contact your Studiocode representative 
before attempting to progress any further.) The IP address can be found in the networking panel of 
the computer System Preferences.

1. Navigate to the Network Preferences panel:
a. Click on the apple in the upper left hand corner of the screen.
b. Choose System Preferences... from the menu.
c. Click on the Network icon in the System Preferences panel.
d. Click on either “Ethernet” or “Airport” in the list of the Network Preferences panel 
depending on whether your connection is to be hardwired or wireless.
Click  the “Advanced” button 
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Network Locations
A handy Mac OS feature is network locations. Locations can be switched quickly to 
configure the system from one network environment to another.
1.  Open network preferences panel in System Preferences.
2.  Click on the Location menu in the top of the panel and choose Edit Locations...
3.  Add a new location and give it a name suitable for the network environment.
The newly created location will have all the settings that are currently set in network 
preferences panel. If any changes are made, the changes will be saved for this location.
To quickly switch locations, click on the apple in the upper left corner, choose Location and 
select the proper network environment.

2. Con!gure the Server computer Ethernet or Airport port to a static ip address.

a. Con!gure = Manually
b. IP Address = 10.0.1.1 
c. Subnet Mask = 255.255.255.0 
d. Press the Apply button.
e. 

3.     Con!gure the Client computer(s) Ethernet or Airport port to a static ip address.

a. Con!gure = Manually
b. IP Address = 10.0.1.2 
c. Subnet Mask = 255.255.255.0 
d. Press the Apply button.

Connect the computers using an ethernet 
cable if Ethernet is con!gured.
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Preferences for Remote Communication

Open the Communication Preferences by clicking on the Preferences button in the 
Communications window or by choosing Studiocode > Preferences then click on the 
Communication icon in the toolbar.

The “Stop/Disable all communications” checkbox  option is a universal network security option. This 
preference is checked by default so when you access the Preference Window for the !rst time the 
Preference window will be unavailable. You will be required to uncheck the box and then either 
enter a password chosen for the network, (for a completely new network,) or enter the password of 
the existing network.  You will now be able to set the remainder of the preferences for your network 
to operate. See the explanation below regarding this function, but we recommend that this 
checkbox be activated when the network is inactive.  

Name/Description

Provide the computer with a name for the network. This is the name that will appear in the
Communications window of other computers connected to the network, to indicate whether 
or not you are connected. Use a name that best describes how the computer will be used eg. 
Client computer 1  or Server computer.  This will make it easier to identify computers in the list.
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Password

Set the password and verification field for the computer for this network.  NB. This is not a 
“system password” - it is a password for this Studiocode network only.  It is common practice to 
set all computers in the network to the same password, so the auto connection feature can be 
used.

Port Settings

Port settings can be changed here. Studiocode uses 9093 which is a port left undefined by 
networking standards. When setting up for Internet remote communications, this may be 
changed to suit firewall rules. Be careful when changing this setting even on a local area 
network. Changing this could cause serious problems for a network where other services may 
be running over the same ports. Consult the IT department before changing this number.

Default Password for Auto Connection To Clients

Tick the box next to Use same password as default for auto connection to clients. This will try 
to connect with clients using the same password that is set above for the computer. A very 
convenient option to use when there are multiple clients to connect.

Allow Servers to Start/Stop Capturing

Tick this box to allow connected servers to start/stop capture on the computer.

Allow Servers to Pause/Resume Capturing

Tick this box to allow connected servers to pause/resume capture on the computer

Allow Servers to Update Capturing

Tick this box to allow connected Servers to update capture
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Do Not Show Errors As They Occur

Tick this box to stop the error log from popping up during remote communications. Keep this 
option ticked unless trouble shooting is required.

Do Not Connect With Clients

Tick this box when the computer will be acting only as a client. The computer will not act as a 
server and send any commands to any clients. Commonly used when computer is acting as a 
client only. DO NOT CHECK THIS BOX  if you are a Server computer in the network.

Stop Servers Connecting To This Computer
Tick the box to stop all servers from connecting to the 
computer. The computer cannot be a client when this 

ticked. Commonly used when the computer is acting as a server only.

Disable Automatic Connection To Clients
Tick this box to stop auto connecting to clients. This 
stops any attempt to find and connect with clients 

using Bonjour technology on the network. When this option is ticked, all clients must be 
added manually.

Use AMX Communication Protocol
The AMX communication is available to users that 
have an AMX system with the custom protocol 
code installed on the AMX control system

Remote Communication Security

Stop/Disable All Communication
Tick this box to stop all remote communications. 
We highly recommend that when remote 

communications are not being used that this box is ticked. Accidentally starting capture or 
code button pushing could be very problematic for other computers on the network.
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The Communication Window

Open the Communication window by choosing File > Communication window.

Either enter a password chosen for the network, (for a completely new network,) or enter the 
password of the existing network in the dropdown panel.The function of the dropdown panel 
is for you to either set or change the communications password for your network.

The communication window is where Client computers can be added, suspended, removed 
and edited. Errors and logs can be accessed for trouble shooting or basic monitoring.  You may 
also access the Preference panel from here too.

All available and connected Clients and Servers are shown in this window. The number of 
connected Clients and Servers are shown in the list on the left edge of this window.

NOTE: If remote communications are required to be sent over the Internet, IT consultation will be a must. 
This will require a high level of network experience and is a very involved setup. Please contact Studiocode 
to get more information on setting up remote communications over the Internet.
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Connecting To Clients For Remote Communication
Clients can be added and connected in two ways. Automatically or Manually.

Automatic Connection

Click on the Clients button in the list on the left of the Communications window. Clients with 
remote communications enabled and servers with automatic connection to clients enabled 
will appear automatically in the main list of the communications window. If the default 
password for auto connect option is set, it will connect automatically too. 
The Bonjour icon will appear if connected automatically. If this is not set, then double click
on the computer name and set the password in the window. Tick the Initiate recording on 
client computer if capture needs to be started on the client. A red button will appear 
next to the computer name when initiate capture is configured. When the client is connected, 
the status column will report connected other wise it will report password required or unable 
to connect to IP or Port.

Manual Connection

Manually adding clients is used when no clients are readily available on the local area network 
or the client is being to connected to over the Internet via a public IP address or VLAN. This 
allows for all client configuration to take place before connecting to any network.
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Click on the Clients button in the list on the left of the Communications window.
Add the clients manually by clicking on the Add button in the window.
Add the IP address or URL for the 
client, set the password, then press 
the Test button to check whether 
the client is ready to communicate. A 
timeout duration can be set to better 
synchronize communication. A longer 
timeout duration may need to be 
set if connecting over the Internet or 
there is heavy traffic over a slow network. When the password is set and the test checks out 
OK, press OK. If the test does not report back a positive result, the client can still be added. The 
client will be added in the list of clients. When a client is added in this fashion, the computer 
name will not appear in the list. Remember to set the initiate capture option if required.

Capturing Using Remote Communication

Once the clients and servers are connected in the Communications window, capture 
commands can be initiated through the Capture window. Open the Capture window to view 
or set up the necessary buttons in the Capture toolbar.

There are two capture remote communication buttons in the Capture window, Communicate 
and Communicate Only. These buttons are not a part of the default of the toolbar set and must 
be added by customizing the capture window toolbar, (see the capture window section on 
customizing the toolbar to add these buttons to the capture window.)

The Communicate capture button will initiate a quickstart capture locally 
(server) and remotely on the connected clients with the initiate recording option 
checked. All the capture functions in the local capture window: stop, pause and 

resume will both work on the local (server) capture and the remote (client) captures.

The Communicate Only capture button will only send capture commands 
to the clients and will not initiate the local capture. The captured files will be 
found in the preferred quickstart capture folder. They will be named using a 
date stamp according to the system date. To set the Quickstart capture folder 

choose Capture > Quickstart set folder from the main menu bar along the top of the screen.
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Remote Communication Coding

The most powerful and simple feature of remote communications is the ability to send 
button push commands from a server’s code window to a client’s code window. This means 
that multiple people can be coding on different computers, all feeding information to each 
other’s timeline or into a single timeline over a network. Using the Internet, capture and 
coding processes can literally be done across the globe.

The button push commands are sent from server computers to client computers automatically 
when code mode is activated in a code window. There are no configuration settings in the 
preferences for this feature of remote communications. The only things that are required are 
the connection to a client and the identical code windows on each computer.

There are a few items to note.
1.  Use identical code windows on each server and client. Remote button pushing is when a 

server code window sends the push command to the matching client code window. The 
client computer locates the button to be pushed down and pushes it down. If the same 
code window is not open on the client computer, no buttons will be pushed down, so no 
instances will be created in the timeline of the client computer. 

2.  Multiple windows can be open at one time. It is a good practice to break down a single large 
code window into multiple smaller ones. This can make the coding process focused and 
accurate for the people coding. 

3.  Do not set the same hotkeys for multiple windows. When multiple code windows are open, 
the hotkeys may push down the wrong buttons if the same ones are set in the buttons of 
the windows.

4.  Capturing does have to occur locally on a server computer. Connect to a capturing client 
with the same code window open, open the same code window on the server and  activate 
code mode. The button pushes will start on the client even though the server is not 
capturing.

Imagine 20 or more people could be viewing the same event, coding on separate computers 
in different geographical locations while all the data is being pushed into one capturing client. 
The possibilities for this feature are endless...
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Part 4  -   Review / Analysis
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Movie Playback

Playing a movie is easy, you can go to any part of the movie whenever you like with a click of 
the mouse. You’ll be there instantly, no need to fast forward or rewind.

Playing any Movie
There are five ways to play a movie:

Pause any Movie 
There are five ways to pause a movie:

Note: With a roller mouse place your cursor over any movie window and roll up or down to 
play or pause movie playback. With two finger scrolling turned on, put two fingers on the track 
pad and push fingers up to play and pull fingers down to pause movie.
Change the playback speed of a movie by holding down COMMAND, place the mouse over the 
window and two finger scroll on the track pad or use the wheel mouse.
The state of play, whether the movie is paused or playing, will re-engage after any rewind or 
fast forward action. 

Press the UP 
ARROW on 
the keyboard.

Click on 
the movie 
window.

Click on the 
pause icon    
on the tool bar.

Press the 
SPACE BAR on 
the keyboard.

Press the 
DOWN 
ARROW on 
the keyboard

Press 
CONTROL+K 
on the 
keyboard.

321 4 5

Double click 
on the movie 
window.

Click on the 
play icon 

on the main 
tool bar.

Press the 
SPACE BAR on 
the keyboard

Press 
CONTROL+L 
on the 
keyboard.

321 4 5
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View the Movie Frame by Frame 

There are two ways to view a movie frame by frame:

Play a Movie in Slow or Fast Motion

1.  The tool bar has a speed slider, click and drag the sliding indicator to the speed you 
require.    All movies will be played at this speed.

2. Press and hold the LEFT or RIGHT ARROW keys

Go to a Speci!c Part of the Movie
There are three ways to go to a specific part of the movie:

Movie Playback Keyboard Control
Once a movie is created or linked to a timeline, you can use many key combinations to play it 
at different speeds.

· UP ARROW plays the movie.
· DOWN ARROW stops the movie.
·  RIGHT ARROW moves the movie forwards by 1/10 sec frame by frame. Hold it down 

for continuous slow motion movement forward.
·  LEFT ARROW moves the movie backwards by 1/10 sec frame by frame. Hold it down 

for a smooth rewind action.
·  HOME moves the playhead to the beginning of the movie.
·  END moves the playhead to the end of the movie.
Pressing the modifier keys; COMMAND, SHIFT, OPTION, & CONTROL plus LEFT OR RIGHT 
ARROW will move the playhead at different increasing speeds. Another way to move the 
playhead around is press CONTROL+L, CONTROL+K, or CONTROL+J. CONTROL+L will play the 
video forward, each time it is pressed the movie will play faster. CONTROL+J works the same 
way, but in reverse. CONTROL+K will pause the video.

Use the Fast Forward or 
Fast Rewind Buttons on 
the main tool bar.

Drag the 
playhead in the 
timeline to the 
required point 
in the movie.

Press the RIGHT or LEFT 
ARROW keys to move 
the playhead though the 
movie.

321

 With the movie paused, Press the LEFT 
or RIGHT ARROW keys to view the movie 
frame by frame.

Click on the Step Forward/Back Button on 
the main tool bar.

21
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Creating Instance Movies

You can create an instance movie in the timeline from:
· A single instance.
· All instances in a single row chronologically.
· Selected instances across multiple rows chronologically (Merge rows).
· Sequential rows in order of row number and the selected rows (Sequential rows).
· Selection order in a single row or across multiple rows (Selection order).

Play a Single Instance 
1. Double click on the instance in the timeline or select an instance and press the Make 
movie button in the timeline tool bar.

Play All Instances in a Single Row
1. Select the row of instances by clicking on the row number. 
2.  Click on the Make movie button in the timeline tool bar. All instances in the row 

will play in chronological order. Alternatively, after selecting the instances, press 
OPTION+COMMAND+M on the keyboard to create the instance movie.

To make it even easier, double click on the row number and an instance movie will be created 
from all the instances in the row.
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Merge Rows, Sequential Rows, and Selection Order
There are 3 different ways to play instances across multiple rows by changing the make movie 
method in the timeline. By default, Merge rows is selected. To change, click on the square 
button in the upper left corner of the timeline window. Remember to press the Make movie 
button or use the shortcut OPTION+COMMAND+M.

Merge Rows

Merge row creates instance movies in chronological order of the timeline. When multiple 
instances are selected in different rows, the merge rows feature will merge the instances and 
create chapter markers where instances overlap.
1.  Hold down COMMAND to select multiple rows. Select the row of instances by 

clicking on the row number.
2.  Click on the Make movie button on the timeline tool bar. The instances will play in 

chronological order, alternatively use the shortcut OPTION+COMMAND+M.

Sequential Rows

Sequential rows creates instance movies in row order of the timeline for all selected instances. 
When multiple instances are selected in different rows, the sequential rows feature will start 
from the lowest row number and proceed to the highest row number. All instances in each row 
will be played in chronological order.
1.  Organize the timeline rows by dragging on the row number.
2.  Select the Sequential rows feature in the timeline.
3.  Hold down the COMMAND key and click on the row number to select multiple rows.
4.  Click on the Make movie button on the timeline tool bar. The instances will play 

according to their row order.

Selection Order

Selection order creates instance movies in the order that instances are 
selected in the timeline.
1.  Select the Selection order feature in the timeline.
2.  Hold down the COMMAND key and click on the instances in the order 

you want them to play in the instance movie. As each instance is 
selected, it is labeled with a number [1], [2], [3]...

3.  Click on the Make movie button on the timeline tool bar. The instances 
will play according to their selected order.
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Presenting Instance Movies
Any timeline movie or instance movie can be presented in full screen.

Present a Movie in Full Screen
There are three ways to present a movie in full screen:

Stop Presenting a Movie in Full Screen
To stop presenting a movie in full screen press the ESC key on the keyboard.

Loop Instance Playback
Looping an instance repeats it continuously
1.On the main tool bar, select the Loop button. It will change from         to        .
2.Double click on the instance to play it. ..
NOTE: When the looping feature is turned on, the timeline movie will loop also. If the timeline 
is zoomed in, it will loop within the zoomed range.

Adjust the Movie Volume
1. On the main tool bar, click on the Volume button.          Drag the control button to the desired 
volume.
2. In an instance movie, click on the speaker icon in the bottom left of the movie window. Drag 
the control button to the desired volume.
1. Use the Function keys on the keyboard to increase or decrease volume.

Resize Movie Window
1.  Select the movie window.
2.  Choose Reduce movie size or Increase movie size from the Windows menu in the main menu 

bar, or use the shortcut keys, SHIFT+COMMAND+ <key  ,  or SHIFT+COMMAND+ >key.
 
Note: A timeline movie has 2 rectangle icons in the bottom left of the window. These can be 
clicked to change the movie size also. If CONTROL is held down when these are clicked, the 
timeline and movie will arrange automatically.

Select Windows from 
the main menu bar and 
choose Present movie.

On the main tool bar, click 
on Present movie button. 

This will present the movie 
full screen.

To play the movie in 
full screen presentation 
mode, select the movie 
window, and press the 
COMMAND+M keys on 
the keyboard.

321
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Exporting Movies

DV Video Export

If a movie is in the DV format, then you can export using the DV export feature in the main tool 
bar. This will export the selected movie to a camera or an analog/digital convertor. If the movie 
is in a different format like MPEG-4, it will not export to the external devices. 

1.  Create the instance movie you wish to export.
2.  Select the instance movie, so it is the active window.
3.  Set your device to accept digital input.
4.  Click on the Export to... button    in the main tool bar. If the movie is exporting 

properly, the arrow in the icon will change from yellow to red. The 
video will appear in the camera or the device connected to the convertor.

5.  Play your instance movie. If you are exporting to a tape recorder or DVD burner, 
queue the movie to the beginning on the computer, press record on the recorder 
or burner, then hit play on the computer. For presentation, you can use all the 
fast forward, fast rewind, frame by frame, and slow motion features. If you switch 
instance movies, press the “Export to” button again to begin exporting.

Video Out Export

When movies are not DV format, the only way to export full screen video to a recorder, burner, 
or projector/tv monitor is to use the video out port of the Apple computer. Plug in the external 
device using the DVI, Mini-DVI, or Video Out port on the computer. You may need to use a 
convertor cable to match the input of the external devices. With the hardware connected, 
follow these steps to enable the video to be exported.
1.  Open the Display preferences in the System Preferences of the computer. Click on 

the blue apple in the upper left corner of the screen, choose System Preferences 
from the menu.

2. Click on the Displays icon in System Preferences.
3.  In the Display preferences, click on the detect display button. This will export the 

desktop to the external device. The image will appear on the external device.
4.  There are two ways to export using the display settings. The first is mirroring the 

desktop, so that what is on the main screen of the computer is presented. There is 
a check box in the display preferences that will turn mirroring off or on. The second 
is extended mode where a secondary monitor is available to use as another screen 
for video export. The secondary display position can be moved in relation to the 
primary screen in the display preferences.

5.  If mirroring is enabled, the exact image on the computer will be displayed on the 
secondary monitor. This is a common way to set this up as users tend to lose the 
mouse on the secondary monitor and find it difficult to manage two monitors 
especially when they are not side by side. If extending the desktop to a secondary 
monitor is used, an instance movie when presented in full screen will be exported in 
full screen to that monitor.
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Using Instance Movie Chapter Markers

When an instance movie is created from multiple instances in a timeline, each instance in 
the instance movie is marked by a chapter marker. There are two ways to jump through the 
chapter markers.
1.  In the instance movie, press the TAB key to 

move forward to the next chapter marker. 
SHIFT+TAB moves backwards to the previous 
chapter marker.

2.  Click and hold on the chapter menu in the 
bottom right corner of the instance movie. 
A drop down list of chapter markings will 
appear. Click on the instance you want to view.

NOTE: A similar feature is in the timeline. 
Select a row of instances, press CONTROL+TAB 
to jump to the beginning of each instance. 
SHIFT+CONTROL+TAB will move to the previous instances.

Viewing Text Labels In An Instance
Text labels within an instance can be viewed in two ways.

Open the Edit labels window by selecting 
Edit instance labels... from the Edit menu 
in main menu bar. Click on an instance 
and the labels will appear in the Edit labels 
window.

Hover the mouse cursor over the instance 
in the timeline, the text labels will appear 
in the strip above the playhead bar.

1 2
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Manipulating Movies

Closing Movie Windows
The most basic movie operation aside from opening a movie is closing one. To close a movie 
window, press the red button in its window bar. However, a more convenient way to close movies 
is to use the shortcut, COMMAND+I. This shortcut closes all open instance movies instantly. When 
analysing instances from the timeline, a lot of instance movies can be open at one time; clicking on 
the red button to close them all can take awhile. Using this shortcut, makes this a lot quicker. This 
function can be found under the Windows menu, Close all instance movies.

Movie Window Sizes and Proportions
One of the more basic manipulations of a movie is to change the size. Studiocode changes 
the size based on halves of the original movie size. The change a movie window size, press 
COMMAND+SHIFT+ on the keyboard to increase and COMMAND+SHIFT+, to decrease. The same 
function can be found under the Windows menu: Reduce movie size and Increase movie size. In the 
menu, the shortcuts for this are COMMAND+> and COMMAND+<. > and < are inputted by holding 
down SHIFT+. and SHIFT+,.

To reset the movie window to its native size, choose Windows > Natural movie size menu item.

Movie proportions can be changed by using the: Movie proportions 16x9, Movie proportions 4x3 
and Movie proportions - native. Using these features will either stretch or shrink the movie window 
according to the movies aspect ratio. It is usually very obvious when these settings should be used. If 
a movie’s aspect ratio is 16x9 and the movie window is set to 4x3, objects in the movie will appear to 
be thinner that they naturally might appear to the human eye in real life. If the movie’s aspect ratio is 
4x3 and the movie window is set to 16x9, objects will appear wider than they might actually appear 
in realy life.

Overlay Two Movies 
Using the overlay feature you can take two 
instances and put them on top of each other to 
analyse the di"erences in the movies.

1. Create two separate instance movies.

2. Choose Overlay instance movies from the 
Windows menu in the main menu bar or 
press the shortcut OPTION+COMMAND+Y.
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Align Two Overlaid Movies

1. Create the overlaid movies as above.
2. Press the SHIFT+OPTION keys, click in the movie frame and drag the top movie to align the area of 

interest with that of the second (lower) movie.
3. When you play the movie the top and lower movies will stay in this aligned position.

Change Transparency Level of Movie Windows

Choose Reduce transparency or Increase transparency from the Windows menu in the main menu 
bar. Use the shortcut keys CONTROL+OPTION+9 or CONTROL+OPTION+0, by pressing these 
repeatedly you can vary levels.

Flip an Instance Movie

1.Create an instance movie.

2. Choose Flip movie horizontally from the 
Windows menu in the main menu bar. The 
movie frame will be #ipped horizontally.
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Stacking Instance Movies

“Stacking” is the process of projecting more than 1 movie in the movie window at the same time.
Two or more instance movies can be stacked in various con!gurations in one movie window. The 
only limiting factors to how many movies can be stacked are the computer’s screen size and speed. 
Each viewing angle in the stack movie can be moved around the stack. The stack con!guration can 
be changed; 1x2, 2x2, 4x1, etc. Any viewing angle in the stack can be zoomed and the other movies 
in the stack are hidden from view.
1.  Open a timeline with some coded instances. Find three similar instances to view and 

make 3 separate instance movies from each one.
2.  Set the playhead on each movie to a point at which all three movies will be in sync. This 

might be one second prior to a particular event.
3.  With all the sync points set in each instance movie, press COMMAND+Y or choose Stack 

instance movies from the Windows menu in the main menu bar.
4.  A stacked movie will open up with all three instances in a 3x1 con!guration.
5.  To change the stack movie con!guration, press CONTROL+COMMAND and click in the 

stack movie window. Select 1x3 or 3x1 from the pop up menu.
6.  To move a viewing angle location in the con!guration, press down COMMAND and click 

and drag the viewing angle to another location in the window.
7.  To zoom an individual angle, press OPTION+COMMAND and double click on the angle in 

the movie window. Use the same procedure to zoom out to viewing all angles at once or 
press the stack movie button . The keystroke and mouse clicks work in full screen 
also.

To  make viewing angles in the stack easier and avoiding constant rewinding of the movies, there are 
some playback features built in. 

For an instance movie with chapter markers.
1.  If the movie is playing and it is zoomed, the movie jumps back to the previous chapter marker.
2.  If the movie is stopped and it is zoomed, the movie only changes views and does not jump.
For an instance movie without chapter markers or a timeline movie.
1.  If the movie is playing and it is zoomed, the movie jumps back 10 seconds by default. This time can 

be adjusted in the movies preference panel.
2.  If the movie is stopped and it is zoomed, the movie only changes views and does not jump.

NOTE: If you wish to use this feature, we recommend using the most powerful computer that is 
available. When stacking 4 or more DV movies together, plan on using a desktop computer not a 
portable. Playing multiple movies simultaneously is very cpu and hard disk use intensive.
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Stacking Timeline Movies

Multiple timelines can be stacked to create a single timeline and linked stack movie. After 
capturing and coding multiple synchronous camera angles of an event, each timeline can be 
merged into a single stacked timeline.

Stacking timelines merges all the coded instances in the timelines that are being stacked. If the 
same rows exist in each timeline, the instances and rows will be merged into one in the new 
timeline.

Stacking timelines requires synchronous video. So, it is important that all captures are 
continuous through the whole event. Pausing and resuming capture will cause the movies to 
be out of sync. We recommend starting capture 1-2 minutes prior to the start of the event. It is 
also a good idea to capture audio.

Audio is a great way to !nd the synchronization point of a movie. If all cameras are not pointed 
at the same thing when the event starts, audio can provide solid clues to !nd a worthy sync 
point.

Stacking timelines is basically the same process as stacking instance movies.
1.  Close all windows except for the timelines and movie windows that are going to be stacked.
2.  Find the sync point in each timeline and position the playhead on each timeline to 

that point. It is a good idea to move the playhead back a couple of seconds by pressing 
OPTION+LEFT ARROW on each timeline after setting the sync point. This will give a little 
extra movie time prior to the !rst event that might need to be coded.

3.  Choose File > Stack timeline movies.
4.  Name the !le and save it. Remember to check what type of package is being created when 

you save. Standalone, reference and compressed are all options. We recommend creating 
a reference package !rst, so the results can be checked quickly. Do not delete the original 
movies until you have saved it as a stand alone package.

When saving standalone packages, check the !le size, stacked timelines can create some very 
large !les.
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Stack Movie Zooming

The stack can be zoomed in a Timeline, Instance, or full screen movie. 
• Hold down OPTION+COMMAND and double click on the view you want to zoom in, all other 

views will be hidden until you zoom back out.
•   To zoom out back to the stack, press OPTION+COMMAND and double click on the zoomed in 

view.

Multiview Hotkeys can be con!gured so the zooming can be done by pressing keys on the keyboard.
1. Access the Preferences for Multiview Hotkeys in the Movies panel of the Studiocode Preference. 

Choose Studiocode > Preferences, then press the Movies Icon In The Toolbar
2. Tick the Multiview hotkeys tick box to turn the feature on, then set the Hotkeys for the switching.
There are 12 possible views available for zooming using Hotkeys.
• Click in the empty buttons to the right of the Movie numbers. Then press a key on the keyboard 

to set the Hotkey.

When a stack movie is open and a multiview Hotkey is pressed the view will zoom. To unzoom back 
to the stack view, press the Hotkey again. This can also be done by clicking on the grid icon in the 
top of the movie. The movie views are numbered from left to right, top down in the grid. 
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Changing Stack movie view locations in the grid

Hold down COMMAND while clicking and dragging on the view. Drop the view in the approximate 
location of the grid to relocate.

Changing Stack movie grid layout.

Hold down CTRL+COMMAND and click on the Stack movie. Choose the grid layout from the popup 
menu. If using a right click mouse, hold down COMMAND, then right click on the stack movie and 
choose the grid layout from the popup menu.

Stack movie Playback Preferences.

Refer to the Movie Preference Window section on pages 12 - 13.

For an Instance movie with Chapter Markers in a Stacked Movie View.
• If the movie is playing and it is  selected. It will expand the view (zoom in) if the view 

is of all the movies in the stack. It will contract the view (zoom out), if the view is of an 
expanded view in the stack.  The movie time will jump to the previous chapter marker at 
that beginning of the chapter for both of the view options described above.

• If the movie is stopped and it is selected, (for both an expanded or contracted view), the 
movie only changes view and does not jump to a chapter marker.

For an Instance movie without Chapter Markers or a Timeline movie.
Note: In the case of an Instance movie, this will be a movie made of a single instance only.

• If the movie is playing and it is zoomed in or out, the playhead will jump back by the 
number of seconds which have been speci!ed in the Movie Preferences 

• If the movie is stopped and it is zoomed in or out, the movie only changes view and the 
playhead does not jump back 10 seconds.

Making a Movie from a Folder of Movies
Studiocode captures in a series of movie segments, each segment contains a number in the 
!le name: 00001, 00002, 00003, etc. This sequential numbering scheme is also used by tapeless 
video cameras. So, to make generating a single movie from a series of sequentially named 
movie !les easy, the Make movie from a folder of movies can be used.

Place all the movie !les in the same folder, the choose File > Make movie from a folder of 
movies and select the folder. A reference movie will be created with all the segments together 
in sequence according to the number in their !le name. Save the movie as a standalone or 
convert it to another format.
This feature is handy if a movie package has been corrupted or when capture has ended 
unexpeditely. The movie parts can be quickly put back together to create a continuous movie.
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Editing Instance Movies
Instance movies can be edited using delete, cut, copy and paste or drag & drop features. By 
selecting a segment of an instance movie, the segment can be deleted or copied and pasted 
into another instance movie. NOTE: Editing instance movies does not edit the timeline.

Delete a Segment in an Instance Movie

1.  Select a segment in the instance by holding SHIFT and dragging the playhead in the 
instance movie. As the playhead is dragged, the timeline of the instance movie will 
fill in with a darker grey color. The darker grey area is the selected portion.

2.  Press CONTROL+COMMAND+DELETE to clear the selected segment. Or choose 
Delete movie segment from the Edit menu in the main menu bar. An instance movie 
for presentation can be assembled from many different segments of other instance 
movies.

Copy, Cut and Paste Instance Movie Segments

When an instance movie is created from a timeline, the entire length of the movie is selected 
by default. If you move the playhead in the instance movie, you will lose the selection. To 
reselect the whole instance, move the playhead to the beginning, hold down SHIFT, and drag 
the playhead the entire length of the instance movie.

1.  Open two instance movies from a timeline.
2.  In the second instance movie, press CONTROL+COMMAND+C. This will copy the 

selection in the instance movie. If the playhead was not moved, it will copy the 
entire length of the instance movie. If it was moved, it will only copy the frame that 
is currently being displayed.

3.  In the first instance movie, move the playhead to the end and press  
CONTROL+COMMAND+V. This will paste the second instance movie segment at the 
end of the first instance movie.

4.  Repeat this process to continue adding segments to the end of the instance movie.

Note: Segments can be pasted into any part of an instance movie. Position the playhead where 
you want the segment to be inserted and when you copy and paste, it will be inserted at that 
point. The actions of the Keyboard Shortcuts referred to above may also be achieved from the 
Edit drop down in the Main Menu .
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Drag and Drop Instance Movie Segments

To simplify the process, you can drag and drop movie segments from one instance movie to 
another.
1.  Open two instance movies from a timeline.
2.  Position the playhead in the beginning of the first 

instance.
3.  Click and drag from the middle of the movie frame of 

the second instance and drop into the first instance 
movie. The first instance movie will highlight with 
zebra stripes around the movie frame.

4.  The segment will insert at the location of the playhead. 
In this case, that is at the beginning of the first 
instance.
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Combining Instance Movies

A simple way to combine instances in a specific order is to use the Combine instance movie 
feature. This feature creates a new instance movie from all open instance movies in the order 
that they are layered on the screen.
1.  Open 2 or more instance movies in reverse order for which you want them 

combined. Create the second instance first, then the first one. This will layer them 
correctly without having to click on the movie windows to layer them.

2.  Choose Windows > Combine instance movies in main menu bar. A third movie 
window will open that will have both instances in the movie in the order that they 
were layered on the screen.

NOTE: To add another instance to the beginning or end of the new combined movie, close 
the first 2 instance movies used to create the newly combined one. Do not close the newly 
combined instance movie. Open another instance from the timeline, layer it in front or behind 
the open combined instance movie, then choose Combine instance movies. If the new 
instance was in front of the combined one, it will be added to the beginning, if it was behind, it 
will be added to the end. Repeat this process to assemble a full length movie for presentation

Saving Instance Movies

Any instance movie can be saved as a file for presentation, archive, or distribution purposes. 
So, after editing a movie, you can save your work.
1.  Click on the movie that you want to save so that it is the front most window. When 

saving, the front most window will be selected by the software as the window to 
save.

2.  Choose Save from the File menu in the main menu bar. Alternatively, you can press 
COMMAND+S or click on the save button in the main tool bar.

3.  Select the target save location and name the file.
4.  Set the required movie format from the bottom of the save window.

Studiocode stand-alone or MoviePlayer stand 
alone movie formats create files that contain 
all the necessary data to view the movie 
independent of the original movie file. Since 
stand alone movies contain all the necessary data 
to be played on its own, they tend to be large 
files. Stand alone files are required when you wish 
to share the movie with other people on their   

           computers.
Studiocode or MoviePlayer reference to original movie formats create reference files that point 
to original movies. Reference movies are very small in size and save very fast as they do not 
contain any raw video data and thus do not duplicate video data. However, the file must have 
access to it’s original raw movies from which it was created. If you delete the original movie, a 
reference movie will not play. Use reference movies to quickly assemble an edit, then save it as 
a stand alone when you are done.
5.  Click the Save button to save the movie.
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Removing Extra Movie Tracks

There are many types of tracks inside a movie file besides video and audio. Studiocode uses 
text tracks to display transcription text in the movie window. There are situations where this 
data needs to be removed from the movie. To do this, open the movie and choose Edit > 
Remove tracks except video and audio. All tracks not video or audio will be removed from the 
movie. Save the movie after completing this operation. This cannot be undone, be careful if the 
data is important such as subtitles.

Removing extra tracks can help some third party applications open Studiocode movies files 
and the vice versa is true for Studiocode. So, if the movie has text appearing in unexpected 
places, use the feature to clean up the movie tracks.

Multiplying Audio

If the sound track for a movie is too low or high, it is possible to increase or decrease the 
track’s volume. Open the movie that needs the sound track changed, then choose Edit > 
Multiply audio. A dialog will open where the percentage increase or decrease change can be 
set. Setting a value above 100% will increase the volume, values below 100% will reduce the 
volume. Press OK to commit the new setting and save the movie.
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Working with Code Rows

Move a Row

Click and drag from the row number in the timeline.

Select Multiple Rows
1.  Press COMMAND and click on the row numbers  you want to select.
2.  To select a range of rows, select the top row of the desired range, then select the 

bottom row while holding down SHIFT.

Duplicate a Row
1.  Press CONTROL and click (RIGHT CLICK) on the row number you want to 

duplicate.
2. Select Duplicate selected rows from the drop down menu.

Delete a Row
1.  Press CONTROL and click (RIGHT CLICK) on the row number  you want to delete.
2.  Select Delete selected rows from the drop down menu.

Edit Code Row Names
1.  Press CONTROL and click (RIGHT CLICK) on the row number you want to edit.
2.  Select Edit row from the drop down menu. This opens the row properties strip.
2. Type in the new name in the text area.
3.  Use the arrow keys to move up and down rows or press ENTER to move down rows 

and SHIFT+ENTER to move up rows.
4. Press the ESC key when changes are complete to close the strip.

Change Code Name Colors
1.  Press CONTROL and click (RIGHT CLICK) on the row 

number you want to edit.
2.  Select Edit row from the drop down menu.
3.  Click on the color chip to the left of the row name
4. Drag into the color palette and choose a new color
5.  Use the arrow keys to move up and down rows or 

press ENTER to move down rows and SHIFT+ENTER 
to move up rows.

6. Press the ESC key when changes are complete to close the strip.
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Add a New Blank Row to a Timeline
 

Choose Rows > Add row from the main menu bar. The new 
row will be created below the selected row in the timeline. 
Alternatively, you can press the New row icon in the 
timeline tool bar or press COMMAND+N.

Create a New Row from Selected Instances using New Row +
 

Select the instances that you wish to include in a new row, press COMMAND and select 
the instances one by one or click and drag in the timeline to select a group of instances. 

You can also select rows of instances too. With the instances selected, click on the New row + 
icon in the timeline tool bar. 

Create a Combination of Rows

1.  Choose Rows > Create new row from the main menu bar. This opens the Add row window 
where you can select 2 rows to create a new one using different time intersection options.

2.  Name the new row and select where in the 
timeline to insert it.

3.  Click the Combine rows radio button to form 
new row.

4.  In row A, choose the first row you want to use.
5.  Choose the operation that will apply to the 

combination of rows. The type of operation is 
illustrated in the box at the left of the window.

6. In row B, choose the second row you want to 
use and click the Create row button.

AND, OR, or NOT can be used as 
operators. AND will create instances 
where A and B overlap. OR will create 
instances from both rows combining 
where overlaps occur. NOT creates 
instances where A does not exist.

Create New Row Hints
1. For fast alternating dialogue between two people, code one person’s half of the 
conversation, then use the NOT operator, to create the second person’s timeline row.
2. When you want to use more than two rows, create a new row from the first 2 rows, then 
create another row from that row using it as row A and the third row as row B. Repeat this 
again and again to drill down further.
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Sorting Code Rows

Rows can be sorted in a variety of ways, manual dragging up and down being the most 
common. However, using name and color can automate the process and make organizing the 
timeline a lot quicker.

Sort Rows by Name
Choose Rows > Sort rows by name from the main menu bar. All rows will sort by alphabetical 
order.

Sort Rows by Color
Choose Rows > Sort rows by color from the main menu bar. Colors are sorted in order of the 
palette from left to right descending from lighter to darker. The color palette has 600 colors 
and each color has an (X,Y) coordinate. White in the upper left most corner (1,20) and the 
darkest red in the lower right most corner (30,1) define the sorting pattern from left to right, 
top to bottom.

Sort Rows by Color then by Name
Choose Rows > Sort rows by color then by name from the main menu bar. All rows will sort by 
color and then within each color sort by name.

Sort Rows by Number of Instances
Choose Rows > Sort rows by number of instances from the main menu bar. All rows will sort 
according to how many instances are in each row. The row with the most amount of instances 
will move to the first row. The row with the second most amount of instances will move to the 
second row and so on.

Sort Rows in Reverse Order
Choose Rows > Sort rows in reverse order from the main menu bar. All rows will arrange in 
reverse order from top to bottom to bottom to top.

Code Button Colors and Sorting
A great way to make organizing the timeline a quick job is to consider your button colors 
and how they will affect sorting. Use colors with the X coordinates from 1-30 and same 
Y coordinates for similar code buttons categories. Then, use descending Y coordinates 
from 1-20 for grouping different categories. The code window will look like a rainbow, but 
you can quickly sort the timeline using the Sort rows by color feature. So, Teacher action 
buttons might range from (1,16) to (30,16) and Student action buttons might range from 
(1,7) to (30,7). In this example, the Teacher actions will sort to the top of the timeline and 
the Student actions will sort below them.
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Editing Instances in the Timeline
Manually Creating a New Instance
1. Highlight a row by clicking on the code row name or row number. ( If there are no code 

rows, you will need to create a new row.  Refer to page 107 “Add a New Blank Row to a 
Timeline” )

2. Position the playhead at the point in the timeline where you want the instance to start or 
end.

3.  Press down OPTION+COMMAND and drag the playhead in the timeline to the required 
end or starting point.

Note: Using a 2 button mouse, you can hold down OPTION+COMMAND+RIGHT CLICK and 
drag in any row to create an instance. Pressing CONTROL and clicking activates the right 
mouse click. So, you can press CONTROL+OPTION+COMMAND and click & drag in any row to 
create an instance too.
Adjust the Length of an Instance

Instance Edit
1. Select an instance in the timeline.
2. Choose Edit > Instance edit from the main menu bar or 
press CONTROL+E. A movie window will open with left & right 

arrows in each of its upper corners.
3. Press the arrows in the direction required to lengthen or shorten the clip. The upper left 
arrows will adjust the start of the instance and the upper right arrows will adjust the end. 
The instance will update in the timeline as adjustments are made.

Click and Drag
Press OPTION+COMMAND, position the mouse cursor over the 
beginning or ending of an instance. When the cursor changes to arrows 
pointing to the left & right, click and drag the instance to the required 
length.

Trim
The trim feature can be used to quickly adjust start and end times for a row of existing 
instances. It is a sequential process: trim start > end > start > end > start and so on. The 
process starts by setting the first point, if the playhead is set before the midpoint of the 
instance, it will begin by adjusting the start time to the playhead location. When it is set 
beyond the midpoint it will adjust the end time. Once the adjustment is made, it will jump 
to the end time of the selected instance or the start of the next instance.
1.  Highlight the instance and position the playhead to the required start time of the 

instance, not beyond the midpoint or the end point will be trimmed.
2.  Press CONTROL+T, the start time will be adjusted and the playhead will jump to the end 

time of the instance.
3.  Position the playhead to where the adjustment of the end point should be made and  

press CONTROL +T. The playhead will jump to the next instance in the row.
4.  Position the playhead for the new start time and press CONTROL+T. The playhead will 

jump to the end of the instance. Repeat, until all adjustments are made.
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Delete an Instance

Highlight the instance by clicking on it, then press the DELETE key.

Copy an Instance from One Row to Another

1. Press OPTION and click & drag on the instance you want to copy.
2. Drag it to the new row.

Move an Instance from One Row to Another

1.  Copy the instance to the new row by pressing the OPTION and click & drag the instance to 
the new row.

2. Delete the original instance by selecting it and pressing the DELETE key.

Instance Splitting

An instance in the timeline can split at the playhead intersection by dragging the playhead to point 
that the instance should be split into two, then choosing Edit > Instance split.

Instance Adjustments
1.  Select an instance or range of instances by clicking and dragging over the instances in 

the timeline.
2.  Select Edit > Instance adjustments... from 

the main menu bar.
3.  Input the time in seconds for the amount to 

be adjusted. 
4.  Select whether the time will be added or 

subtracted from the instance marks.
5.  Check the mark in or mark out check boxes to 

apply the adjustments to one or both.
6.  Click the adjust button.

Note: If you make a mistake, simply make the opposite adjustment. If you added 3 
seconds to the mark in time of an instance, change the add to a subtract and adjust it back. 
Adjustments can be made up to hundredths of seconds, so this can make some very finite 
adjustments to an instance, hardly possible with a mouse.

4
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Combining Timelines

Two or more timelines can be combined back to back, so analysis over multiple movies can be 
performed very quickly. The combine timeline process creates a reference package. A reference 
package takes up very little space, but remember do not delete the original movies until the project 
is !nished or saved as a stand alone package.
1.  Choose Combine 

timeline movies 
from the File menu 
in the main menu 
bar.

2.  Locate the 
timelines you want 
to combine.

3.  Select and add 
each one in the 
order you want 
them to appear 
into the new 
timeline.

4.  With all the 
timelines added, 
press the Combine 
button.

5.  Name the !le and 
save.

Merging Timelines
There are cases where multiple users have coded the same movie and they must merged together 
to either compare the results of the coding or combine the results of the coding into one timeline. To 
do this, use the merge timeline window feature. The key to using this feature is the coding should be 
done using the same video of an event or possibly another video angle of the same event. This way 
the codes will synchronize with the video correctly.

Here are steps to merge 2 timelines, however many timelines can be merged at once also.
1. Open 2 timelines that are linked to the same movie or copy of the same movie.
2. Select the rows to be merged in each timeline. Individual instances can also be selected, if there 

are instances that should not be included in the merged timeline.
3. Choose File > Merge timeline windows
4. A new timeline will appear with the merged rows of instances. This timeline will not be linked 

to a movie.
5. Choose File > Link movie to timeline window... and select the movie that the original timelines 

were linked to. The timeline should be saved either next to movie package that it is linked to or 
be saved inside the movie package.
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Databasing Instances

Databasing provides an easy method to group speci!c coded instances into one timeline. 
Studiocode creates stand alone databases that hold all the coded information and video data for 
each instance that is exported to it. Databases are a great way to keep only the information that you 
code. A neat way to use databases is to create one for each student. As a research project progresses, 
instances from di"erent movies can be exported into their personal database. By the end of the 
project, each student has a database of selected instances already made and ready for review.

1.  Create a new empty database by choosing Database from the File > New menu in the main menu 
bar.

2.  Name the database and save it.
3.  Open a timeline with the instances you want to export. Select all the instances to be exported, 

then press the database button in the timeline tool bar.

4.  Target the database to export to, and hit the Export to button.
5.  Open a second timeline, select instances, and export them into the same database. These 

instances will append to the database. Continue this process until complete.



113

A
n

 In
tr

o
d

u
ct

io
n

C
o

d
e

C
ap

tu
re

R
ev

ie
w

 /
 A

n
al

ys
is

D
is

tr
ib

u
te

R
ev

ie
w

 /
 A

n
al

ys
is

The Find Window

The Find Window provides the capacity to search for metadata in any open window, a folder on 
the hard drive containing Studiocode !les or across a network to a shared location. When used 
e"ectively the Find Window will save countless amounts of time particularly in transcription and 
statistical scripting plus improve the analysis process when creating video based reports across 
extensive longitudinal data.
Find can be accessed by clicking on the Find button in the timeline toolbar or choosing Edit > Find 
in the main toolbar across the top of the screen. 

Quick Label Searches
The most basic type of search is the Quick label search, just type in the label to be searched for and 
hit RETURN on the keyboard. This quick label search is conducted on all open timelines. The results 
of this search are displayed as a number in the yellow button to the right of the text that you have 
just typed in. Clicking on the yellow button will make a movie of the found instances. This is the 
quickest way of searching for a particular label.
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Advanced Search

There are 3 search modes in the Find window: Instances, Text, and Find and Replace. These modes 
apply to spec!c !le types. Instances mode is designed to search for codes, labels, and transcription 
text in timelines, transcription windows or movie organisers.  Text mode is designed to search 
through transcription and statistical windows. And Find and Replace works across all !le types.

The Find window will open in Instances mode by default. This will likely be the most common mode 
used. Instances and Text modes work very similar in the way in which the search criteria is setup. 
Find and Replace work with direct text input while allowing speci!c windows to run against to be 
toggled on or o".

The following sub-sections will cover using the Find window in Instances mode. Following sub-
sections will speci!cally describe the alternate features in the other modes.

Where to Search

The Find window can be targeted to search in speci!c windows or groups of windows. The search 
area target by default is the front window. This means the timeline, transcription window or movie 
organiser that is the top window, no other windows will be searched. Using the all open windows, 
will target  all open windows and return anything found in these windows. The front timeline and all 
open timelines options will only search in timeline windows spec!cally.

When selecting all timelines in folder, the target folder that contains the timelines must be set. Click 
on the following drop down option to choose the folder 

 
The ability to search across particular folders is incredibly powerful for analysis as it makes 
conducting longitudinal queries very easy.

Note: When searching across all timelines in a folder, the timelines are then opened behind the Find 
window based upon your search results. This search option can take a long time if there are hundreds of 
timelines to search.
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Establishing Search Criteria

Once the search target has been determined the next step is establish the search criteria
Establishing searching criteria for a label is created using the following steps:

1. Select Any, All or None of the following are true from the drop down menu. If any is chosen, each  
row with criteria set will return the found instances. When all is chosen, only instances that meet all 
rows of criteria combined will be returned. None will return any instances that do not match the 
criteria.

2. The !rst choice in setting the criteria is the data type. The data types that can be searched are 
Transcription, Label or Code. In the !rst drop down menu select Label to start to establish the initial 
criteria.

3. Establish the operator of the search criteria by selecting from the following drop down menu. As it 
relates to labels, these options mean:
Is will return labels that contain the exact characters inputted in the search string.
Is not will return labels that do not contain the exact characters inputted in the search string.
Contains will return the labels that have the search string in their names.
Does not contain will return labels that do not have the search string in their names.
Begins with will return labels that have the search string in the beginning of their name.
Ends with will return labels that have the search string in the ending of their name.  

4. Input a search string. This is usually the label name or part of the label name. A string is made up 
of any amount of characters including puncuation and other character types.

5. Establish the last element in the search criteria row by selecting from the following drop down 
menu. 

Note: Grouping only applies to labels. Further criteria can be 
subtracted, added, or nested by using the  buttons, respectively, to 
the right of the criteria row. 
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6.The last item to set is in the Search Options section below the rows of the criteria. These options 
apply to all search strings that was inputted in the rows of criteria.

Ignore case will ignore capitalization. So, Bob will be considered the same as bob.
Ignore white space will ignore spaces between characters. So, Bob Jumped will be same as 
BobJumped.
Use wildcards, this is a method of pattern seaching. If there were a certain amount of label names 
that started with B, an asterisk could be used to !nd these by using B* as the search string.
Trim whitespace will ignore spaces after names. This is helpful if names were inputted strangely.
Only search selected categories will search only selected code rows in a timeline.

7. With the criteria in place, press the Search button  in the Find window toolbar. If any 
instances are found, the results will be displayed in the lower portion of the window with a count of 
the found instances at the very bottom of the window. Click on the disclosure triangle to reveal all 
the found instances.

Making Movies From Found Instances

After a successful search, the results can be made into movies by selecting the Make Movie icon  or 
by double clicking in the search results list that is displayed. 

Databasing Found Instances
Searches results can be databased by selecting the instances in the results and clicking on the 
database icon found in the toolbar.



117

A
n

 In
tr

o
d

u
ct

io
n

C
o

d
e

C
ap

tu
re

R
ev

ie
w

 /
 A

n
al

ys
is

D
is

tr
ib

u
te

R
ev

ie
w

 /
 A

n
al

ys
is

Text Mode
Using text mode is very similar in its way of building up the search criteria to that of instances mode. 
However, text mode is designed to be used with transcription, statistical windows and label trees, so 
there are a few di"erent options.

The !rst di"erence is the search target, only the front window or all open windows can be searched. 
This mode will not search a folder of !les like instance mode.

 The second di"erence is the data type options; Cell text, Cell script and Column title. These are the 
onle types of data that can be searched for in this mode. Cell text will look for text that is contained 
a cell; this could be transcription or statistical output. Cell script will search the script that is attached 
to the cell. And Column title will search only in a given column name.

The last di"erence and most powerful aspect of text mode are the search options.

Like the instance mode; Ignore case, Ignore whitespace, Trim whitespace and Use wildcards are 
available. These are the heavy lifters for searching transcriptions particularly wildcards. Use the 
asterisk following or preceding a search string to !nd rows that might contain the data being hunted.

But, the real power of the text mode is the Generate results feature. By clicking the Generate results 
button, a window with the results will be generated. This work great for pulling out speci!c rows into 
a new window. To help keep transcription in context, rows before and after can be set to be included 
in the generate window. The proceeding and/or following rows will be included in the new window. 
It is often important in transcription analysis to !nd out what said before or after an utterance to 
better understand its meaning.

When simply !nding text in a transcription window, any found text will be highlighted in the 
window using the color chosen in the color well, default is red. Options to Bold or Underline are also 
available.

To clean up the found text items, click on the Clear now button. All highlighted text will become 
unhighlighted. The Auto clear option can be ticked which will clean up previously found strings 
of text. Or, auto clear can be unticked and using the color well, multiple strings can be found and 
highlighted in di"erent colors.
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Find And Replace

The !nd and replace mode works as most !nd and replace features work in any word processing 
software. A string of text is chosen to !nd, then another is chosen to replace the found text. This 
window can help to replace misspelled text, change button names in the code window or change 
scripts in the statistical window. It covers all windows.

When making replacments to text, it is very important to be careful. Make sure to validate what is 
being replaced before it is replaced. We recommend following this usage pattern: Add the string to 
be searched for in the Find text input box, click on the search button in the toolbar and check the 
results in the bottom of the window, then click on the replace button.
Note: Sometimes a replacement is made and it is impossible to go back. For instance, if “this” is changed 
to “that”, it cannot be changed back because all the existing “that”’s this will be changed to “this”’s.

The !nd and replacement strings can be swapped around by clicking on the  button. Again, 
be careful doing this as a lot more items could be changed than were originally intended.

It is very easy to replace something in the wrong window, so it is also suggested to choose the exact 
window and data type in the search options. Untick or tick the speci!c items.
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Recent and Saved Searches

While searching timelines and other windows, every time a search is done, the criteria is saved in the 
Searches column on the left of the window. Any search can be easily referenced by clicking on the 
date-time row in Recent Searches section.
Note: If the list is not in view, click on the disclosure triangle to the left of the Recent Searches text. 

When the date-time row is clicked on, the criteria will be loaded and the search can be done again. 
This does not load previously found data, only the criteria used in the search. This can be saved by 
clicking on the save button at the end of the Search mode selection row, the criteria will then be 
saved in the Saved Searches list. The saved search will be given a default name of Saved Search. To 
rename the search, double click on the name and input the new name.

Search criteria can be saved directly to be used again in the future. This is especially helpful when 
creating complicated searches. By clicking on the save button at the end of the Search mode 
selection row, the criteria will be saved in the Saved Searches list. Just as stated above, the saved 
search will be given a default name of Saved Search. To rename the search, double click on the name 
and input the new name.

A saved search is saved in the in the search mode context. So, when a !nd and replace search is 
saved, when it is selected in the Saved Searches list, the mode will be switched to !nd and replace. 
The mode is represented by the saved or recent icon;  icon is Instance mode,  icon is Text 
mode and  icon is Find and Replace mode.
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Code Matrix

The code matrix is a two dimensional grid representation of code rows and text labels in a timeline. 
The rows in a matrix are generated from the rows in a timeline. The columns are the text labels that 
are coded in the instances of the rows. The cells of the matrix display the instances that have the text 
label coded in them. The intersection cells can count the instances that have the text labels coded 
in them or count the amount of the label are found in the instances. By default, the matrix is an 
instance counter, not a text label counter.

Using The Code Matrix

1.   Click on the Matrix 
button in a timeline 
or code window.

2.   Double click on the row name 
to create a movie for all instances 
in the row.

3.   Double click on the column name 
to create a movie for all instances 
with the text label.

4.   Double click on a cell to make a 
movie of the intersection of the 
instance and label.

 The cumulative totals of columns and rows 
can also be highlighted and viewed. 
These totals represent the total instances 
in the timeline from which the matrix 
was generated. Double click on these 
totals to make a movie.

NOTE: When a row name, text label, cell or total is clicked on, the instances are selected in the timeline. The matrix can be 
used to select instances to paste into a movie organizer or sorter window.

The Code Matrix Toolbar

The code matrix can be easily customized to display speci!c in depth analysis. Rows and columns 
can be deleted or added, text labels can be put together using boolean operators: and, or, or not. 
After customizing a code matrix, it can be saved and opened at another time to use on another 
timeline.
Adding Columns and Rows

After removing a column or row, you may want to add it again. Add a  
label by doing the following:
• Deselect all columns and rows by clicking in a cell or in an empty area 

around the matrix.
• Click on the Add button in the matrix toolbar, this will reveal a menu to 

select the label or row to add.
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• Select the column or row to add. It will be added at the end of the 
columns or rows.

Note: If a column is selected when you are adding, a combination will result, see the Combining Labels by Adding section 
below.

Removing Columns and Rows
Any row or column can be removed from the matrix view by selecting it and pressing the 
remove button on the matrix toolbar or pressing the DELETE key on the keyboard. The row 
or column can also be removed be right clicking on the name of the row or column and 
selecting remove from the drop down menu.

Swapping Axis
The matrix view can be swapped, so the columns and rows switch axis. By default text 
labels are displayed in the columns and timeline rows in the rows of the matrix.  By 
clicking on the Swap Axis button in the matrix tool bar, the text labels will become the 
rows of the matrix and the timeline rows will become the columns.

Sorting Columns and Rows
Columns and rows can be sorted by ascending and descending names. 
Click on the Sort button in the matrix toolbar and select to sort by labels, 
groups or rows. Choosing ascending will sort alphabetically A to Z, 
descending will sort Z to A. Since rows have color, they can be sorted by 
color ascending and descending as well. See the Sort Code Rows section 
of this manual for an explanation of how the color sorting works.

Print The Code Matrix 

Click on the print button in the matrix tool bar. Add a title to the matrix by editing the text 
box to the right of the print button.

Movie

Click on this button to make a movie of selected instances .... either by highlighting a 
column or row or by selecting speci!c instances.

Loading Timelines In The Code Matrix

A saved matrix can be used to run against di"erent timelines other than the original one 
used to create it, this is especially handy when doing comparative or longitudinal analysis. 
Open the saved matrix and a timeline you wish to load into the matrix, then click on the 
Timeline button in the matrix toolbar and select the timeline from the list.
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Note: If the saved matrix does not contain new labels in the new timeline they will not 
automatically show up. If you want to add new labels to a saved matrix. Open a new 
matrix by clicking on the matrix icon in the timeline toolbar, then copy and paste the new 
labels into the saved matrix. If you are planning on using the matrix to do longitudinal 
analysis, do not change your code window without updating a saved matrix.

Export
Besides copying the matrix as a table and pasting into another document, the matrix can 
export an Excel document and a tab-delimited text !le. Click on the Export button in the 
matrix toolbar to access the various exports.

Exporting A Code Matrix To Microsoft Excel
The matrix can be exported as an Excel ready document. The export generates a table for the full 
matrix. Click on the Export button in the toolbar and select Excel from the menu. Name the !le and 
save.

Exporting A Code Matrix As A Tab-delimited text !le
To make using the matrix data available to more third party applications, the matrix can be exported 
as a tab-delimited text !le. This is a common format and easily imported by other applications. Click 
on the Export button in the toolbar, select Text from the menu, name the !le and save.

Matrix Settings
The matrix has 3 settings. These settings are accessed by clicking on the Settings button in 
the matrix tool bar.

Title

The Title text setting is used when the matrix is printed. This will be the title on the printed 
document.

Count labels inside of instances

By default, the matrix displays a count of the instances that contain a text label or combination of 
text labels. It does not count the amount of labels found in the instances. For example, if an instance 
contains 2 duplicate labels, the matrix will return a count of one. Occasionally for statistical reasons, 
it is interesting to count the amount of duplicate labels contained within an instance. Counting the 
labels contained within an instance is done by ticking the “Count labels inside of instances”. This will 
count duplicate labels. So, using the example above, the matrix will now report a count of two.



123

A
n

 In
tr

o
d

u
ct

io
n

C
o

d
e

C
ap

tu
re

R
ev

ie
w

 /
 A

n
al

ys
is

D
is

tr
ib

u
te

R
ev

ie
w

 /
 A

n
al

ys
is

Add new labels and codes to matrix

By ticking this option, the matrix will dynamically add new rows and columns on the #y during the 
coding process. This is an important feature during live coding/capture as the matrix can be used to 
quickly provide counts and video. This process is also important for using the matrix web exports. 
The web export picks up the changes in the matrix and exports the movies automatically. If this is 
not ticked, new instances will not be exported.

Keep existing labels and rows
Choosing this option will keep the matrix codes and labels static. If “Add new labels and code to 
matrix” is selected, the new labels and codes will be added to the existing rows and columns.

Replace rows from selected Timeline
When this option is selected and a new timeline is loaded in the matrix, the new timeline’s code rows 
will replace the existing ones. This is similar to the matrix organizer behavior in previous versions.
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Replace Labels and Codes from selected Timeline
This option will empty the matrix completely and use the newly loaded timeline data. A very rarely 
used option, but there if needed.

Information Button

This button provides the ability to output an edited matrix it to a printer or to a web 
page, without the output a"ecting the original matrix table. Autoname contructs a 
default name using the combined labels eg. “LabelA and LabelB and Label ....“  The 
naming convention can be disabled using this button and a custom name can be 
inputted in its place.

Add Button
This button has identical functions to the Add button in the 
Toolbar.

Refer to the instructions on page 120.

Organizing Rows and Columns
Move rows or columns by clicking on the name and dragging to a new location. Standard cut, copy 
and paste functions can be used, so you can select a column, press COMMAND+X to cut, select the 
column to paste after, then press COMMAND+V to paste.

Copy The Code Matrix As A Picture 
Using the snapshot feature in Mac OS X, you can take a picture of any image that is displayed. Press 
SHIFT+CONTROL+COMMAND+4, drag the mouse cursor from of the upper left corner of the matrix 
window to the bottom right corner, then let go. A shutter sound will be heard indicating that the 
picture has been copied to the clipboard. Press COMMAND+V to paste the picture. A snapshot of the 
matrix can be pasted into a Word document or any other text editor that accepts images.

Copy The Code Matrix As A Table
A selection of cells or the whole matrix can be copied and pasted or dragged and dropped into an 
open spreadsheet or text editor. Select the rows and columns or cells by holding down COMMAND 
or select the whole matrix by pressing COMMAND+A. To copy and paste, press COMMAND+C to 
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copy the cells, then press COMMAND+V in the target document. To drag and drop, you must select 
the row and/or column name to drag from then drop in the open spreadsheet or text document.

Create A New Code Row In The Timeline From A Text Label 
1.   Select a column in the matrix by clicking on the text label column header.
2.   A new row can be created from the matrix by pressing CTRL while clicking on the selected text 

label column header. Select Make Timeline row from selected cells. This will create a new row in 
the timeline with a row name of the text label.

Duplicating Columns
Columns can be duplicated by holding down OPTION and clicking and dragging on the column 
name, then drop into desired position. Another way to duplicate is to right click on the column and 
choose duplicate from the menu. Also, you can copy and paste to duplicate. Duplicating columns is 
most often used when creating label combination columns.

Combining Labels
One of the most powerful features of the matrix 
is labels can be combined using boolean 
operators: AND, OR, and NOT to count di"erent 
combinations of labels that may exist within an 
instance.

There are many ways to combine labels 
together. When labels are combined the label 
name will display  at the beginning of the label 
combination. The default boolean operator is 
AND when a label combination is made.

Select the label 
you want to 
combine with 

another label. Press 
the Add icon in the 
toolbar and select the 
label from the menu. 

1
Select the label you 
want to combine with 
another label. Right 
click on the “Add “ 
button and choose a 
label from Add > Label 
or Group menu.

Select the label you want to combine 
with another label. Drag the label you 
want to combine with the selected 
label to the combination bar. The 
combination bar is located immediately 
below the toolbar. 

2 3
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Changing the Boolean Operator
The default operator is AND while this is the most commonly used operator. There are times you will 
want to change this especially when trying to exclude certain labels. The operator can be changed 
by clicking on the operator between two labels in the combination bar below the toolbar. In most 
occasions the operator will be AND. After clicking on the operator to expose the menu, select AND, 
OR, or NOT.

AND will count those instances that contain the combination of labels.
OR will count those instances that contain either of the labels in the combination.
NOT will count those instances that contain the !rst label and not the following label.

Note: A good approach to using this feature is to duplicate a label several times, then add a different label to each 
duplicate to check for existence of the combination. This demonstrates the real analysis powers of the matrix and is what 
it was designed to do.

Saving The Code Matrix
Organizing the matrix and making various label combinations to produce the desired outcome is 
the key to using the matrix to the fullest. Once this work is done, it important to save it, so it can 
used to run against other timelines. Choose File>Save or press COMMAND+S to save the code matrix. 
This !le can opened later and used to analyze the data in another timeline.

Resetting The Code Matrix
After organizing the matrix by deleting columns and rows and making new combinations, you may 
want to revert to the original matrix. To start from scratch, simply open another matrix by clicking 
on the matrix button in the timeline toolbar, all possible rows and columns will be loaded from the 
timeline into the matrix.
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Movie Organizer

The Movie Organizer is a presentation creation tool designed to organize and edit instances. 
Instances can be dragged around to change the order or they can be trimmed using the 
instance edit window. A movie organizer can be saved and reopened for future presentation or 
editing. A movie organizer window can be opened in two ways. 

The first is : Choose File > New > Movie Organizer. 

The second is to use the shortcut keystroke,  press COMMAND+OPTION+V to paste into an 
organizer. This will open a new movie organizer if one is not already open. If an organizer is 
open, then the instances will be pasted in the open movie organizer window.

Paste Instances Into The Organizer

1. Click, drag and drop selected instances into 
the movie organizer.

2. Select an instance or multiple instances, 
and press COMMAND+OPTION+V.

3. To place an entire row into the movie organizer, select the row by clicking on the row name, 
press COMMAND+OPTION+V. Hold down COMMAND and click on multiple row names to 
select multiple rows of instances.

Playing Instances In The Movie Organizer
All Instances can be played by clicking on the Make Movie Button at the top of the movie 
organizer. All Instances associated with a row can be played by double clicking on the row 
name.  An individual instance can be played by double clicking on it in the movie organizer 
window.

Make Movie Options In The Movie Organizer
By selecting Titles, the row name will appear as a title frame before the corresponding 

instances for the row are played. The number of instances are 
displayed diagonally with thumbnails in the title.

By selecting Static text, each instance’s associated text 
descriptors will be displayed in a static title before each 
instance. A static movie will play for the default duration of 
text movies set in the Studiocode preferences.

By selecting Text track, a text track will be displayed at the 
bottom of the instance movie with the text showing in the 
text track.
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Changing Row Name In Movie Organizer
·  Row characteristics such as row name and color can be edited by right clicking on 

the row name in the movie organizer and selecting edit row from the popup menu.
·  Changing the row name for a title row will change the text in the title that is created.

Editing Instances And Movies In The Movie Organizer
·  To move an instance to another row, click and drag instance to desired location.
·  To create a new row click on the new row button in the movie organizer tool bar.
·  To include or exclude rows from operations, select or deselect the tick box.
·  To edit the in or the out point of an instance, select the instance and press the 

CONTROL+E keys. This will open the instance edit window. Make changes by 
pressing the arrows in the upper corners of the instance edit window.

·  To delete any instance, highlight the instance and press the DELETE key.
·  To drag and drop instances between movie organizer windows, select multiple 

instances in a movie organizer, hold down COMMAND+OPTION, click and drag from 
the selected instances and drop into another movie organizer window.

Paste A Picture From The Clipboard Into The Movie Organizer 
1.  Click on the new picture button in the Movie Organizer tool bar, this will create a 

new picture row in your Movie Organizer.
2.  In the new row click on the white box and paste in your picture.
3.  Drag the picture row to the row above the clips you want it to show 

before.
Note: When a picture is pasted into the movie organizer it is scaled to the full movie size. Drag 
the bottom of any picture to resize the row. Pressing SHIFT+COMMAND and dragging the 
bottom of any picture will simultaneously alter the size of all picture rows.

Changing Labels with the Labels Tree Pop-up Menu
The labels tree pop-up menu can be accessed by right clicking on an instance. The labels tree 
pop-up menu is created from all the labels found in the movie organizer window. If new labels 
need to be added, open a new labels tree window, add the labels to the new window, then 
right click on the instances to add the new label or any timeline label tree or previously saved 
labels tree window can be opened and used.

Adding Text
Instance notes can be added to individual instances. Select the instance and press 
the Text button in the movie organizer tool bar. Type the text into the Text window. 
Close the window to save the text or select another instance to add text to.

Save A Movie Organizer
Choose File > Save, File > Save as..., or press COMMAND+S. The Movie Organizer will 
be saved as a file with this icon.

Database Instances from a Movie Organizer
Select the instances you want to export to a database and click on the database 
button in the movie organizer tool bar.
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Instance Sequencer

The instance sequencer presents a list of the instances within a row of a movie organizer. The 
order of instances can be arranged by dragging the rows up or down. Instance labels and 
duration can also be edited.

Open the instance sequencer for a row by double clicking on the yellow sequencer 
icon to the left of the row name in the movie organizer.

Play and Edit Instances in the Instance Sequencer
Double clicking on a row will open the edit instance window, the instance can be viewed or 
edited. To play or edit another row, single click on the row and the edit instance window will 
update the changes in the last row and move to the new selection. Close the edit instance 
window by clicking on the red button in upper left corner of the window.

Delete Instances from the Instance Sequencer
Select a row and press the DELETE key.

Editing Labels in the Instance Sequencer
The labels popup menu can be accessed by right clicking on a row. The labels in the pop menu 
that are displayed will only be those labels from the movie organizer row. Open a saved label 
tree to add new ones or open the timeline and press the labels button.
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Transcription Window

The transcription window is a spreadsheet-style coding and analysis tool. It is a powerful 
combination of a code window, movie organizer, text window and even the statistical window. 
In the transcription window, spoken words and phrases can be coded and transcribed, 
instances can be trimmed, labels can be added or removed plus full presentations can be 
organized. Rows can be automatically sorted by movie time references, alpha-numerically, 
or frequency of occurrence according to data in the cells of the columns. And after all the 
transcription work is complete, presentations can be arranged and a movie can be created. It, 
also, includes powerful find, replace and generate results features.

Open a new transcription window by choosing File > New > Transcription window from the 
main menu.

Transcription Tool Bar

The print button will send the document to a printer or a pdf can be made.
The Column button inserts a new column after the selected one or creates a new one as 
the last column.
The Row button inserts a new row after the selected one or creates a new one as the last 
row.

The Bold, Italic, Color and Size buttons will change the selected font accordingly.

The Movie button will make a movie of all the rows in the window.
The Edit movie button opens the edit instance movie window where start and end 

times for a row can be adjusted using the arrow buttons in upper corners of the movie 
window.

By pressing the Populate button, selected rows in the transcription window be created 
in an open timeline window. This process will also update existing instances if changes 
have been made, and synchronise changes.
Click on the Play button to start the timeline movie playing.

The Stop button will stop the timeline movie playing.



131

A
n

 In
tr

o
d

u
ct

io
n

C
o

d
e

C
ap

tu
re

R
ev

ie
w

 /
 A

n
al

ys
is

D
is

tr
ib

u
te

R
ev

ie
w

 /
 A

n
al

ys
is

Moves the black looping markers back one loop. The shortcut key is F1.

Moves the black looping markers forward one loop.  The shortcut key is F2.

Moves the red looping markers back one loop.  The shortcut key is F3.

Moves the red looping markers forward one loop. The shortcut key is F4.

Moves the red and black looping markers back 0.5 seconds. The shortcut is F5.

Moves the red and black looping markers forward 0.5 seconds. The shortcut is F6.

Insert or update the start time for the current row.

Insert or update the start time for the current row and jump down to next row moving 
loop by its duration.

Lines sets the the amount of lines to be displayed in the text track below the movie 
when the Movie button is pressed.

Loop sets the default loop duration during the transcription process.

Transcription Window Column Types

Time Reference

This column displays the start time, duration and the timeline for the instance.

Speaker
The speaker column relates to the row name in the timeline. It is the 
equivelant to a code button, meaning it is a category of marked time.
Transcription. The transcription column is where the free text is inputted. The 
text in these cells will be displayed in the text track of a movie.

Transcription

Labels
This column reflects the labels that have been inserted into the instances using a 
code window or label tree. Labels can be typed into this cell and populated back to 
the timeline.

Default
The default column is used for notes, observationsm, or or column separation. These 
will not be populated back in the timeline.
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Transcription Window Column Type Settings

A column type is set by right clicking on the column setting bar above a column.

Transcription Window Column Settings Bar
Clicking on the icons in the column settings bar of the sorter window will turn on and off the 
settings for locking content, searching, and text overlay.

 Unlocked Column  Cells in column can be edited.
 Locked Column  Cells in column cannot be edited.
 Searchable Column  Cells in column will be searchable.
 Unsearchable Column Cells in column will not be searchable.
 Speaker Column  Text overlay will be displayed.
 Speaker Column  Text overlay will not be displayed.
 Text Label Column   Text overlay will be displayed.
 Text Label Column  Text overlay will not be displayed.

 Transcription Text Column Instance note text track will be displayed.
 Transcription Text Column Instance note text track will not be displayed.

Transcribing Video
Now that we are familiar with the all the buttons and tools in the transcription window, let’s 
go through the process of transcribing from the beginning. Here are the steps using a timeline 
that has no coding:
1. Open a timeline with a linked movie.
2. Set the playhead to the desired start time in the timeline.
3. Choose File > New > Transcription. A transcription window will open. To aid in organizing 

the windows, hold down CTRL and click on the timeline movie resize buttons in the 
bottom corner of the timeline movie. They look like 2 different sized rectangles.

4. In the timeline, you should see the red and black looping markers at the start of the 
movie. If you do not, tick the check box below the movie time in the timeline. Drag, the 
left red marker to the desired start time if needed. 

5. With everything in place, press the button to insert a start time, the shortcut for this 

is CTRL+I. Now press the play button . The shortcut for play is CTRL+L. The movie will 
start to play and loop around between the black markers.

6. Enter the speaker name by clicking in the speaker cell of the row or press TAB on the 
keyboard. Then, enter the utterance of the speaker in the transcription cell by clicking in 
the cell or using TAB to move into the cell.
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7. It is likey that the utterance is longer than 5 seconds, so we want to advance the loop to 

continue entering the whole phrase or thought. Click on the button or press F2 on 
the keyboard, F1 will move markers backward. The loop will jump forward 5 seconds and 
inputting can continue. Continue to advance the markers and transcribe until the loop is 
in the region you want to end the instance.

8. While looping around the desired end time, press the button or CTRL+O at the 
moment you want the instance to end. After clicking on the button or keystroke, the end 
time will be set, the routine will jump down a line, set the start time for the new row using 
the previous end time and populate the speaker cell with the last speaker. So, all that 
needs to be inputted is a new speaker, the utterance and jump through the loops until 
desired end time. Repeat this pattern until transcription is complete.

Once you are comforable with this routine, we recommend really learning the keyboard 
shortcuts. This can drastically reduce transcription time. Using the keyboard, the pattern from 
the first instance is:
CTRL+L > CTRL+I > SPEAKER > UTTERANCE > F1 > MORE UTTERANCE > CTRL+O
The second instance:
SPEAKER or TAB > UTTERANCE > F1 > MORE UTTERANCE > CTRL+O

Keyboard Shortcuts Function

CTRL+J Play movie backward, press multiple times to 
increase speed.

CTRL+K Stop movie playing.

CTRL+L Play movie forward, press multiple times to 
increase speed.

OPTION+CTRL+J Play a fraction of movie forward with audio.

OPTION+CTRL+L Play a fraction of movie backward with audio.

CTRL+I Set start time

CTRL+O Set end time

F1 Move black markers backward

F2 Move black markers forward

F3 Move red markers backward

F4 Move red markers forward

F5 Move red and black markers 0.5 seconds 
backward

F6 Move red and black markers 0.5 seconds 
forward
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If the function keys are controlling other aspects of the system like the sound or brightness, 
open System Preferences, click on Keyboard and tick the “Use all F1, F2, etc. keys as standard 
function keys”. Once this setting is enabled, you will need to press the fn key and the Fkey to 
perform the system operation like increase the volume.

Exporting Instances to a Transcription Window
Any group of selected instances or a single instance can be exported to a Transcription 
window. Select the instances in the Timeline, then press the transcription button in the 
Timeline tool bar. If a Transcription window is open the instances will be pasted below the 
last row of that window. If a transcription window is not open a new one will be created 
automatically with the instances. When multiple instances are exported at once, they will be 
pasted in the window chronologically. If the selection is across multiple rows, each row will be 
pasted in their respective sections in the window.

Creating an Instance Movie in the Transcription Window

Double click on the row number or time reference cell for a row. To make a movie of 
multiple rows, select the rows using COMMAND or SHIFT and press the movie button 
in the transcription tool bar. If no rows are selected, the movie button will create an 
instance movie from all rows.

Viewing and Editing Instances in the Transcription Window

The edit instance movie can be used to view and trim instance rows in the 
transcription window. Click in a cell and press on the edit movie button in the 
transcription window tool bar to open the instance edit movie window. The start and 
end time of the instance can be edited using the arrow buttons in the corners of the 
edit instance movie. To change the instance being displayed in the movie window, 
click in any cell of a different row. The edit instance movie will update as the cells are 
clicked in different rows. Turn on movie looping mode to make the make the movie 
play continuously, saving a few keystrokes or mouse clicks.

Editing Labels with the Label Tree Popup
Labels and instance notes can be edited, added, or removed in a cell. Click in the cell 
change the text, input new text, or delete the text. When adding text labels, care must 
be taken that the label is inputted correctly in the cell. If a label is misspelled or the 
capitalization is wrong, two different labels will be created that mean the same thing. To 
help this problem, the label tree popup menu can be accessed in any cell by holding down 
OPTION and clicking in a cell. The label tree popup menu will appear and the labels can 
be added or removed. Using the label tree is the best way to make sure that labels are 
consistently inputted in the transcription window.
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Using the Keyboard
To move around in the transcription window with the keyboard, begin by selecting a cell with 
the mouse. Press the TAB key to move to the next cell to the right of the active cell. When 
the last cell in the row is reached it will wrap to the next row down in the first cell. Pressing 
SHIFT+TAB will move in the reverse direction. Alternatively, hold down CTRL and use the arrow 
keys to move up, down, right, and left around the cells.

Sorting Rows
Columns in the transcription window can be automatically sorted in 
5 different ways. To access the sorting options, right click on the 
column header name cells.

1.  Sort Ascending sorts the rows in alphabetical order from A-Z according to the data found in 
the column. Numbers will be sorted from lowest to the greatest number.

2.  Sort Descending sorts the rows in reverse alphabetical order from Z-A according to the data 
found in the column. Numbers will be sorted from the greatest to the lowest number.

3.  Sort Frequency Ascending sorts the least frequent found text or number in 
the column and groups those at the top, the next least frequent found text 
or number is placed below this grouping. This pattern is followed through 
out the column of data.

4.  Sort Frequency Descending sorts the most frequent found text or number in 
the column and groups those at the top, the next most frequent found text 
or number is placed below this grouping. This pattern is followed through 
out the column of data.

5.  Sort All Rows by Movie Time sorts the rows according to the instance start 
time. This sorting option only works when clicking on the time reference column header.

Synchronizing Changes Back to the Timeline
After making changes to the duration of instances, speakers, transcription, and labels in the 
rows of a transcription window. The changes can be synchronized back to the original timeline. 
Select the specific rows in the window to be synchronized, then press the populate button in 
the tool bar.

 
To synchronize all the rows, press COMMAND+A to select all the rows, then press the populate 
button. When synchronizing data back into timelines, the original timelines must be open.

NOTE: The purpose of requiring the timelines to be open is to insure that accidental 
synchronization does not occur. Changes made through synchronization cannot be undone 
once the timeline is saved. By default, the auto save timeline data preference is turned on.
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Overlay Text Display Options in the Transcription Window

Each column of data in the Transcription window can be turned off for overlay text display. 
When the column type icon has cross through it, the data will not be shown as overlay text.

This is used to limit what is presented in the movie and attention can be brought to specific 
data. The examples below show how turning off columns displays less data.

No columns turned off.

Row name column turned off.

Row name and Field Zone columns turned off.

Row name, Field Zone and Phase Play Start columns turned off.
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Transcription in the Timeline

Transcription can be added directly to an instance in the timeline. This is designed to add 
information conveniently if the transcription window is not neccessary. It is a good way to quickly 
add content that speaks to those viewing the movie or as a method to record special information 
regarding the instance. The transcription will appear in the text track at the bottom of an instance 
movie when text tracks is checked in the timeline tool bar.

Adding a Transcription to an instance

1.   Select the instance in the timeline to add text to.
2. Open the Edit transcription note window by pressing 

on the Text button in the timeline tool bar.
3.   Add the text in the Edit instance window. When all 

the text is added, click on the red button to close the window 
and save the text.

The Edit instance window can be left open to easily add transcription text to an instance. Select any 
instance and the edit instance window will change to that instance. The text will be saved in the 
instance when the next instance is selected after adding the text. This makes adding text a quick job 
and saves on mouse clicks.

Viewing Transcription text in a movie

Enable transcription text in the timeline by 
checking the text tracks check box.
When a movie is made from instances in the 
timeline, a text track will appear at the 
bottom of the movie window.

Setting the amount of lines of text displayed
Click on the lines drop down menu in the timeline tool bar. Select the number of lines of text that 
will appear in the movie at the base of the movie window. If there is a lot of text that is required to 
display, set this to match the lines required to display the text. Otherwise, the transcription text will 
adjust to scroll evenly throughout the length of the movie.
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The Drawing Window
The Drawing Window Toolbar

Drawing visibility turned on.

Drawing visibility turned o".

Selection Tool – Select, move, or change drawing objects 

Trash

Sets the color of the drawing objects.

Type text directly into drawing or video window. 

Sets the size of the text when text tool is used.

Draws a straight line from point to point.

Draws a straight dashed line from point to point.

Draws a straight line from point to point with an arrow head at the end of the line.

Draws a straight dashed line from point to point with an arrow head at the end of the line.

Draws a zig-zag line from point to point.

Draws a zig-zag line from point to point with an arrow head at the end of the line.

Draws freehand according to mouse position.

Draws an angle between three points.

Draws a rectangle with no !ll color

Draws a rectangle with !ll color

Draws an ellipse with no !ll color

Draws a dashed ellipse with no !ll color

Draws an ellipse with !ll color

Sets the thickness of the selected drawing tool or object.

!"

!"



139

A
n

 In
tr

o
d

u
ct

io
n

C
o

d
e

C
ap

tu
re

R
ev

ie
w

 /
 A

n
al

ys
is

D
is

tr
ib

u
te

R
ev

ie
w

 /
 A

n
al

ys
is

Drawing Tools

1. Select the pencil from the Main Tool bar.
2.  To draw a straight line, select . Click on the point of the movie frame where you want 

the line to start and drag the line to the desired end point.
4.  To change the colour of the line click on the .
5.  To change the width of the line click on the .

Changing a Drawing Object
1. Select a color from the Color palette.
2.  Select the tool you wish to use by clicking on it. This tool will remain active until another 

tool is selected or the ESC key is pressed. When the ESC key is pressed the default 
selection tool will become active.

3.  Click & drag to draw in a Movie with the active tool.
4.  To resize or change a drawing object, click the selection tool then click & drag on the 

handles of the drawing object. (Handles are the squares at the ends of the line.)
5.  To move a drawing object, click on the selection tool and click & drag on the object.
6.  To change the color of an object select the object, then click on the Color Palette tool        

and select the desired color in the palette.
7.  To change the thickness of an object, select the object and click the Line Thickness 

tool and select the desired thickness from the list.

Using the Text Tool

1. Select a color and font size for the text.
2.  Click on the text tool   , then click on the location in a movie where you want to type the text.
3. Type the text in the text box.
4. To edit the text, double click on the text using the selection tool.
5. To save and exit click the red button at the top left of the window
Note: The instance will be marked in the Timeline with a triangle in the top left corner of the instance 
marker to indicate that the instance contains either text or drawing marks.

Delete Drawing Items
To delete drawing items , select the Edit menu from the Main Menu bar or use the Keyboard  
Shortcut  function 

Customizing the Drawing Tool Bar
Most of the drawing tools you may !nd that you do not use and the wide tool bar can get in the way 
when presenting and drawing in full screen. To customize the appearance of the tool bar, click on the 
button in the upper right corner of the tool bar. This will reveal a check box below each tool. Uncheck 
any tools that you do not wish to see in the tool bar. Click on the button in the upper right corner to 
close and save customization. 

!"

!"

!"
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Create a Movie incorporating the Drawing Window

To create movies incorporating pictures of your analysis use the drawing window. The drawing 
window is able to create movies that can be combined with other instances.

1. Open up an instance by double clicking on it. Stop the instance movie at the point where you 
want to make a coaching note with drawing and text. (We shall call this “the original instance 
window”)

2. Select “File> New> Drawing Window” from the Main Menu bar. A blank drawing window will open. 
Copy and paste the still frame from the original instance window across to the drawing window. 
(apple/command + c for copy and apple/command + v for paste).

3. Draw on the drawing window using tools. The arrow icon 
on the drawing toolbar will take you back to a cursor in 
order to move things around or make other selections.
Hint: to make text stand out, put a square or rectangle on 
the page !rst and then write in an opposite colour on top.

4. Tick the Constrain box in the toolbar and nominate the length you’d like to freeze the frame and 
then press the movie icon to make the movie

Note: it will ask you to save the movie created. Click save to get to the next step but you don’t need 
to keep this after the whole drawing movie has been created.

5. When the movie pops up, hold down shift and drag the bottom hour-glass shaped cursor all the 
way along. The darkened background indicates the whole movie is selected.

6. Click and hold on the movie and drag it back into the original 
instance window. This is called drag and drop editing and 
indicated by a pixelated frame. The original frame will now also 
have a darkened section within it’s timeline

7. File> Save as> Format: Movie Player Standalone movie (on 
desktop). The movie is now ready to be distributed or presented in 
a Quicktime movie format (on either Mac or PC).
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Create Angles and Measurement Lines

The measurement tools, line and angle, can be found under the Analysis > Measurement menu. By 
using known distances in a frame of video, you can accurately measure other distances relative to 
a known distance. Known distances that can used in a video frame are landmarks such as a goal or 
!eld marker. You can use the landmark to set the relative scale of the line tool.

Line Measurement Tool

Choose Line from the Analysis > Measurement menu in the main menu bar.
1. 2000

3 
20001

A line will appear in the middle of the screen. The 
measurement tool has a number of invisible handles on 
it. On the line measurement tool there are three handles 
to grab. Move the mouse pointer over the ends of the 
line tool, the cursor changes to a cross-hair (1+2). Click 
on these areas to move that end of the line. Move the 
mouse pointer over the center of the line tool, the cursor 
changes to a !nger pointing (3). Click on this area to 
move the line tool.

Set the Line Parameters

Press CONTROL and click on one of the lines to set the Line Color, Line Thickness, Vertical Scale, 
Horizontal Scale, Make Vertical, Make Horizontal.

Setting the Scale Factor for the Line Length

You can use the vertical and horizontal scale option to scale the lines and angles to re#ect real world 
values.
• To set the Vertical scale for a movie, move the line over a known measurement in the movie, 

select the “Vertical Scale Option” and type in the real world value. 
• To set the horizontal scale for a movie, move the line over a known measurement in the movie, 

select the “Horizontal Scale Option” and type in the real world value.

All angles and lines should be recalibrated accordingly.

The biomechanical measurement tool can be used either on the preview movies or in full screen 
mode – where greater precision of measurement is available, because of the larger picture size.

The line tool is most e"ective for movies where the camera is !xed and does not zoom in and out.
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Creating Title Movies
The drawing window is great for creating title movies that you can paste in front of an instance 
movie. This lets the viewing audience know what is coming up and helps keep them focused on 
the subject of the presentation.
Create a folder called Titles. Open a drawing window, paste your logo in the window, set the 
background color, add some drawing objects and color them to match your scheme. Add some 
large bold text in the middle of the window and save the drawing in the Titles folder.
Edit the bold text to match the subject of the instance movie, this might be the row name. Then, 
create the movie and save it in the Titles folder with the name of the bold text. Repeat this 
process for all the categories of instance movies you will be presenting. Since it is very common 
that you will need to use these titles over and over, they are now created and saved in the Titles 
folder for future use.

Angle Measurement Tool

Choose Angle from the Analysis > Measurement menu in the main menu bar.

1

3

4

5
900

An angle will appear in the middle of the screen. The 
measurement tool has a number of invisible handles on 
it. On the angle measurement tool there are !ve handles 
to grab. Move the mouse pointer over the ends of the 
line tool, the cursor changes to a cross-hair (1+2+3). Click 
on these areas to move the ends of the angles and the 
vertex. Move the mouse pointer over the middle of 
either arm, the cursor changes to a !nger pointing (4+5). 
Click on this area to move the angle tool.

The Measurement tools can be cleared by right clicking 
on the tool and selecting delete or delete all.
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Using a Remote Control

The Apple Remote can be used in various ways. These peripheral products are great tools for 
boardroom presentations of coded video.

This remote can be customized in the software preferences.

Each button on the remote can be assigned a movie, drawing tool, or code button hot key function. 
Click on the button type drop down and select from Code, Movie, or Drawing button.

Code buttons can be assigned to match hot keys in a code window. When the button window is 
open and in code mode, the button can be pressed on the remote and it will push that button in the 
code window.

Movie buttons are the various playback features of the software that can be performed in a movie 
window using the keyboard shortcuts.

Drawing buttons will enable di"erent drawing tools in the drawing tool bar. This 
is very handy when presenting in full screen.
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Statistics Window

The statistics window is a spreadsheet style window with the ability to perform complex calculations 
based around instances in a timeline. The Statistics window must be built “from the ground up”.

Mathematical and logical expressions can be built into scripts in each cell. The scripts are built into 
each cell individually. Each cell can hold text, show data, change background color, or text color 
according to actions from the scripts. You are not able to populate the cells automatically from any 
other window.

The statistics window scripts can be executed manually by pressing the execute button in the 
window or executed automatically upon a change in the timeline or with the click of a button in the 
code window.

The statistics window can drive output from a script to a button in the code window. Scripts can be 
written to change button colors and push buttons up or down according to customized calculations.
The statistics window is extremely #exible, rows and columns can be moved, added and deleted to 
present the output in hundreds of ways.

A Statistics window reads the front-most Timeline unless the “From” command is used in it’s scripting

Create A Statistics Window

Choose File > New > Statistics window from the main menu bar.

The Statistics Window Toolbar
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Print

Prints the window contents

Column

A new column will be created to the right of the column where the cursor is located. If 
the cursor is not in a cell, then the column will be created to the right of the last column 
in the window.

Row

A new row will be created immediately below the row where the cursor is located. If the 
cursor is not in a cell, then the row will be created below the last row in the window.

Text Properties

For manipulating the text in the heading columns and rows.

Execute

Searches the Timeline open and executes the statistical commands in every cell in the 
window that has a statistical script.

Unlocked and Searchable Column Cells

Allows cells in the column to be edited.
Allows cells in the column to be searched with CNTRL+F

Locked and Unsearchable in Column Cells

Prevents cells in the column from being edited
Prevents cells in the column from being searched with CTRL+F
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Moving around a Statistics Window

Moving from cell to cell can be done in two ways.

1. Pressing the TAB key will move the cursor from one cell to the next cell on the right.   
 Pressing SHIFT+TAB will move the cursor from one cell to the next cell on the left.

2. Holding down the CTRL key and pressing the arrow keys will move the cursor in the   
 direction of the arrow key that is pressed.

Moving A Column
Click and drag on the column information header where the column number is located, move the 
column to the new location.

Moving A Row
Click and drag on the row number, move the row to the new location.

Deleting A Column
To delete a column, press CTRL and click on the column information 
header. Select Delete column from the popup menu.

Deleting A Row

To delete a row, press CTRL and click on the row number. Select Delete row 
from the popup menu.

Sorting Rows By Column
Rows can be sorted by column by pressing CTRL and 
clicking on the column header name cell. This is useful when 
sorting rows alphabetically or numerically. Sorting options 
are explained further in the Sorter window section of this 
manual.

Opening The Edit Script Window
To add a script to a cell, press CTRL and click on a cell. Choose Edit script from the popup menu. This 
will open the script editor window.

After a script is added to a cell, the upper left corner of the cell will 
have a green triangle in it.
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Copy and Paste Rows with Scripts

Hold down OPTION and click and drag on the row number. This will create a duplicate row with 
all the scripts included. This is quite a time saver when creating rows that will have the the same 
columns of data in them like student statistics.

Use Cell References

Use a cell as a data place holder for script referencing. Setup a column where the student names 
are inputted, then reference this column by its name or coordinates in a script. This makes 
changing data very easy because it can be changed in the cell, not the script.
In the script, create a variable that reads the reference cell’s data.
$studentname = cell(“Student”,$row)
show count “Outburts” where row = $studentname
This variable will look to the player column in the same row and use this data in the script. By 
typing A.McGrath into the Student column cell, the script !nds how many Outburts labels there 
were in the A.McGrath timeline row.

Copy to Excel

Data being displayed in the cells of a statistical window can be copied into Excel or any other 
spreadsheet program. Hold down COMMAND and click in the cell, then press COMMAND+C 
to copy the data to the clipboard. COMMAND+V will paste the data in the other applicaiton. A 
group of cells can be selected by holding down COMMAND, click in top left cell, then click in the 
bottom right cell of the group of cells to be copied.

Adding A Script

The edit script window is a very basic text 
editor with copy and paste functionality.

The window consists of two parts: the title of 
the cell and the script for the cell.

The title of the cell can be set so it can be 
referenced in another cell’s script.
The script for the cell is set in the area below 
the title.

The scripting language and commands 
are quite di$cult to master, but extremely 
powerful. Each command is documented in this manual with examples. Work through these 
examples and email support@sportstec.com for further help.
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Statistical Commands Quick Glossary
$COLUMN Returns the column the cell is in.

$ROW Returns the row the cell is in.

ABS Returns the absolute value of a number.

AND If values are numbers: returns 1 if both values are not zero, otherwise returns  
If using text then it is assumed that you are referring to labels and the return 
result will be instances from the timeline that contain both labels. “AND” is 
commonly used inside other commands (see IF, COUNT...) and can be combined 
with “OR” and “NOT”

BUTTON 
STATE

Returns 1 if button is down and 0 if button is up, in the code input window.

CEILING Returns a number which has the number rounded up to the speci!ed number 
of digits from the decimal point. If you need to display a certain number of 
digits after the decimal point use the decimal command.

CELL Grabs the output from another cell in the window.

CELL_COLOR Changes the color of the cell.

COUNT Counts the number of labels in the timeline (including multiple ones in the 
same instance).

DECIMAL Returns a string which has the number to the speci!ed number of digits from 
the decimal point. The number is always rounded down.

END Gives the latest end time of the labels or instances in the timeline in seconds. 
Returns -1 if no instances.

END TIME Returns all instances that have the correct end time condition.

EXIT Stops the rest of the cell from being executed

FLOOR Returns a number which has the number rounded down to the speci!ed 
number of digits from the decimal point. Similar to DECIMAL excepts that it 
returns a number and not a string. If you need to display a certain number of 
digits after the decimal point use DECIMAL.

FROM Will get instances from speci!ed timelines. Not using this command will default 
to use front timeline

HH:MM:SS Speci!es the time in hours, minutes and seconds

IF Executes the statement based on a condition.

INDEX Finds the value from a range of cells with the given o"set

INSTANCES Returns all the instances in the timeline.

INSTANCES2 Will return all the instances in the timeline between the red markers.
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INSTANCE[x] Returns the ‘x’th instance in the timeline based on start times.

LABEL Returns a label in the timeline or row. If an instance has 3 matching labels it will 
return 3.

LABEL IN LABEL IN Will return a label in the instances. If an instance has 3 labels it will 
return the instance 3 times.

LABELS Returns all the labels in the timeline or row. If an instance has 6 labels overall it 
will return 6.

LABELS IN Will return all the labels in the instances. If an instance has 3 labels it will return 
the instance 3 times.

LARGE Finds the nth largest value in the cell group

LENGTH Gives the length of labels in the timeline (including multiple ones in the same 
instance) in seconds.

LOOKUP Finds a match for a given value in the !rst range, and then returns the value 
in the cell with the same relative position in the second range. Ranges cannot 
overlap or be of di"erent sizes

LIMIT Limits instances based on conditions.

NOT If value is number: returns 1 if value is 0, otherwise returns  If using text then 
it is assumed that you are referring to labels and the return result will be 
instances from the timeline that do not contain the label. “NOT” is commonly 
used inside other commands (see IF, COUNT...) and can be combined with “AND” 
and “OR”.

OR If values are numbers: returns 1 if either value is not zero, otherwise returns  
If using text then it is assumed that you are referring to labels and the return 
result will be instances from the timeline that contain either label. “OR” is 
commonly used inside other commands (see IF, COUNT...) and can be combined 
with “AND” and “NOT”.

OVERLAP Returns instances from the given arguments that overlap for any part of the 
timeline. Opposite of UNIQUE.

PUSH 
BUTTON

Pushes the button up/down in the code window. If this is a label button then 
you only need to use DOWN.

RANK Finds the rank of the value in the range

ROUND Returns a number which has the number rounded to the speci!ed number of 
digits from the decimal point. It will round up or down depending on which 
is the closest digit. If you need to display a certain number of digits after the 
decimal point use DECIMAL.

ROW_COLOR Changes the color of the row.

SMALL Finds the nth smallest value in the cell group
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SEND Changes the value of the button in the code window with that button name.

SEND 
BUTTON 
COLOR

Changes the background color of the button in the code window with that 
button name.

SEND TEXT 
COLOR

Changes the text color of the button in the code window with that button 
name.

SHOW Outputs the number or text to the cell.

START Gives the earliest start time of the labels or instances in the timeline in seconds. 
Returns -1 if no instances found.

START TIME Returns all instances meeting the correct start time condition

SUM Adds all the values in the cell group.

TIME Returns all instances meeting the instance length condition

TIMER Converts the input in seconds to a timer string with a given precision

UNIQUE Returns instances from the given arguments that do not overlap for any part of 
the timeline. Opposite of OVERLAP.

UNIQUE 
RANK

Finds the rank of the value in the range making sure it is unique

WHERE Selects certain instances based on conditions.
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Display Commands

These commands change the display of the cell that the script is in.

CELL_COLOR 
Changes the color of the cell. The color ranges are 0 to 100 percent of red, green, and blue. 
Di"erent percentages of each color will result in di"erent colors.

Format:
CELL_COLOR ( red , green , blue )

Arguments:
red: a number 0 to 100
green: a number 0 to 100
blue: a number 0 to 100

Example:
cell_color (100,0,0) turns the background color of the cell red.
cell_color (100,100,0) turns the background color of the cell yellow.

ROW_COLOR 
Changes the color of the row. The color ranges are 0 to 100 percent of red, green, and blue. 
Di"erent percentages of each color will result in di"erent colors.

Format:
 ROW_COLOR ( red , green , blue )

Arguments:
red: a number 0 to 100
green: a number 0 to 100
blue: a number 0 to 100

Example:
row_color (0,0,100) turns the row background color blue.
row_color (100,50,0) turns the row background color orange.

SHOW 
Outputs the number or text to the cell.

Format: 
SHOW value

Arguments:
value: numerical expression or quoted text

Example:
show “Hello” displays Hello in the cell when the scripts are executed.
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Information Commands

Information commands return information about timelines and statistical windows.

CELL
Grabs the output from another cell in the window. This command is useful in calling on another 
cell’s output to be used in an expression or variable.

Format:
CELL reference

Arguments:
reference: (column number or column title , row number), quoted text representing a cell or the 
column title.

Example:
show cell (2,1) returns the output from the cell in column 2, row 1
show cell “my cell title” returns the output from the cell which has a title “my cell title”
show cell “my column title” returns the cell which has a column title of “my column title” on this 
cell’s row
show cell (“Column 1”,3) return the cell which has a column title of “Column 1” on row 3
show cell ($column-1,$row+2) returns the contents of the cell 1 row to the left and 2 rows down
show cell (“Column 2”,$row-2) returns the contents of the cell which has a column title of “
Column 2” and 2 rows up from this cell

COUNT
Will count the number of labels in the timeline including multiple ones in the same instance.

Format:
COUNT labels

Arguments:
labels: quoted text specifying label you wish to count in the front timeline or instances(which 
can be grouped using OR, AND, NOT) optional WHERE conditions
conditions: ROW = quoted text or ROW != quoted text (which can be grouped using OR, AND, 
NOT)

Example:
count “Outburst” returns a count of all the “Outburst” labels in the front timeline.
count “Outburst” and “Elated” where row = ”Miller” returns the total number of  “Outburst” and 
“Elated” labels in the row “Miller”
count “Outburst” where row != ”Miller” returns the total number of “Outburst” labels which are 
not in row “Miller”
$a = not (“Outburst” or “Elated”)
show count $a
This example uses a variable and shows the total number of labels in the front timeline which do 
not have “Outburst” or “Elated” labels in them. Variables are handy to use in long expressions or 
scripts saving a lot of time in retyping or changing conditions.
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END
Will give the latest end time of the labels or instances in the timeline in seconds. It will return -1 
if no instances are found.

Format:
END instances

Arguments:
instances: instances or quoted text specifying label you wish to get the latest end time

Example:
end “Outburst” returns the end time of the latest instance which has the label “Outburst” in 
seconds
end “Outburst” and “Elated” where row = ”Miller” returns the latest end time of “Outburst” and 
“Elated” labels in the row “Miller”
end instances returns the end time of the last instance. i.e. The latest overall end time
show end instance[-1] shows the end time of the last instance (based on start time). This might 
not be the latest overall end time

END TIME
Will return all instances that have the correct end time condition that meets the criteria in the 
argument.

Format:
instances WHERE END TIME operator value

Arguments:
instances: quoted text specifying label you wish to count in the front timeline or instances which 
can be grouped using OR, AND, NOT
operator: < <= > >= =
value: the end time you wish to test (in seconds)

Example:
count instances where end time > 20 will count the number of instances that have an end time 
after 20 seconds
count “a” or “b” where row = ”row1” and end time > 20 will count the instances that have “a” or “b” 
in them in row “row1” ending after the !rst 20 seconds
count instances where (start time <4 or end time >20) and time<4 will count all the instances 
which are smaller than 4 seconds, and have a start time in the !rst 4 seconds or an end time after 
the last 20 seconds.

HH:MM:SS

Specify the time in hours, minutes and seconds

Format:
HH:MM:SS

Arguments: 
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HH: hours 
MM: minutes 
SS: seconds

Example: 
show count instances where start time > 00:01:01.45 show a count of all the instances that have 
a start time greater than 1 minute, 1.45 seconds

INDEX

Finds the value from a range of cells with the given o"set

Format: 
INDEX ( o"set IN reference..reference )

Arguments: 
o"set: an o"set number (1 is the !rst cell) or column o"set (1 is the !rst column), row o"set (1 is 
the !rst row). If the o"set is just a number, it will count the o"set in the columns !rst

Reference: 
column number or column title , row number

Example: 
index (2 in 3,4..3,8) returns the 2nd cell in the range. This will be the cell in column 3, row 5.

index (4,2 in 2,5..9,9) returns the 4th column and 2nd row starting from column 2, row 5. 
This will be the value in column 5, row 6

INSTANCES
Will return all the instances in the timeline.

Format:
INSTANCES

Example:
length instances returns the total length of the instances in the timeline.
count instances returns the total number of instances in the timeline.
Use in conjunction with WHERE to select particular rows.

INSTANCES2

Will return all the instances in the timeline between the red markers.

Format:
INSTANCES2

Example:
length instances2 returns the total length of the instances in the timeline between the red 
markers. 

count “a” and instances2 returns the total number of instances with “a” in them between the red 
markers in the timeline.
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I
INSTANCE[x]

Will return the x’th instance in the timeline based on start times.

Format:
INSTANCE[index]

Arguments:
index: a number less than or greater than 0. if index is greater than 0 then it will count from the 
beginning. eg. 1 represents the !rst instance in the timeline, 2 the second instance etc. If index is 
less than 0 it will count from the end. eg. -1 represents the instance with the latest start time, -2 
the second latest start time etc.

Example:
length instance[2] returns the length of the second instance in the timeline.
length instance[-3] returns the length of the third last instance in the timeline.
If you wish to have more control then the LIMIT command should be used

LABEL

Will return a label in the timeline or row. If an instance has 3 matching labels it will return 3.

Format:
LABEL

Example: 

count label “Good” returns the total number of “Good” labels in the timeline.

Use in conjunction with WHERE to select particular rows.

count label “Rob” and “Good” where row = “Effort” returns the total number of “Rob” labels 
where “Good” was also found in the instance in the row named “E"ort”. 

count label “Good” and “Rob” where row = “Effort” returns the total number of “Good” labels 
where “Rob” was also found in the instance in the row named “E"ort”.

LABEL IN

Will return a label in the instances. If an instance has 3 labels it will return the instance 3 times.

Format:
LABEL string IN instances

Arguments:
string: a label name 
instances: any command that returns instances

Example:
show count label “a” in instances limit 1 returns the total number of labels in the 1st instance in 
the timeline with “a” in it.
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LABELS IN

Will return all the labels in the instances. If an instance has 3 labels it will return the instance 3 
times.

Format:
LABELS IN instances

Arguments:
instances: any command that returns instances

Example:
show count labels in instances limit 1,1 returns the total number of labels in the second instance 
in the timeline.

LABELS

Will return all the labels in the timeline. If an instance has 3 labels it will return the instance 3 
times.
Format:
LABELS
Example:
count labels returns the total number of labels in the timeline.
Use in conjunction with WHERE to select particular rows

LARGE

Finds the nth largest value in the cell group

Format:
LARGE ( reference .. reference RANKED ranking )

Arguments:
reference: column number or column title, row number or quoted text representing a cell title. 
ranking: a number representing the nth largest value. 1 being the largest.

Example:
large (2,1..4,3 ranked 2) returns the 2nd largest value of all cells between column 2, row 1 and 
column 4, row 3

large (“cell1”..”cell2” ranked 1 ) returns the largest value from all cells between cells with titles 
“cell1” and “cell2”

large (2,1..”column1”,4 ranked 3 ) returns the 3rd largest value of all cells between column 2, row 
1 and the column with the title “column1” on row 4

large ($column+1,$row..$column+2,$row+1 ranked 1) returns the largest value of all cells 1 
column right of current cell to 2 columns right, 1 row down
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LENGTH

Will give the length of labels in the timeline (including multiple ones in the same instance) in 
seconds

Format:
LENGTH labels

Arguments:
labels: quoted text specifying label you wish to get the length of in the front timeline or 
instances(which can be grouped using OR, AND, NOT) optional WHERE conditions
conditions: ROW = quoted text or ROW != quoted text (which can be grouped using OR, AND, 
NOT)

Example:
length “Outburst” returns the total length in seconds of all the “Outburst” labels in the front 
timeline
length “Outburst” and “Elated” where row = ”Miller” returns the total length of “Outburst” and 
“Elated” labels in the row “Miller”
length “Outburst” where row != ”Miller” returns the total length of “Outburst” labels which are 
not in row “Miller”
length “Outburst” where row != ”Miller” or row != ”Smith” returns the total length of Outburst 
labels in the front timeline which are not in row “Miller” or row “Smith”
show length instance[1] shows the length in seconds of the !rst instance in the timeline
instances(which can be grouped using OR, AND, NOT)

LIMIT

Will limit instances based on conditions that meet the criteria in the argument.

Format:
instances LIMIT o"set,select
instances LIMIT select

Arguments:
instances: quoted text specifying label you wish to count in the front timeline or instances(which 
can be grouped using OR, AND, NOT)
o"set: the o"set to start counting. eg. 1 = will skip the !rst instance etc. If o"set < 0 then will 
count from end. eg. -1=last instance. Can be left out if o"set is 0.
select: how many instances to select. If select < 0 it will select up to the end value (-1=last, 
-2=2nd last etc...)

Example:
instances limit 2 will grab the !rst 2 instances
instances limit 4,2 will o"set 4 instances and select the next 2. That makes it the 5th and 6th 
instance.
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instances limit 4,-1 will grab the 5th to the last instance.
instances limit -3,-2 will grab the 3rd and 2nd last instance.
length “a” or “b” where row = ”row 1” or row = ”row 2” limit 3,2 returns the total length of the 4th 
and 5th labels in the timeline with a or b in them and the row = ‘row 1’ or ‘row 2’

LOOKUP

Finds a match for a given value in the !rst range, and then returns the value in the cell with the 
same relative position in the second range. Ranges cannot overlap or be of di"erent sizes

Format:
LOOKUP ( value IN reference .. reference USING reference..reference )

Arguments:
reference: column number or column title, row number 
value: a number, string, or instances you want to search the !rst range with. A range is speci!ed 
by reference..reference

Example:
show lookup ( “w” in $column-2,1..$column-1,8 using $column-4,1..$column-3,8 ) shows the 
value in the cell 3 to 4 columns to the left of the current cell, if it !nds “w” in the cell 1 to 2 
columns to the left of the current cell 
lookup(cell “data” in “sorted”,1..”sorted”,8 using “rank”,1..”rank”,8 ) using the cell on the same row in 
column “data” search the column “sorted” and if it !nds it return the value from the column “rank” 
at the same row

OVERLAP

Will return instances from the given arguments that overlap for any part of the timeline. (This is 
opposite of the unique command.)
Format:
OVERLAP ( instances , instances )
Arguments:
instances: labels or instances
Example:
overlap (“label 1”,“labels 2”) returns all instances which have label 1 in them and overlap with any 
instance containing label2 in them. It will also return all instances which have label 2 in them 
and overlap with any instance containing label 1. It will also return instances with both labels in 
them but only once.
overlap (instances,instances) will return all the instances as every instance will overlap itself
overlap (instance[1], instance[2]) returns both the !rst and second instance in the timeline 
provided they overlap. Otherwise it will return nothing
show start overlap (“label 1” where row = ”row 1” ,”label 2” where row = ”row 2”) will show the 
start time of the !rst instance that overlaps where label 1 is in row 1 and label 2 is in row 2

RANK

Finds the rank of the value in the range.

Format:
RANK ( value IN reference..reference order)
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Arguments:
reference: column number or column title, row number 
value: a number to search reference..reference for 
order: LARGEST or SMALLEST depending on what you want the rank to represent. The value is 
optional and will default to LARGEST

Example:
rank (2 in 2,1..4,3 largest) returns the 2nd largest value of all cells between column 2, row 1 and 
column 4, row 3

rank ( 1, “column1”,1..”ccolumn1”,5 ) returns the largest value from all cells between row 1 and 5 
in column “column1”

rank ( 2, “column1”,4..”column2”,9 smallest ) returns the 2nd smallest value of all cells between 
“column1”, row 4 and “column2”, row 9.

SMALL

Finds the nth smallest value in the cell group

Format:
SMALL ( reference .. reference RANKED ranking )

Arguments:
reference: column number or column title, row number or quoted text representing a cell title 
ranking: a number representing the nth smallest value. 1 being the smallest.

Example:
small (2,1..4,3 ranked 2) returns the 2nd smallest value of all cells between column 2, row 1 and 
column 4, row 3

small (“cell1”..”cell2” ranked 1 ) returns the smallest value from all cells between cells with titles 
“cell1” and “cell2”

small (2,1..”column1”,4 ranked 3 ) returns the 3rd smallest value of all cells between column 2, 
row 1 and the column with the title “column1” on row 4

small ($column+1,$row..$column+2,$row+1 ranked 1) returns the smallest value of all cells 1 
column right of current cell to 2 columns right, 1 row down

START

Will give the earliest start time of the labels or instances in the timeline in seconds. It will return 
-1 if no instances are found.

Format:
START instances

Arguments:
instances: instances or quoted text specifying label you wish to get the earliest start time
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Example:
start “Outburst” returns the start time of the earliest instance which has the label “Outburst” in 
seconds
start “Outburst” and “Elateds” where row = ”Miller” returns the earliest start time of “Outburst” 
and “Elated” labels in the row “Miller”
start instances returns the start time of the !rst instance
show start instance[-1] shows the start time of the last instance (based on start time)

START TIME

Will return all instances that have the correct start time condition that meets the criteria in the 
argument.

Format:
instances WHERE START TIME operator value

Arguments:
instances: quoted text specifying label you wish to count in the front timeline or instances which 
can be grouped using OR, AND, NOT
operator: < <= > >= =
value: the start time you wish to test (in seconds)

Example:
count instances where start time < 20 will count the number of instances that have a start time 
in the !rst 20 seconds
count “a” or “b” where row = ”row1” and start time < 20 will count the instances that have “a” or “b” 
in them in row “row1” starting in the !rst 20 seconds
count instances where (start time <4 or end time >20) and time<4 will count all the instances 
which are smaller than 4 seconds, and have a start time in the !rst 4 seconds or an end time after 
the last 20 seconds.

TIME

Will return all instances that have the instance length condition that meets the criteria in the 
argument.

Format:
instances WHERE TIME operator value

Arguments:
instances: quoted text specifying label you wish to count in the front timeline or instances which 
can be grouped using OR, AND, NOT
operator: < <= > >= =
value: the instance length you wish to test (in seconds)

Example:
count instances where time < 20 will count the number of instances that are shorter than 20 
seconds in length
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count “a” or “b” where row = ”row1” and time < 20 will count the instances that have “a” or “b” in 
them in row “row1” and are shorter than 20 seconds
count instances where (start time <4 or end time >20) and time<4 will count all the instances 
which are smaller than 4 seconds, and have a start time in the !rst 4 seconds or an end time after 
the last 20 seconds.

TIMER

Converts the input in seconds to a timer string with a given precision

Format:
TIMER ( seconds , precision )

Arguments:
seconds: the time in seconds you wish to convert to hours:mins:seconds 
precision: the number of decimal places to show. A value <= 0 will show no decimal places

Example:
TIMER ( 3601.123,0 ) will return 1:00:01

TIMER ( 3601.123,2 ) will return 1:00:01.12

UNIQUE

Will return instances from the given arguments that do not overlap for any part of the timeline. 
(Opposite of the overlap command.)

Format:
UNIQUE ( instances , instances )

Arguments:
instances: labels or instances

Example:
unique (“label 1”,“labels 2”) returns all instances which have label1 in them and do not overlap 
with any instance containing label2 in them. It will also return all instances which have label2 in 
them and do not overlap with any instance containing label1
unique (instances,instances) will do nothing as there will be no unique instance as it will overlap 
with itself
unique (instance[1],instance[2]) returns both the !rst and second instance in the timeline 
provided they do not overlap. Otherwise it will return nothing
show start unique (“label 1” where row = ”row 1” ,”label 2” where row = ”row 2”) will show the 
start time of the !rst instance that does not overlap where label 1 is in row 1 and label 2 is in row 
2
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UNIQUE RANK

Finds the rank of the value in the range making sure it is unique

Format:
UNIQUE RANK ( value IN reference..reference UNIQUE reference..reference order)

Arguments:
reference: column number or column title, row number 
value: a number to search reference..reference for 
order: LARGEST or SMALLEST depending on what you want the rank to represent. The value is 
optional and will default to LARGEST

Example:
show unique rank( cell”points” in “points”,1..”points”,9 unique “position”,1..”position”, $row-1) 
Placing this script in all of the cells in “position” column between rows 2 and 9 will produce a 
ladder position based on points. It works because it does a normal RANK command and then 
checks the values above it. If it !nds there is another team on equal points it will return the next 
number not used in the unique range. The cell in row 1 of the “position” column would only need 
the RANK command.

WHERE

Will select certain instances based on conditions that meet the arguments.

Format:
labels WHERE conditions

Arguments:
labels: quoted text specifying label you wish to count in the front timeline or instances which 
can be grouped using OR, AND, NOT
conditions: ROW = quoted text or ROW != quoted text (which can be grouped using OR, AND, 
NOT)

Example:
count “a” or “b” where row = ”row 1” or row = ”row 2” returns the total number of labels in the 
timeline with a or b in them and the row = ‘row 1’ or ‘row 2’
count instances where row != ”row 1” returns the total number of instances in the timeline not 
counting those in ‘row 1’.
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Logical Commands...
Logical commands are used to create boolean operations in an expression to help narrow down 
speci!c searches and arguments.

AND
Used to combine arguments in order to specify a search more directly. If values are numbers: 
returns 1 if both values are not zero, otherwise returns 0. If using text then it is assumed that you 
are referring to labels and the return result will be instances from the timeline that contain both 
labels. “AND” is commonly used inside other commands (see IF, COUNT...) and can be combined 
with “OR” and “NOT”
Format:
labels AND labels
number AND number

Arguments:
labels: quoted text representing labels in the timeline
number: numerical expression

Example:
show count ”Handshape” and “Inaccurate” shows the number of instances with labels 
“Handshape” and “Inaccurate” in them
show count not (“a” or “b” and “c”) counts the number of instances that do not have “a” or have 
“b” and “c” as labels in them. AND will be calulated !rst before the OR as it has higher priority. Use 
brackets to force logic.

EXIT
Stops the rest of the cell from being executed

Format:
EXIT

Example:
if ($a<5,exit) if $a is less than 5 then stop executing the cell

FROM
Will get instances from speci!ed timelines. Not using this command will default to use front 
timeline

Format:
labels FROM timelines OR labels FROM ALL TIMELINES

Arguments:
labels: quoted text specifying label you wish to count in the front timeline or instances which 
can be grouped using OR, AND, NOT) timelines: A set of timeline names separated by  comma or 
the key words ALL TIMELINES

Example:
Show count “a” or “b” from “timeline1”,”timeline2” where row=”row 1” or row=”row 2” shows the 
total number of labels in “timeline1” and “timeline2” with a or b in them and the row = ‘row 1’ 
or ‘row 2’ count instances from all timelines where row!=”row 1” returns the total number of  
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instances from all open timelines not counting those in ‘row 1’
IF

Executes the statement based on a condition

Format:
IF (condition, true statement, false statement)
IF (condition,true statement)

Arguments:
condition: if this numeric value is 0 it is considered false and will execute the false statement 
otherwise any nonzero result is considered true and will execute the true statement. You can use 
any relational operators <,<=,>,>=,=,!= on numbers or quoted text and logical operators AND, 
OR, NOT on numbers. When an empty string is compared to a number with = or !=, the string 
will be consdiered as 0.
statement: any normal command including another “IF”

Example:
if (5<6, show “true”, show “false”) shows true. You can change the result by changing the 
condition to 6<5

$a = cell(1,0)
if ($a < 0, show “cell is negative”, show “cell is positive”)
Using a variable, this example shows whether cell in column 1, row 0 is positive or negative 
number

$a = cell(1,0)
if ($a != 0, show 5/$a, show “N/A”)
Again using a variable to set the cell location, this example shows 5 divided by the contents of 
cell in column 1, row 0. If that cell is 0 or blank then show “N/A”
if (“tom” < “tot” and 4<5, show “true”, show “false”) shows true
if (“tom” < “tot” and 6<5, show “true”) will do nothing as the condition is false and there is no 
false statement

NOT
Used to exclude criteria in arguments in order to specify a search more directly. If value is 
number: returns 1 if value is 0, otherwise returns 0. If using text then it is assumed that you 
are referring to labels and the return result will be instances from the timeline that do not 
contain the label. “NOT” is commonly used inside other commands (see IF, COUNT...) and can be 
combined with “AND” and “OR”

Format:
NOT labels
NOT number

Arguments:
labels: quoted text representing instances labels in the timeline
number: numerical expression
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Example:
$a = not “Inaccurate”
show count $a
This example shows the number of instances that do not have “Inaccurate” in them.
show count not (“a” or “b” and “c”) counts the number of instances that do not have “a” or have 
“b” and “c” as labels in them. AND will be calulated !rst before the OR as it has higher priority. Use 
brackets to force logic.

OR
Used to combine criteria in arguments in order to specify a search more directly.
If values are numbers: returns 1 if either value is not zero, otherwise returns 0. If using text 
then it is assumed that you are referring to labels and the return result will be instances from 
the timeline that contain either label. “OR” is commonly used inside other commands (see IF, 
COUNT...) and can be combined with “AND” and “NOT”

Format:
labels OR labels
number OR number

Arguments:
labels: quoted text representing labels in the timeline
number: numerical expression

Example:
$a = ”Handshape” or “Inaccurate”
show count $a
This example shows the number of instances with either “Handshape” or “Inaccurate” in them
show count not (“a” or “b” and “c”) counts the number of instances that do not have “a” or have 
“b” and “c” as labels in them. AND will be calulated !rst before the OR as it has higher priority. Use 
brackets to force logic.
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Numeric Commands
These commands perform numeric calculations. All standard mathematical functions +,-,*,/,(),^ can 
be used. eg. show 7+8

ABS
Returns the absolute value of a number.

Format:
ABS (number)

Arguments:
number: numerical expression

Example:
show abs(-5*2) returns 10.

CEILING
Returns a number which has the number rounded up to the speci!ed number of digits from the 
decimal point. If you need to display a certain number of digits after the decimal point use the 
decimal command.

Format:
FLOOR (number ,number of digits)

Arguments:
number: numerical expression
number of digits: if positive the number of digits to show at the right of the decimal point. If 
negative, the number of digits to the left of the decimal point starting at tens. If 0 no decimal 
placing will be left

Example:
show ceiling (34.23001, 2) returns 34.24
show ceiling (3423.456, -2) shows 3500
show decimal (ceiling(0.1,0) ,2) shows 1.00

DECIMAL
Returns a string which has the number to the speci!ed number of digits from the decimal point. 
The number is always rounded down.

Format:
DECIMAL (number ,number of digits)

Arguments:
number: numerical expression
number of digits: if positive the number of digits to show at the right of the decimal point. If 
negative, the number of digits to the left of the decimal point starting at tens. If 0 no decimal 
placing will be left.
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Example:
show decimal (34.235, 2) shows 34.23
show decimal (3423.456, -2) shows 3400
show decimal ( round(0.499,0) ,2) shows 0.00

FLOOR
Returns a number which has the number rounded down to the speci!ed number of digits from 
the decimal point. This is similar to the deimal command excepts that it returns a number and 
not a string. If you need to display a certain number of digits after the decimal point use the 
decimal command.

Format:
FLOOR (number ,number of digits)

Arguments:
number: numerical expression
number of digits: if positive the number of digits to show at the right of the decimal point. If 
negative the number of digits to the left of the decimal point starting at tens. If 0 no decimal 
placing will be left

Example:
show #oor (34.235, 2) returns 34.23
show #oor (3423.456, -2) shows 3400
show decimal (#oor(0.999,0) ,2) shows 0.00

ROUND
Returns a number which has the number rounded to the speci!ed number of digits from the 
decimal point. It will round up or down depending on which is the closest digit. If you need to 
display a certain number of digits after the decimal point use the decimal command.

Format:
ROUND (number ,number of digits)

Arguments:
number: numerical expression
number of digits: if positive the number of digits to show at the right of the decimal point. If 
negative the number of digits to the left of the decimal point starting at tens. If 0 no decimal 
placing will be left

Example:
show round (34.235, 2) returns 34.24
show round (3423.456, -2) returns 3400
show decimal (round(0.499,0) ,2) shows 0.00
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Statistical Commands
These commands perform statistical calculations performed on cell ranges.

SUM
Adds all the values in the cell group.

Format:
SUM ( reference .. reference )

Arguments:
reference: column number or column title, row number or quoted text representing a cell title.

Example:
sum (2,1..4,3) returns the sum of all cells between column 2, row 1 and column 4, row 3
sum (“cell1”..”cell2”) returns the sum of all cells between cells with titles “cell1” and “cell2”
sum (2,1..”column1”,4) returns the sum of all cells between column 2, row 1 and the column with 
the title “column1” on row 4
sum ($column+1,$row..$column+2,$row+1) returns the sum of all cells 1 column right of current 
cell to 2 columns right, 1 row down

Text Commands
These commands manipulate text. To join text you simply use the + operator.

Example:
Show “Hello.” + “How “ + “are you?” displays “Hello. How are you?” in the cell.
Show count “Outburst” + “ student outbursts” displays how many times “Outburst” is found, then 
followed by “ student outbursts. So, if there were 30 Outburst’s in the timeline, it would display 
“30  student outbursts” in the cell.

Variable Commands
Variables are speci!ed using the dollar sign and a name. eg. $message = “hello”. In that example 
$message holds the text “hello” which can be used later on in the script. Variables only hold their 
value for the cell in the statistical window. A variable can hold a number, text or even instances in the 
timeline. Numbers cannot be used as the !rst character after the $ sign.

Example:
$outbursts = count “Elated” or “Angry”
show $outburst
This will display the total count of “Elated” or “Angry” labels found in the front timeline. As the 
script gets larger and more complex, variables make it easier to make changes because the 
variable only has to be edited in one spot. It will not need to be changed in every part of the 
script where it is called.
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$COLUMN
Returns the column where the cell is located.

Format:
$COLUMN

Example:
show “My current column is “+$column will show a message what the column is for that cell in 
the statistical window.

$ROW
Returns the row where the cell is located.

Format:
$ROW

Example:
show “My current row is “+$row will show a message what the row is for that cell in the statistical 
window.

Output Commands
These commands will output or e"ect another parts of the program like buttons in the code window. 

BUTTON STATE
Returns 1 if button is down and 0 if button is up, in the code input window.

Format:
BUTTON button_name STATEOR 
BUTTON button_name STATE IN WINDOW window_name

Arguments:
button_name: a string with the name of a button in the code input window window_name: the 
name of the code input window

Example:
SHOW BUTTON “name1” STATE shows 0 or 1 depending on if the button is up or down

IF (BUTTON “name1” STATE IN WINDOW “window1”, SHOW “DOWN”, SHOW “UP”) show up/
down depending on if the button “name1” is up or down in the code input window with title 
“window1”



170

PUSH BUTTON
Pushes the button up/down in the code input window. If this is a label button then you only 
need to use DOWN.

Format:
PUSH BUTTON button_name DOWN
PUSH BUTTON button_name UP

Arguments:
button_name: a string with the name of a button in the code input window. The button name 
must be in quotes.

Example:
push button “Poor Behavior ” down pushes the button “Poor Behavior” down in the front code 
input window.

$elatedOutburst = count “Elated” where row = “Student”
$angryOutburst = count “Angry” where row = “Student”
If ($angryOutburst > $elatedOutburst, push button “Poor Behavior” down, push button “Poor 
Behavior” up)
This script uses an if statement, when the student’s Angry Outbursts are greater than their Elated 
Outbursts, the “Poor Behavior” button is pushed down and it starts to code the timeline. When 
the Elated Outbursts and Angry Outburts are equal or the Elated Outbursts are greater than 
Angry Outbursts it pushes the “Poor Behavior” button up and stops coding

SEND
Changes the output value of the button in the code window with that button name. In order 
to display output in a code button, the display output option must be checked in the button 
properties for that button.

Format:
SEND value TO BUTTON “button_name”

Arguments:
value: a string or a number
button_name: a string with the name of a button in the code window. The button name must be 
in quotes.

Example:
send 37.4 to button “Button 1” changes the output value displayed in “Button 1” button in the 
front code window to 37.4.

$outburst = count “Outburst”
send $outburst to button “Outburst”
This script changes the output value displayed in the “Outburst” button in the front code 
window to the variables $outburst value. $outburst counts the amount of “outbursts” found in 
the timeline.
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The SEND command can send output value to any type of button whether it is a code, text label, 
or title. Graphical buttons can display output too.

The font size of the output can be changed by selecting the 
size next to the display output check box in the edit button 
properties window. When the display output option is checked, 
a question mark will appear below the button name on the face 
of the button. It will change value when the statistical window 
scripts are executed.

Information rich code windows can be created and used 
during live capture and code. The code window can be printed and used as a report or in a 

presentation.

SEND BUTTON COLOR
Changes the background color of the button in the code window with that button name.

Format:
SEND BUTTON COLOR ( red_color , green_color , blue_color ) TO BUTTON button_name

Arguments:
color: a red, green or blue color value 0->100
button_name: a string with the name of a button in the code window

Example:
send button color (100,0,0) to button “Teacher” changes the background color of “Teacher” in the 
front code window to red.

if ($a < 1, send button color (0,100,0) to button “Teacher”, send button color (100,100,100) to 
button “O"ense”)
If $a < 1 then the button will be green otherwise it will be white.

SEND TEXT COLOR
Changes the text color of the button in the code window with that button name.

Format:
SEND TEXT COLOR ( red_color , green_color , blue_color ) TO BUTTON button_name
Arguments:
color: a red, green or blue color value 0->100
button_name: a string with the name of a button in the code window
Example:
send text color (100,0,0) to button “Teacher” changes the text color of “Teacher” in the front code 
input window to red.

if ($a < 1, send text color (0,100,0) to button “Teacher”, send text color (0,0,100) to button 
“Teacher”)
If $a < 1 then the button’s text color will be green otherwise it will be blue.
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Exporting Data Files

Timeline data can be easily exported and used in other applications such as Excel and Final Cut Pro.

Export an Edit List

An edit list generates a complete list of events in play order. It creates a tab delimited !le that is 
easy to manipulate in a spreadsheet editor like Excel. Using the edit list data, graphs, functions and 
macros can create some very informative reports.

The export is simple to perform. Open a timeline and choose File > Export > XML edit list... The !le 
that is exported will likely have an excel icon and can be opened by Excel immediately. Since this is a 
tab delimited !le, it can also be opened by many simple text editors or can be used as a data source 
for other work#ows. 

The export will appear like this in Excel.

For more information, see the Import section of this manual. There is a more in depth explanation of 
the data structure of the !le. Also, see the Export Preferences section, this !le type can be exported 
during capture and coding.

Export an XML Edit List

Like the Edit List, the XML edit list generates a list of events in play order, but in an XML structure. 
The XML edit list is generally used for transferring timeline information from timeline to timeline. 
However, since it is common !le structure, it can be used in hundreds of ways.

To export an XML edit list, open a timeline with coded data and choose File > Export > XML edit list...
The !le will contain all the descriptions of the instances including: start and end times, row names 
and colors, label groupings, text labels, and instance notes. A !le will look this in a simple text editor.

<!le> 
<ALL_INSTANCES> 
<instance> 
<ID>1</ID> 
<start>279.5398520953</start> 
<end>616.7625308135</end> 
<code>Alexis Proctor</code> 
<label> 
<text>Great Work</text> 
</label> 
<label> 
<group>E"ort</group> 
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<text>Solid</text> 
</label> 
<free_text>Excellent example of good footwork.</free_text> 
</instance> 
</ALL_INSTANCES> 
<ROWS> 
<row> 
<code>Alexis Proctor</code> 
<R>64083</R> 
<G>65535</G> 
<B>23454</B> 
</row> 
</ROWS> 
</!le>

For more information, see the Import section of this manual. There is a more in depth explanation of 
the data structure of the !le. Also, see the Export Preferences section, this !le type can be exported 
during capture and coding.

Export Transcript Text File

Using the transcript text !le export will create a tab delimited text !le based on the data in the 
transcription window. This export only works if a transcription window is selected and will export all 
the transcribed rows in the transcription window, separating each column by a tab character.

To use, open an existing transcription window with data, choose File > Export > Transcript text !le... 
Name and choose the location to save the !le.

This format is very common when dealing with transcriptions. A tab delimited !le can be easily 
imported into most spreadsheet programs like Microsoft Excel or other third party applications.

The !rst column is the time stamp for the start of the instance or utterance, the second column is 
code name or speaker, the third column is the text or utterance itself and the remaining columns are 
used for labels or notes.

Here is an example:
00:00:03:84 Matilda Alexis, quit taking all my toys! Angry 
00:00:49:97 Alexis These are my toys, I had them !rst! Upset 
00:01:25:85 Matilda No, you did not! Fired up 

Export Transcriber XML File

This export generates a Transcriber 1.5.1 compatible XML !le from a transcription window. The 
format is very speci!c to this open-source project. To learn more about Transcriber, visit the o$cial 
website. At the time of this writing, the website is http://trans.sourceforge.net/en/presentation.php.
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Instance Frequency Reports

While one of the most basic exports, the instance frequency report is a very e"ective gauge for 
!nding percentages and overall lengths of coded instance rows. It also shows instance count and 
calculates mean time. The export can be quickly viewed in an Output window or saved to an Excel 
!le. 

The following is a  simple example on how to use this export.
1. Open a timeline with some coded instances, the more the better.
2. Select some speci!c rows or a range of rows in the timeline.
3. Choose File > Export Instance frequency report...
4. Set the Summary statistics window to use Selected rows. If no rows are selected in the timeline, 

this option will be dimmed out.

5. Set the Send output to: option to Output window.
6. Press OK.
The results show a quick summary of each of the selected rows from the timeline. This export while 
very simple is really quite powerful if the instances are accurately coded. 
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This feature allows you to view:
• The number of times each code was used in the timeline.
• How much time those actions took. 
• The percentage of the total time those codes were used in relationship to full length of the 

movie. 
• The mean time of the instances in each row.

Using the Send output to Excel option, graphs and other meaningful calculations can be done very 
quickly. This is a truly powerful little feature.

Export Final Cut XML

The Final Cut XML export creates a XML !le with instance information that can be imported into 
Final Cut Pro 6.0 or greater.

To use this export, select some instances in a timeline, choose File > Export > Final Cut XML... There 
are two export type options in the save dialog at the bottom: Clips & Markers.

The Clips option will export each instance as a clip in the project bin. So, each instance will be row in 
the clip bin and treated individually.

Markers is the other option. The instance movie start and end times will be imported into Final 
Cut as Markers to the timeline movie. Instance information such as labels is included in the marker 
making it convenient to see data about the marker. See the Final Cut documentation for more 
information.

Both formats of the !le that is created will have all the clip information including row, instance 
number and transcription information. The row name and instance number will appear as the name 
of the clip or marker in Final Cut. The timeline !le name will appear in the master comment 1 section 
of the bin and the transcription notes will appear in the clip comment section of the bin.

Note: The XML !le references the movie data which is likely a reference movie, moving the source movies 
will disconnect the media and the clips will have to be relinked in Final Cut. There are some situations 
that can cause Final Cut troubles when resolving the movie references that are based on other movie 
references and so on. It is best to try not have a lot of movie references built on top of each other. The 
closer the source movie is in the data referenced in the XML !le, the better the chances everything will 
work consistently.
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Converting Movies

Any movie can be converted to another format using the convert movies features in this 
software. If Studiocode can view the file, it can be converted in some way to another format 
using this system.
The standard format for captured movies is DV. The DV format creates very large files, 
approximately 13.8GB of hard disc storage per hour of video. These files will fill up an internal 
hard disk very quickly. To save space, we recommend converting the files into an alternate 
format. Follow these instructions for a simple and fast method of converting any movie to a 
MPEG-4 format that is suitable for coding, editing, analysis, and presentation.
NOTE: Converting is commonly referred to as compressing since the purpose in most cases is 
to reduce (compress) the size of the file. Converting the movie creates a stand alone movie.

1.Open an instance movie from a timeline that has a video linked to it. Set the video window 
size to half of its natural size. So, if your 
video is 720x480, set the movie size to 
360x240.
2. Choose Convert movie from the 

File > Export >Movies menu in the 
main menu bar. This opens the Save 
exported file as... window where you 
can set-up all the options for the 
conversion.

3. Choose Movie to Quicktime Movie 
from the Export drop down menu in 
the window. Then, press the Options 
button to configure the specific movie 
conversion settings. The Movie Settings 
window will open and the Video, Audio, 
and Internet settings can be changed.

4. In the Video area of the Movie Settings 
window, click on the Settings button. 
The Standard Video Compressor Settings 
window will open. In this window, 
configure the following: Frame Rate = 
Current Key Frames = All Compressor 
Quality = Medium Data Rate = Automatic

NOTE: Frame rate will be the same as 
the original. Every frame will be a key 
frame which converts a file that can be 
easily edited. Compressor quality at 
medium and the data rate at automatic 
will produce an acceptable movie where 
the algorithm will determine how to best 
convert the movie from various frame 
samples from the entire movie.
5. Click OK to save the settings.
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 Next, configure the Audio settings.

6. In the Audio area of the Movie Settings window, click 
on the Settings button. This will open the Sound 
Settings window.

7.  Set the Format to AAC, the Channels to Stereo (L R), 
the Rate to 48,000khz, Render Settings to Normal, 
and Target Bit Rate to 128kbps.

NOTE: These audio settings will create a CD quality 
audio track in the converted movie. If audio is not 
important, uncheck this option in the Movie Settings 
window and no audio will be exported. This will make 
the resulting !le smaller, but when  compared to video 
tracks, audio tracks are extremely small in size. So, in the 
long run, not choosing to use audio saves negligible 
hard disk space.

8. The last area in the Movie Settings window are the 
internet streaming options. If you are going to use 
the movie to stream from a !le server on the internet, 
then you should select the appropriate settings as 
de!ned by the host of the server. For this example, 
uncheck Prepare for Internet Streaming options. For 
general use these settings should be turned o".

9.  With the Video and Audio check boxes checked and 
the Prepare for Internet Streaming unchecked click 
the OK button in the Movie Settings window.

10.  In the Save exported file as window, type in a 
name and target location to export the file.

11.  Click OK to start the conversion process.

After the conversion is complete, these settings will 
be saved as the default settings. So, in most cases, 
they do not need to be set up again.

Permanent custom options in the movie format drop 
down menu can be con!gured for individual users. 
Contact Sportstec for help doing do this
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This movie conversion example is very basic and does not fully explore all the options that are 
available. This is a very complex topic and for the purposes of this manual, we will not offer an 
explanation for every compressor and its various options.

Using the settings described, you will likely find varying results over time. Some movies will 
be smaller in file size even though they are similar in length. Other times you will see quality 
differences in two similar movies. Because each movie is different in shot, composition and 
length, you will have varying results when translated by the compressor’s algorithm automatic 
settings. But using automatic settings is a good way to start understanding how to convert 
movies.

Here are a few tips to experiment and find what will work for you best for your particular 
purpose.
1.  Use a short instance to experiment with different settings. Waiting for long conversions is 

tedious and you will not always get the desired results.
2.  Set the frame size of the movie first. In most situations, 360x240 NTSC or 360x288 PAL is 

the right frame size to use. Studiocode will use the instance movies window size for the 
conversion size. There is a great difference in time to convert a movie that is twice that frame 
size.

3.  If file size is most important, try setting manual data rates. This will guarantee the file size 
and forces the conversion to use the same amount of data per frame. Start with 6400 kbps. 
Automatic settings will find the best data rate which can vary greatly from movie to movie.

4.  Try using different compressors. Use H.264 or Sorenson Video to convert a small clip and 
compare the results. Some compressors are better for different types of video. MPEG-4, 
H.264 and Sorenson are popular compressors, so sharing these formats will be compatible 
with any system running Quicktime 7.0 or greater.

5.  Adjusting the key frame intervals can make a big difference when video quality and size 
are concerned. Try setting the keyframes to 25 instead of all or 1 frame. Key frame settings 
greater than one every frame creates movies that will not be suitable for coding, editing, 
and slow motion analysis. Spreading out the key frame intervals, is recommended when the 
video will be distributed for playback only via internet or email.

6.  Video acquisition is probably the most important aspect to converting movies. If the video 
is poor quality to begin with, converting it will not make it better. Try to get the best copy 
of the video possible or get proper training on how to use your camera. Fast panning or 
zooming can cause conversion results to look very pixelated. To achieve the best results, 
avoid quick camera motions.

Drag and Drop Reference Movies
A quick and easy way to create reference movies for batch converting is to drag from the 
video in the movie window and drop onto the desktop. This will create a movie clipping 
on the desktop. As you drag and drop, rename the movies, so you don’t forget what 
video is in each one. Remember to select the segment of the movie in the instance movie 
timeline for which you want to create a movie clipping.
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Direct Movie Exports

Beyond the standard Convert Movie export, there are 4 direct movie export features found in the 
File > Export > Movies menu. To export a movie using one of these options, create an instance movie 
and select the export from the menu. The export will automatically take place. Each of these direct 
exports do not have any customizable options.

iPhone movie to iTunes

This export converts the instance movie to an iPod ready format and sends it to the iTunes library. 
Depending on the iTunes preferences, it could be added to the library or be copied into the library.

AppleTV movie to Desktop

If you use an Apple TV device, this export will create an Apple TV ready !le that can be synchronized 
to the device. When chosen, the !le will be automatically exported to the desktop. This export also 
produces very high quality video.

Selected instances by row to iPhone movie to iTunes

Upon export, each row will be exported as an individual movie with the selected instances in time 
sequence, selection order cannot be used. The movie name will be the row name. Once the export is 
complete the movies are sent to the iTunes library.

A trick to using this feature, is to duplicate rows and change their names, the movie will take the 
name of row and will appear nicely organized in iTunes. Another clever way of using this feature is to 
make new timeline rows from label columns in the matrix.

Flatten movie

The #atten movie export is used when you wish to have the overlay text burned into the movie. The 
overlay text is a SportsCode feature only and will not be recognized by any other editors or players. 
Use this feature when creating content that will be distributed to an audience that do not have 
SportsCode or if you want to use it in a DVD project or other editing software.

The movie is compressed using the identical codec of the source movie. Some codecs will work 
better than others when rendering the text. It is possible that when using MPEG-4 or H.264, the text 
may not look as good as the original.

Convert movie package...

A movie package can be easily converted to another format using the convert movie package... 
feature. The feature creates a copy of the package with the timeline !le included, converts all the 
movie parts in package into the new format, creates a new reference movie for the timeline based on 
the newly formatted !les and links this movie to the timeline.
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To use this feature, open an existing timeline to be converted, choose File > Export > Convert movie 
package..., set the desired compression settings and name plus location for the new package.

An additional option to this, is to have the process #atten the movie once the export is complete. 
This will create a single !le from all the movie parts inside the package. It is recommended to do this 
as it makes the package void of !le references. A de!nite plus in terms of !le portability, also it allows 
the !le to be extracted from the package and directly uploaded to Sportstec Stream or used more 
easily in some other work#ow.

When the options are set and the Save button is pressed, the export movie window will appear.

Each movie part in the package will be converted until all are converted. The export will continue 
converting all the parts in the package until it is !nished or the application is quitted. If the 
application is quitted while there are still movie parts left to convert it will start up again when the 
original movie package is opened again. Once the export is complete, a movie package with same 
will be found in the same folder as the original capture.

An export can be paused, cancelled or deleted anytime. To pause press the pause icon in the row to 
the right of the progress bar. To cancel press the x icon to the right of the progress bar. To delete a 
row in the queue, select the row and press DELETE on the keyboard.

The export window supports multiple items in the list. It is based on a !rst in !rst out queuing 
system. To add more items to the queue during capture, say for converting multiple packages over 
night, open a timeline package, select the timeline window, then choose File > Export > Movies > 
Convert movie package..., select the movie format and destination and add it to the queue. All items 
in the queue will be handled when the previous item above it in the queue is completed. This is 
especially useful for archiving and hard disk space saving purposes.
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Create an Edit List

An Edit list provides you with a complete list of events in play order. Edit lists are great for creating 
customized reports in Excel. Using Excels graphs, functions and macros you can create some very 
informative reports from the timeline data.

1. Open a timeline with the data to be 
exported.

2. Choose Edit list from the File > Export menu 
in the main menu bar.

2. Save the Edit list to a !le name related to the 
performance you are analysing and choose a 
target location for the !le.

3. Click on Save.

To Copy a Movie Frame to Output

If you want to take a movie frame and transfer it to another application such as Word or PowerPoint, 
!nd the frame of video you want to use in a movie window, Choose Copy movie frame to output 
from the Analysis menu in the main menu bar. The frame/picture you’ve selected will be copied to 
the output Window. You can now drag a box around the picture and copy it to the clipboard, from 
there you can paste it into another application or print it.

Text Window

The text window is a simple text editor. It is commonly used as a notepad or paste board. A clever 
way to use the window is as a paste board. Movie frames can be copied from an instance movie and 
pasted in this window where they can be collected, then later pasted into another application like 

Word. The text window can be saved just like any other text document.

Mac OS X Snapshot Features
Here are some shortcuts built in Mac OS X for creating snapshots of the screen or specific 
windows.
SHIFT+COMMAND+3 will save a picture of the screen to the desktop.
SHIFT+CONTROL+COMMAND+3 will turn the mouse cursor into cross hairs where you can 
click and drag a selector on the image you want to take a snapshot of. It saves the image 
as picture on the desktop.
SHIFT+COMMAND+4 will save a picture of the screen to memory, so it can be pasted into 
another open window.
SHIFT+CONTROL+COMMAND+4 will turn the mouse cursor into cross hairs where you can 
click and drag a selector on the image you want to take a snapshot of. It saves the image 
to memory, so it can be pasted into another open window.
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CODA
CODA allows you to code without the video. You can code 
during a live event and use the data for statistical reports 
and analysis; or code from pre-recorded material – even 
DVDs.  You can then export the coded data to Studiocode 
for your video review and more detailed analysis. CODA 
gives you the ability to increase your coverage at minimum 
costs.

iCODA 
Designed as the perfect complement to CODA for 
portability, iCODA runs on iPhone, iPod Touch and iPad for 
truly mobile data capture. Code anywhere, any place then 
download your data to CODA to analyse what you have 
captured, and even ,(by transfering the !le to Studiocode,) 
link your coding to video.

STREAM
Video streaming has never been easier than with 
SportsCode Stream! Developed initially for sports and 
built on a secure, reliable foundation, SportsCode Stream 
empowers Tutors, Students and Research Collegues to 
view and analyse video clips across the internet.

EXCHANGE
Sportstec Exchange is a video sharing and management 
platform that is accessible online, meaning you can use it 
anytime, any place.  Exchange cuts through the problems 
of conventional video sharing by creating an online library 
for you and your collegues to upload, download and 
request video through.
 

www.studiocodegroup.com



CRONUS
Information is only truely powerful when it can be collected, 
managed, manipulated and shared.  Cronus is a powerful tool 
for knowledge and information management to give your 
team a competitive edge.
 

www.studiocodegroup.com
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